Bug 128104 - macOS: Spell checker dialog in Writer does not accept non-US keyboard entries, e.g., äöü
Summary: macOS: Spell checker dialog in Writer does not accept non-US keyboard entries...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.5.0 target:6.4.0.1 target:6.3.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Spell-Checking-Dialog
  Show dependency treegraph
 
Reported: 2019-10-12 11:21 UTC by HTK300
Modified: 2020-01-26 08:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
error when zipping the profile (14.67 KB, image/png)
2019-10-13 19:07 UTC, HTK300
Details
user profile dialog for resetting to default (83.57 KB, image/png)
2019-10-13 19:10 UTC, HTK300
Details
querty vs quertz (53.18 KB, image/png)
2019-10-13 19:11 UTC, HTK300
Details
user profile (29.25 KB, image/png)
2019-10-13 19:12 UTC, HTK300
Details
change Keyboard type (90.29 KB, image/png)
2019-10-13 20:49 UTC, HTK300
Details

Note You need to log in before you can comment on or make changes to this bug.
Description HTK300 2019-10-12 11:21:14 UTC
Description:
even I selectet the text to be spell-checked in German language, then when I browse through the phases that contain misspellings, I may not be able to enter the single letter for ss, which is the ß or even Umlaut oe ö, ae ä, ue ü.


Steps to Reproduce:
1. select a German text
2. open spelling check
3. browse through the typos
4. try to enter a German character
5. even the german dictionary is being indicated at top, checking works, but entering German letters is impossible

Actual Results:
I cannot enter German letters in the Spell checking frame

Expected Results:
as in previous versions, I should be able to enter German letters 


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter 2019-10-13 12:34:41 UTC
I can't confirm it with

Version: 6.3.2.2 (x64)
Build-ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

Perhaps it's MAC only. But to be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile (https://wiki.documentfoundation.org/UserProfile) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the issue is still present
Comment 2 HTK300 2019-10-13 19:07:00 UTC
Created attachment 154970 [details]
error when zipping the profile

when archiving user profile, this error was shown
Comment 3 HTK300 2019-10-13 19:10:12 UTC
Created attachment 154971 [details]
user profile dialog for resetting to default

user profile dialog for resetting to default
Comment 4 HTK300 2019-10-13 19:11:00 UTC
Created attachment 154972 [details]
querty vs quertz

querty vs quertz
Comment 5 HTK300 2019-10-13 19:12:29 UTC
Created attachment 154973 [details]
user profile

user profile
Comment 6 HTK300 2019-10-13 19:22:22 UTC
Hello,

yes it is a MAC problem as I ticked the corresponding checkmark! On windows 8.1 it works well on my side, too.

The point is, even the German input language is being indicated by the drop-down menu, the fact is that the US keyboard layout is active.



I typed the keys on the keyboard laid over the asdf fingers, and the US keys appeard as with the qwerty, but qwertz should have been shown, it means the UMLAUT cannot be shown typing the key to the left from the letter L

I am running a macOS HighSierra 10.13.6


when I changed the input language to Russian, the LO crashed repeadedly.
Comment 7 HTK300 2019-10-13 20:44:24 UTC
just found out that on a MAC LibreOffice 6.2.5 works well with the Spelling window entering German characters is possible.

Yet, there might be some relationship to recognizing the keyboard of mz MacBook Pro when I insert a USB dongle from a wireless mouse. Go to the Apple System preferences an then hit the keyboard symbol. The fist tab says Keyboard.

To the left of the Button [Modifier Keys] shere should appear the button [Change Keyboard Type]. Once you open that, the procedure will start to recognize your keboard being a japanese or a US Ascii 101 or anything else. This feature might be relevant with the initial problem described not being able to enter German characters into the spelling checker window, even the German input language in the drop down menu is selected.

best regards,
Harry
Comment 8 HTK300 2019-10-13 20:49:13 UTC
Created attachment 154979 [details]
change Keyboard type

change Keyboard type in Apple's System Setting > Keyboard
Comment 9 eisa01 2019-11-02 23:28:04 UTC
I can replicate this.

1. Open any document with text
2. Select non-US keyboard layout
3. Open Tools->Spelling...
4. Type in the window, it will use the US keyboard layout, e.g., æøå doesn't work on Norwegian keyboard layout

Not present on LO 3.3

Version: 6.4.0.0.alpha1+
Build ID: 80109586e6cb6d3e2e0a53a9079c3125ec9b8368
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 10 Xisco Faulí 2019-11-14 12:34:53 UTC
I can reproduce it with a spanish layout using they key ñ

Regression from

https://cgit.freedesktop.org/libreoffice/core/commit/?id=243b5b392906042ab03800e0b5765e6f3513372c

author	Caolán McNamara <caolanm@redhat.com>	2019-06-14 21:56:44 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2019-06-22 19:28:38 +0200
commit	243b5b392906042ab03800e0b5765e6f3513372c (patch)
tree	d82300c65829578bddbb34e37e0fb08ac544d9aa
parent	01cd1d68d96057624db38b9baaa6c6795353758d (diff)
weld SpellDialog

Bisected with: bibisect-mac64-6.3

Adding Cc: to Caolán McNamara
Comment 11 Caolán McNamara 2019-11-14 15:24:33 UTC
Does the same problem occur for drawing textboxes ? i.e. in writer, insert->shape->basic shapes->rectangle and type into that.
Comment 12 Caolán McNamara 2019-11-14 15:51:30 UTC
nevermind I think I know what the problem is
Comment 13 Commit Notification 2019-11-14 20:15:22 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/556d4f458d92745a8f95ecb12fefa76e68cb9251

tdf#128104 Input Engine events are delivered via Command

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2019-11-14 20:16:55 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/e54b0467422e8871600ae93b953a0770dc27e785

tdf#128104 Input Engine events are delivered via Command

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Caolán McNamara 2019-11-15 10:21:53 UTC
that should work in master and 6-4 with backports to 6-3 in gerrit
Comment 16 Xisco Faulí 2019-11-18 09:09:35 UTC
Verified in

Version: 6.4.0.0.beta1+
Build ID: c2097477e3a43d75c170a6f7a5daf5dcb2169329
CPU threads: 8; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-US (en_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!
Comment 17 Commit Notification 2019-11-18 12:21:58 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/070bb33d301daeb8767d31847c0eeaa19165d761

Resolves: tdf#128104 Input Engine events are delivered via Command

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2019-11-18 16:37:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/9a21a3295c57f5692c5cf9b14f7342138a38e3db

Related: tdf#128104 extend popup handler to cover all CommandEvents

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 HTK300 2019-12-07 17:33:05 UTC
all of the earlier mentioned applies to LO 6.4.0.0 beta1 on macOS
Comment 20 HTK300 2019-12-07 17:58:53 UTC
Just tested LO Writer 6.3.4.1 and the feature is working now. 
Non-US characters are selectable in the spell checking window.



(In reply to Commit Notification from comment #18)
> Caolán McNamara committed a patch related to this issue.
> It has been pushed to "libreoffice-6-3":
> 
> https://git.libreoffice.org/core/commit/
> 9a21a3295c57f5692c5cf9b14f7342138a38e3db
> 
> Related: tdf#128104 extend popup handler to cover all CommandEvents
> 
> It will be available in 6.3.4.
> 
> The patch should be included in the daily builds available at
> https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> https://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.
Comment 21 HTK300 2019-12-07 18:07:02 UTC
Hi, 
I am afraid, about an hour ago I tested this spell checking window trying to enter German letters (Umlaute), it still did not work with LO Writer 6.4.0.0 beta1
 
I am on macOS 10.13 High Sierra

For LO 6.4.3 however, this test went fine, it was working there.

Harry


(In reply to Xisco Faulí from comment #16)
> Verified in
> 
> Version: 6.4.0.0.beta1+
> Build ID: c2097477e3a43d75c170a6f7a5daf5dcb2169329
> CPU threads: 8; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
> Locale: en-US (en_ES.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> @Caolán, thanks for fixing this issue!
Comment 22 HTK300 2019-12-07 18:09:05 UTC
sorry, 
LO 6.3.4 is the Version I was talking about, earlier.
Comment 23 Caolán McNamara 2020-01-11 20:41:41 UTC
I imagine this is working fine now, just a matter or builds not available with the fix in it at the time