Download it now!
Bug 129620 - Crash when I press down arrow in edit header dialog using e.g, Japanese keyboard
Summary: Crash when I press down arrow in edit header dialog using e.g, Japanese keyboard
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All Mac OS X (All)
: high critical
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2019-12-26 01:32 UTC by ted bug
Modified: 2020-05-25 08:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screen capture of the crash (3.92 MB, video/quicktime)
2020-02-17 23:27 UTC, ted bug
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ted bug 2019-12-26 01:32:26 UTC
Description:
1. new spreadsheet
2. format, page, header, edit
3. press down arrow on keyboard
4. document crashed
5. recovery dialog appeared, changes are lost.

Steps to Reproduce:
1. new spreadsheet
2. format, page, header, edit
3. press down arrow on keyboard
4. document crashed
5. recovery dialog appeared, changes are lost.

Actual Results:
4. document crashed
5. recovery dialog appeared, changes are lost.

Expected Results:
nothing happens, no crash


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.3.4.2
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-AU (en_AU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-12-26 08:46:17 UTC
I can't reproduce it in

Versión: 6.3.4.2 (x86)
Id. de compilación: 60da17e045e08f1793c57c00ba83cdfce946d0aa
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 2 ted bug 2019-12-27 22:08:39 UTC
It's still happening in safe mode, and in a new blank profile.

Might be a macos specific bug for the 6.4.3.2?

Not happening in the stable older version
Version: 6.2.8.2
Build ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-AU (en_AU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Oliver Grimm 2019-12-28 23:41:23 UTC
cannot reproduce here in

Version: 6.3.4.2.0+
Build-ID: 1:6.3.4-2
CPU-Threads: 2; BS: Linux 5.3; UI-Render: Standard; VCL: kde5; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded
Comment 4 Roman Kuznetsov 2020-01-08 13:23:44 UTC
don't repro in

Версия: 6.3.3.2
ID сборки: a64200df03143b798afd1ec74a12ab50359878ed
Потоков ЦП: 4; ОС:Mac OS X 10.15.2; Отрисовка ИП: по умолчанию; VCL: osx; 
Локаль: ru-RU (ru_RU.UTF-8); Язык интерфейса: ru-RU
Calc: threaded

nor in

Версия: 6.4.0.0.beta1
ID сборки: 4d7e5b0c40ed843384704eca3ce21981d4e98920
Потоков ЦП: 4; ОС:Mac OS X 10.15.2; Отрисовка ИП: GL; VCL: osx; 
Локаль: ru-RU (ru_RU.UTF-8); Язык интерфейса: ru-RU
Calc: threaded

nor in

Version: 6.5.0.0.alpha0+
Build ID: e22a3f596ce50b5166063e217d96ef674a54d380
CPU threads: 4; OS: Mac OS X 10.15.2; UI render: GL; VCL: osx; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2020-02-17 15:24:43 UTC
Hello ted,
Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 6 ted bug 2020-02-17 23:27:34 UTC
Created attachment 157963 [details]
screen capture of the crash

Still happening in 
Version: 7.0.0.0.alpha0+
Build ID: 4caa7b790cf99eebbe47fc2e6a56124c42f1f3fc
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-AU (en_AU.UTF-8); UI-Language: en-US
Calc: threaded
Macbook 12 inch early 2015
Comment 7 Xisco Faulí 2020-02-18 16:14:45 UTC
mac only ?
Comment 8 Ahmad Haris 2020-02-19 02:54:31 UTC
I can't reproduce this both in stable and master.

Version: 6.3.4.2
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 8; OS: Mac OS X 10.15.3; UI render: GL; VCL: osx; 
Locale: en-ID (en_ID.UTF-8); UI-Language: en-US
Calc: threaded

Version: 7.0.0.0.alpha0+
Build ID: 15c0f22c31a46ce37e98f9394e6a8e0bc92495f9
CPU threads: 8; OS: Mac OS X 10.15.3; UI render: default; VCL: osx; 
Locale: en-ID (en_ID.UTF-8); UI-Language: en-US
Calc: threaded
Comment 9 Whatnao 2020-02-22 17:53:25 UTC
6.3.4.2. on Mac OS 10.14.6
Similar problem. I go to insert -> headers and footers
Try to type in the dialogue, hitting any key would crash.
Tried on safe mode, and still happens.
Comment 10 Ash-f 2020-03-03 23:35:31 UTC
I can reproduce this problem when I use Apple Japanese IME.

MacOS High Sierra 10.13.6
LibreOffice 6.4.1.2
Comment 11 NAMIKAWA Seiji 2020-03-05 10:33:05 UTC
I have a similar problem.
Crash when selecting a Japanese input source and entering any key in the header and footer dialogs.
No crash when selecting U.S. input source.

Reproduce in the following environment.

Version: 6.4.1.2
Build ID: 4d224e95b98b138af42a64d84056446d09082932
CPU threads: 4; OS: Mac OS X 10.13.6; UI render: default; VCL: osx; 
Locale: ja-JP (en_JP.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.4.1.2
Build ID: 4d224e95b98b138af42a64d84056446d09082932
CPU threads: 4; OS: Mac OS X 10.15.4 Beta(19E242d); UI render: default; VCL: osx; 
Locale: ja-JP (ja_JP.UTF-8); UI-Language: en-US
Calc: threaded

Does not reproduce in the following environment.

Version: 6.3.1.2
Build ID: b79626edf0065ac373bd1df5c28bd630b4424273
CPU threads: 4; OS: Mac OS X 10.15.4 Beta(19E242d); UI render: default; VCL: osx; 
Locale: ja-JP (ja_JP.UTF-8); UI-Language: en-US
Calc: threaded
Comment 12 Xisco Faulí 2020-04-06 15:07:24 UTC
Not reproduced in

Version: 7.0.0.0.alpha0+
Build ID: 6c7d51643634a4a4111f673760567e10e48467d0
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: ja-JP (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 13 Marctoo 2020-04-08 00:14:00 UTC
Not reproducible both on stable and master versions

Version: 6.4.2.2 (x64)
Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: CL 


Version: 7.0.0.0.alpha0+ (x86)
Build ID: 7c5d207c6adaafa8c4f6fe90e3389c7fdaadc800
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: CL
Comment 14 eisa01 2020-05-02 19:30:19 UTC
I can reproduce this, and it has been reproduced by three other commenters besides the original bug reporter

Insert-> Header and footer
Click after text on "Sheet1" in center area
Press arrow key down -> Crash of document

It only happens if I choose e.g., Katakana as input method, not e.g., Norwegian

Not present in LO 3.3, and this is a regression since 6.2.8 according to comment #2

As this is a regression and a crash, setting priority to highest critical

Version: 6.4.3.5
Build ID: 4db9852e73d9e9d662fc8a2783bace79addf1805
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 15 Xisco Faulí 2020-05-14 18:34:09 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=556d4f458d92745a8f95ecb12fefa76e68cb9251

Author	Caolán McNamara <caolanm@redhat.com>	2019-11-14 16:01:53 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-11-14 21:14:33 +0100
commit	556d4f458d92745a8f95ecb12fefa76e68cb9251 (patch)
tree	2032c9d6d8e0ad65a0c8c358e96eaa8a998ad352
parent	746fb9401af4178d4d227783026bed9aa2f398ac (diff)
tdf#128104 Input Engine events are delivered via Command

Bisected with: bibisect-mac64-6.5

Adding Cc: to Caolán McNamara

Adjusting importance a bit
Comment 16 Commit Notification 2020-05-18 13:49:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d6fce28dea6e1e51ec5de88ef17cc56180b8c2db

Resolves: tdf#129620 crash because there is no associated window

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Caolán McNamara 2020-05-18 13:50:02 UTC
fixed in master, backport to 6-4 in gerrit
Comment 18 ted bug 2020-05-21 04:40:38 UTC
tested and confirmed it is not crashing anymore with english keyboard or other input method (japanese, korean, chinese)
but new minor bug is introduced:
there is no keyboard cursor in the active text area, even though typing is fine.

reopen or submit a new bug?

Version: 7.0.0.0.alpha1+
Build ID: 442c7b95e2ee94b66a9854d0cb22f8ecb76532c6
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded
Comment 19 Caolán McNamara 2020-05-21 07:56:51 UTC
don't reopen because its not the bug reported
Comment 20 Commit Notification 2020-05-25 08:28:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/f6b3f97759be00e382e482512fb89f3d777e8e06

Resolves: tdf#129620 crash because there is no associated window

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.