Download it now!
Bug 128126 - TRANSLATION: DATEDIF (Date difference) calc function translated as SIFECHA, can leads to mistake, FECHADIF looks more accurated
Summary: TRANSLATION: DATEDIF (Date difference) calc function translated as SIFECHA, c...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All All
: medium normal
Assignee: Adolfo Jayme
URL: https://help.libreoffice.org/7.0/es/t...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-13 22:42 UTC by m.a.riosv
Modified: 2020-05-12 03:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2019-10-13 22:42:34 UTC
Description:
DATEDIF (Date difference) calc function translated as SIFECHA, can leads to mistake, FECHADIF looks more accurated

Actual Results:
.

Expected Results:
.


Reproducible: Always


User Profile Reset: No



Additional Info:
.
Comment 1 Xisco Faulí 2020-05-11 08:26:17 UTC
Hello Miguel Angel , is this issue still reproducible in master ?
Comment 2 m.a.riosv 2020-05-11 08:30:43 UTC
Yes.
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 97a2c1fc5e376c0c00968f17a0392c6d3a5ed565
Subprocs. CPU: 4; SO: Windows 10.0 Build 19608; Repres. IU: Skia/rej. píx.; VCL: win; Locale: es-ES (es_ES); Idioma de IU: es-ES Calc: threaded
Comment 3 Xisco Faulí 2020-05-11 08:36:52 UTC
is it then a translation issue? Who should fix it, translators ? I have no idea to be honest
Comment 4 m.a.riosv 2020-05-11 08:44:28 UTC
I guess translator, could fix, if it is fine for them.
Comment 5 Julien Nabet 2020-05-11 09:12:07 UTC
git grepping SIFECHA in "translations/source/es" gives this:
formula/messages.po:827:msgstr "SIFECHA"
helpcontent2/source/text/scalc/01.po:56447:msgstr "SIFECHA"
helpcontent2/source/text/scalc/01.po:56456:msgstr "<bookmark_value>función SIFECHA</bookmark_value>"
helpcontent2/source/text/scalc/01.po:56465:msgstr "<variable id=\"datedif\"><link href=\"text/scalc/01/func_datedif.xhp\">SIFECHA</link></variable>"
helpcontent2/source/text/scalc/01.po:56483:msgstr "SIFECHA(Fecha inicial; Fecha final; Intervalo)"
helpcontent2/source/text/scalc/01.po:56600:msgstr "<item type=\"input\">=SIFECHA(\"1974-04-17\";\"2012-06-13\";\"y\")</item> devuelve 38."
helpcontent2/source/text/scalc/01.po:56609:msgstr "<item type=\"input\">=SIFECHA(\"1974-04-17\";\"2012-06-13\";\"ym\")</item> devuelve 1."
helpcontent2/source/text/scalc/01.po:56618:msgstr "<item type=\"input\">=SIFECHA(\"1974-04-17\";\"2012-06-13\";\"md\")</item> devuelve 27."
helpcontent2/source/text/scalc/01.po:56636:msgstr "<item type=\"input\">=SIFECHA(FECHA(1974,4,17);\"2012-06-13\";\"m\")</item> devuelve 457: ha vivido 457 meses."
helpcontent2/source/text/scalc/01.po:56645:msgstr "<item type=\"input\">=SIFECHA(\"1974-04-17\";\"2012-06-13\";\"d\")</item> devuelve 13937: ha vivido 13 937 días."
helpcontent2/source/text/scalc/01.po:56654:msgstr "<item type=\"input\">=SIFECHA(\"1974-04-17\";FECHA(2012;06;13);\"yd\")</item> devuelve 57: su cumpleaños acaeció hace 57 días."

Adolfo: I can do it but are you ok for the change "SIFECHA" -> "FECHADIF"

Also, I see these for "Guarani (Paraguayan)(gug)", should I make the change for this language too?
Comment 6 Adolfo Jayme 2020-05-11 11:22:55 UTC
I don’t invent the names. The Spanish team purposely uses the same translations as Microsoft Excel to facilitate migration. And DATEDIF is “SIFECHA” in Spanish-language Excel. I don’t like it either, but we’re stuck with it ¯\_(ツ)_/¯
Comment 7 Adolfo Jayme 2020-05-11 11:37:54 UTC
To expand a little further—

Citation from Sánchez, C. (2008), Excel 2007: Guía de funciones. Argentina: USERS/Gradi, S.A., p. 86 (translation from Spanish mine):

“[The SIFECHA] function is so little-known that even its name is the product of a misunderstanding. The English name is DATEDIF, difference between dates. But whomever translated Excel into Spanish just looked at the ‘IF’ at the end (‘si’ in Spanish), and thus termed the function like so.”

https://books.google.com/books?id=9mqg1CZRLdsC&pg=PA86
Comment 8 Julien Nabet 2020-05-11 11:48:39 UTC
As usual, if it was just me, I would do the change because I don't consider Excel bug compatibility a priority, rather a plague.
Anyway, I added this here:
https://wiki.documentfoundation.org/Development/stuck_stuff
Comment 9 m.a.riosv 2020-05-11 12:21:19 UTC
(In reply to Adolfo Jayme from comment #7)
> To expand a little further—
> 
> Citation from Sánchez, C. (2008), Excel 2007: Guía de funciones. Argentina:
> USERS/Gradi, S.A., p. 86 (translation from Spanish mine):
> 
> “[The SIFECHA] function is so little-known that even its name is the product
> of a misunderstanding. The English name is DATEDIF, difference between
> dates. But whomever translated Excel into Spanish just looked at the ‘IF’ at
> the end (‘si’ in Spanish), and thus termed the function like so.”
> 
> https://books.google.com/books?id=9mqg1CZRLdsC&pg=PA86

Here we are with another msoffice bug mantained on LibreOffice for compatibility purposes.

As there are several SI (IF) functions, only can leads to mistakes or not being found/used while it can be. Looks like a function to verify the value is a date.

I think a little explanation would be nice in the help, to make it easier to find the function in Spanish.
Comment 10 Adolfo Jayme 2020-05-11 12:32:49 UTC
Good idea; I wrote some notes here: https://translations.documentfoundation.org/translate/libo_help-master/textscalc01/es/?&offset=6273#history

Thanks Miguel Ángel for your report, and Julien for adding the compatibility note.

Yes, sometimes we must decide whether we want LibreOffice to be “bug-free” or “bug-compatible”. I err to the latter side when in comes to users who migrate to our solution.
Comment 11 Julien Nabet 2020-05-11 12:36:53 UTC
(In reply to Adolfo Jayme from comment #10)
> ...
> Yes, sometimes we must decide whether we want LibreOffice to be “bug-free”
> or “bug-compatible”. I err to the latter side when in comes to users who
> migrate to our solution.

There may be also people who don't expect same bugs as Excel but I'm not naive, I suppose majority of users badfully expect compatibility with Excel.
For them, I'd just tell them: stick to Excel and pay for it but don't complain about LO for trying to make sense here instead of blindly copycat Excel bugs.