Bug Hunting Session
Bug 128177 - Inserting "Bibliography Entry..." leads to crash on iOS
Summary: Inserting "Bibliography Entry..." leads to crash on iOS
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: iOS (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other iOS
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-16 11:21 UTC by Nicolas Christener
Modified: 2019-10-18 18:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Initial attempt at patch, did not yet help, saved here for potential future reference (1.72 KB, patch)
2019-10-16 12:06 UTC, Tor Lillqvist
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Christener 2019-10-16 11:21:09 UTC
Description:
The function to insert a "bibliography entry" leads to a crash of the iOS app.

This can be triggered on an empty document, I don't think further conditions are relevant (I use the "Empty (A4)"-template from the stock templates on iOS 13, if more details are needed I'm happy to provide them).

Steps to Reproduce:
1. Open a writer document using the iOS app
2. Tap on menu "Insert > Table of Contents and Index > Bibliography..."

Actual Results:
The app crashes.

Expected Results:
The app should not crash, a bibliography entry should be added.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Tor Lillqvist 2019-10-16 11:43:20 UTC
That menu entry seems to invoke a UNO component that is not built for iOS. I am investigating whether it could be built, or whether it would then drag in other stuff that is not built either. The bibliography functionality is to some (unclear yet) extent married to the database functionality, and we don't provide Base in the mobile app.
Comment 2 Tor Lillqvist 2019-10-16 11:45:45 UTC
In case this bibliography functionality would require building lots of stuff that so far has not been built for iOS, like the Firebird database engine which might be hard to build for iOS, would it be OK to simply not have that menu entry in the iOS app?
Comment 3 Nicolas Christener 2019-10-16 12:00:28 UTC
We have no need for that feature at the moment. It's perfectly fine if you just remove the menu item.

I hit the button accidentaly while presenting and found it out that way - not because we need the feature :)
Comment 4 Tor Lillqvist 2019-10-16 12:03:55 UTC
OK, good, dropping it then for iOS.
Comment 5 Tor Lillqvist 2019-10-16 12:06:19 UTC
Created attachment 155038 [details]
Initial attempt at patch, did not yet help, saved here for potential future reference

The crash is preceded by the warning "Uncaught com.sun.star.uno.DeploymentException component context fails to supply service com.sun.star.frame.Bibliography of type com.sun.star.container.XNameAccess".
Comment 6 Tor Lillqvist 2019-10-16 12:33:28 UTC
Fix in https://gerrit.libreoffice.org/#/c/80889/
Comment 7 Commit Notification 2019-10-16 12:47:58 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/online/commit/21b587dea261a6654eb84e4c008aa163b36469c7

tdf#128177: Drop the 'Bibliography Entry...' menu entry in a mobile app
Comment 8 Nicolas Christener 2019-10-18 18:53:15 UTC
Fixed. I tested with 4.1.67 and I can't reproduce the issue anymore.

I think this issue can be closed.

Thanks a lot to the Collabora team and especially Tor for fixing this issue!