Bug 128235 - build pdfium: No rule to make target
Summary: build pdfium: No rule to make target
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
(earliest affected)
Hardware: All All
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2019-10-18 16:44 UTC by David L. Craig
Modified: 2019-10-22 08:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description David L. Craig 2019-10-18 16:44:24 UTC
What built for doesn't for
Gets message "[...] \
target    '[...]tarballs/pdfium-3794.tar.bz2', \
needed by '[...]libreoffice-'."

Builds with '--disable-pdfium' specified.

This problem is encountered when the local script tracing modifications (autogen.sh, configure.frontend) are not involved.

This problem is not encountered by the maintainer of the CRUX libreoffice port on a different computer (with neither the configure.ac.patch (Bug 128189) (/usr/bin is not the last directory in his PATH) nor the tracing mods, but with the other patches and same autogen.sh parameters except it adds --enable-kde5 and --enable-gtk3-kde5).

Steps to Reproduce:
1. Run standard CRUX (GNU/Linux ports-based build-from-source distro) port update  for libreoffice

Actual Results:
[build XSL] CustomTarget/officecfg/registry/officecfg/ucb/Store.hxx
make[1]: *** No rule to make target '/usr/ports/work/libreoffice/src/tarballs/pdfium-3794.tar.bz2', needed by '/usr/ports/work/libreoffice/src/libreoffice-'.  Stop.
make[1]: *** Waiting for unfinished jobs....
make: *** [Makefile:274: build] Error 2

Expected Results:
The install script completes normally as it did for (Note patch for Bug 128189 was needed and installed for as well, since qmake-qt5 is in /usr/bin which is the last directory in PATH).

Reproducible: Always

User Profile Reset: No

Additional Info:
Localized Pkgfile file sourced by pkgmk bash script for installing the libreoffice port:
# Description: LibreOffice is a powerful office suite
# URL: https://www.libreoffice.org/
# Localized: to trace configure processing and fix build problems by David L. Craig, dlc dot usa at gmail dot com
# Maintainer: Tim Biermann, tbier at posteo dot de
# Depends on: clucene coin-or-mp fakeroot fontforge gpgme graphite2 gtk3 harfbuzz-icu hyphen libabw libcdr libcmis libe-book libepubgen libetonyek libexttextcat libfreehand libmspub libmwaw libmythes libnumbertext libodfgen liborcus libpagemaker libqxp libstaroffice libtommath libvisio libwpg libwps libzmf lpsolve mysql neon paper python3-lxml redland sane unzip xmlsec zip
# Optional: cups gst-plugins-base kio qt5 valgrind vlc


unpack_source() {
  for file in ${source[@]}; do
    case ${file##*/} in
        bsdtar -p -o -C $SRC -xf $(get_filename $file) ;;
        mkdir $SRC/tarballs || true
        cp $(get_filename $file) $SRC/tarballs ;;
        mkdir $SRC/tarballs || true
        cp $(get_filename $file) $SRC/tarballs ;;
        cp $(get_filename $file) $SRC ;;

build() {
  cd $name-$version

  # 20191017 dlcusa -- Fix test == operands and qmake-qt5,moc-qt5 location bugs
  patch -Np0 -i ../configure.ac.patch

  patch -Np0 -i ../makefile.in.patch
  patch -Np1 -i ../fix_mdds-orcus.patch

  # 20191017 dlcusa -- dropped ### lines below via configure.ac.patch above.
  #                    The insertion of the set -xv line is still performed
  #                    outside the patch because that is local only (not
  #                    part of the patch sent to the Document Foundation)
  # log the diffs between the original autogen.sh and tweaked version into
  #   authgen.sh.diffs
  # replace the autogen.sh script with a modified version that,
  # in the perl code section,
  #   inserted before the "exec ./configure" and the print that precedes it
  #     a system call to cp -p configure configure.new so configure.new has
  #       the same permissions as configure
  #     a system call to echo the shebang > configure.new truncating the file
  #     a system call to echo 'set -xv'  >> configure.new appending the file
  #     a system call to use gawk to
  #         append everything in configure after its first line to configure.new
  ###       but
  ###         editing all lines matching /test.*==/ to change all occurances of
  ###           "==" to "=" to remediate test command defects and
  ###         editing /^as_dummy="$QT5DIR/$PATH "$/
  ###                 /^as_dummy="`dirname $qt5_libdir`/bin:$QT5DIR/bin:$PATH "/
  ###           to elide those trailing spaces for PATH that are the causes of
  ###             /usr/bin/qmake-qt5 not being found
  ###         to remediate all defects discovered in configure
  #     a system call to show the diffs between configure and configure.new into
  #       file configure.diffs
  #     a system call to move configure to configure.orig
  #     a system call to move configure.new to configure
  #   edited the "exec ./configure" and the print that precedes it to change all
  #     occurrances of "./configure" to "./configure.frontend" 
  # add new script configure.frontend that:
  #   sets up set -xv tracing,
  #   redirects stdout and stderr to configure.log,
  #   reports CRUX and shell infrastructure condition, and then
  #   execs ./configure "$@" while passing the redirected stdout and stderr
  # in order to further debug the strange errors ./configure incurs on host able
  # Be sure pkgmk has -kw specified to be able to examine the configure.log afterwards
  set +e
  diff -u autogen.sh ../autogen.sh > autogen.sh.diffs 2>&1
  set -e
  mv autogen.sh autogen.sh.orig
  cp -p ../autogen.sh .
  cp -p ../configure.frontend .

  find -L . \
     \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
     -o -perm 511 \) -exec chmod 755 {} \; -o \
     \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
     -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

  # determine configure options based on installed packages on the system
  [[ -e /usr/lib/ccache ]] && PATH="$(echo ${PATH} | awk -v RS=: -v ORS=: '/ccache/ {next} {print}' | sed 's/:*$//')"
  [[ -e /usr/lib/ccache ]] && PKGMK_LIBREOFFICE+=" --enable-ccache" || PKGMK_LIBREOFFICE+=" --disable-ccache"
  [[ -e /usr/lib/cups ]] && PKGMK_LIBREOFFICE+=" --enable-cups" || PKGMK_LIBREOFFICE+=" --disable-cups"
  [[ -e /usr/lib/pkgconfig/gstreamer-plugins-base-1.0.pc ]] && PKGMK_LIBREOFFICE+=" --enable-gstreamer-1-0" || PKGMK_LIBREOFFICE+=" --disable-gstreamer-1-0"
  [[ -e /usr/lib/pkgconfig/Qt5Core.pc ]] && PKGMK_LIBREOFFICE+=" --enable-qt5" || PKGMK_LIBREOFFICE+=" --disable-qt5"
  [[ -e /usr/share/kf5/ ]] && PKGMK_LIBREOFFICE+=" --enable-kde5 --enable-gtk3-kde5"
  [[ -e /usr/share/vlc ]] && PKGMK_LIBREOFFICE+=" --enable-vlc" || PKGMK_LIBREOFFICE+=" --disable-vlc" # experimental vlc av backend
  [[ -e /usr/lib/pkgconfig/valgrind.pc ]] && PKGMK_LIBREOFFICE+=" --with-valgrind"

  local build_date=$(date +%Y%m%d)
  # 20191015 dlcusa -- hold off on this fix unless we eventually see it is still needed:
  # 20191017 dlcusa -- The pdfium problem from still aflicts, so add it back:
  # 20191017 dlcusa -- Since updated, now let's troubleshoot this new pdfium bug using rel 2
  #                    First rerun its release 1 configuration to capture the configure.log file;
  #                    then, subsequent runs will be the release 2 configuration for the enabled
  #                    pdfium capturing configure.log into the *-2*.configure.log file.
  # --disable-pdfium \ # moved here to not interfere with the autogen.sh command's continuation chain.
  ./autogen.sh $PKGMK_LIBREOFFICE \
    --with-parallelism=${JOBS-1} \
    --prefix=/usr \
    --with-external-tar="$SRC/tarballs" \
    --enable-{build-opensymbol,dbus,firebird-sdbc=no,gtk3,introspection=yes,release-build,odk,openssl,python=system} \
    --with-{lang="",package-format=archive,myspell-dicts,parallelism} \
    --with-build-version="$name-$version" \
    --with-extra-buildid="$(crux | awk '{ print $1 " " $3 }') ${build_date}" \
    --with-package-version="$version" \
    --with-system-{headers,libs} \
    --with-external-dict-dir=/usr/share/hunspell \
    --with-external-hyph-dir=/usr/share/hypen \
    --with-external-thes-dir=/usr/share/mythes \
    --without-{doxygen,fonts,gssapi,help,helppack-integration,java,system-firebird} \
    --disable-{avahi,build-unowinreg,dconf,dependency-tracking,extension-update,fetch-external} \

  # Note: root needs to prepare /var/CRUX/lo6331-${release}.configure.log for write by pkgmk before
  #       running this build (chown pkgmk:root , chmod 664)
  cp -p configure.log /var/CRUX/lo6331-${release}.configure.log
  # The following is no longer true--configure should now be remediated--libreoffice should build
  ### This is only a test of configure--even if it worked, we need proceed no further
  ##echo "autogen.sh completed with status $? -- now halt the test"
  ##exit 1

  touch {sources.ver,src.downloaded}
  echo "lo_sources_ver=${version}" > sources.ver
  make build-nocheck

  pushd workdir/installation/LibreOffice/archive/install/en-US
  tar xf *.tar.gz

  make DESTDIR=$PKG distro-pack-install

  install -dm755 $PKG/usr/etc/libreoffice
  install -m644 $PKG/usr/lib/libreoffice/program/{bootstraprc,sofficerc} \
  install -m644 $PKG/usr/lib/libreoffice/share/psprint/psprint.conf \

  # install dummy links to make them found by lo
  cd $PKG/usr/lib/libreoffice/program/
  ln -vsrf $PKG/usr/etc/libreoffice/{bootstraprc,sofficerc} .

  # cleanup
  rm -r $PKG/usr/share/libreoffice/sdk
  rm -r $PKG/usr/lib/libreoffice/sdk
  rm -r $PKG/usr/share/doc
  find $PKG -iname "*readme*" -exec rm -fr '{}' \+
Contents of src directory:
-rwxr-xr-x   1 pkgmk nobody  11K Oct 18 08:15 autogen.sh
-rw-r--r--   1 pkgmk nobody 3.1K Oct 18 08:15 configure.ac.patch
-rwxr-xr--   1 pkgmk nobody 2.6K Oct 18 08:15 configure.frontend
-rw-r--r--   1 pkgmk nobody  21K Oct 18 08:15 fix_mdds-orcus.patch
drwxr-xr-x 152 pkgmk nobody 4.2K Oct 18 08:16 libreoffice-
-rw-r--r--   1 pkgmk nobody 1.5K Oct 18 08:15 makefile.in.patch
drwxr-xr-x   2 pkgmk nobody   80 Oct 18 08:15 tarballs
Contents of src/tarballs directory:
# ls -lh /usr/ports/work/libreoffice/src/tarballs
total 108K
-rw-r--r-- 1 pkgmk nobody 95K Oct 18 08:15 0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz
-rw-r--r-- 1 pkgmk nobody 12K Oct 18 08:15 185d60944ea767075d27247c3162b3bc-unowinreg.dll
Build log:
=======> Building '/usr/ports/dlc-local/libreoffice/libreoffice#'.
mkdir: cannot create directory '/usr/ports/work/libreoffice/src/tarballs': File exists
+ build
+ cd libreoffice-
+ patch -Np0 -i ../configure.ac.patch
patching file configure.ac
+ patch -Np0 -i ../makefile.in.patch
patching file Makefile.in
Hunk #3 succeeded at 260 (offset -4 lines).
+ patch -Np1 -i ../fix_mdds-orcus.patch
patching file RepositoryExternal.mk
patching file configure.ac
Hunk #1 succeeded at 9258 (offset -33 lines).
Hunk #2 succeeded at 9564 (offset -33 lines).
patching file external/liborcus/0001-Prevent-unsigned-integer-underflow.patch
patching file external/liborcus/ExternalPackage_liborcus.mk
patching file external/liborcus/ExternalProject_liborcus.mk
patching file external/liborcus/Library_orcus-parser.mk
patching file external/liborcus/Library_orcus.mk
patching file external/liborcus/UnpackedTarball_liborcus.mk
patching file external/liborcus/version.patch.0
patching file sc/inc/mtvelements.hxx
patching file sc/inc/orcusxml.hxx
Hunk #1 succeeded at 70 (offset 1 line).
patching file sc/qa/unit/dataproviders_test.cxx
patching file sc/source/core/tool/scmatrix.cxx
patching file sc/source/filter/inc/orcusinterface.hxx
patching file sc/source/filter/orcus/interface.cxx
patching file sc/source/filter/orcus/orcusfiltersimpl.cxx
patching file sc/source/filter/orcus/xmlcontext.cxx
patching file sc/source/ui/xmlsource/xmlsourcedlg.cxx
Hunk #1 succeeded at 536 (offset 3 lines).
patching file svl/source/misc/gridprinter.cxx
+ set +e
+ diff -u autogen.sh ../autogen.sh
+ set -e
+ mv autogen.sh autogen.sh.orig
+ cp -p ../autogen.sh .
+ cp -p ../configure.frontend .
+ find -L . '(' -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 ')' -exec chmod 755 '{}' ';' -o '(' -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 ')' -exec chmod 644 '{}' ';'
+ [[ -e /usr/lib/ccache ]]
++ echo /var/CRUX/bin:/_/_/bin:/sbin:/bin:/usr/sbin:/usr/bin
++ awk -v RS=: -v ORS=: '/ccache/ {next} {print}'
++ sed 's/:*$//'
+ PATH=/var/CRUX/bin:/_/_/bin:/sbin:/bin:/usr/sbin:/usr/bin
+ [[ -e /usr/lib/ccache ]]
+ PKGMK_LIBREOFFICE+=' --enable-ccache'
+ [[ -e /usr/lib/cups ]]
+ PKGMK_LIBREOFFICE+=' --enable-cups'
+ [[ -e /usr/lib/pkgconfig/gstreamer-plugins-base-1.0.pc ]]
+ PKGMK_LIBREOFFICE+=' --enable-gstreamer-1-0'
+ [[ -e /usr/lib/pkgconfig/Qt5Core.pc ]]
+ PKGMK_LIBREOFFICE+=' --enable-qt5'
+ [[ -e /usr/share/kf5/ ]]
+ [[ -e /usr/share/vlc ]]
+ PKGMK_LIBREOFFICE+=' --disable-vlc'
+ [[ -e /usr/lib/pkgconfig/valgrind.pc ]]
++ date +%Y%m%d
+ local build_date=20191018
++ crux
++ awk '{ print $1 " " $3 }'
+ ./autogen.sh --enable-ccache --enable-cups --enable-gstreamer-1-0 --enable-qt5 --disable-vlc --with-parallelism=4 --prefix=/usr --with-external-tar=/usr/ports/work/libreoffice/src/tarballs --enable-build-opensymbol --enable-dbus --enable-firebird-sdbc=no --enable-gtk3 --enable-introspection=yes --enable-release-build --enable-odk --enable-openssl --enable-python=system --with-lang= --with-package-format=archive --with-myspell-dicts --with-parallelism --with-build-version=libreoffice- '--with-extra-buildid=CRUX 3.5 20191018' --with-package-version= --with-system-headers --with-system-libs --with-external-dict-dir=/usr/share/hunspell --with-external-hyph-dir=/usr/share/hypen --with-external-thes-dir=/usr/share/mythes --without-doxygen --without-fonts --without-gssapi --without-help --without-helppack-integration --without-java --without-system-firebird --disable-avahi --disable-build-unowinreg --disable-dconf --disable-dependency-tracking --disable-extension-update --disable-fetch-external --disable-firebird-sdbc --disable-gstreamer-0-10 --disable-gtk --disable-postgresql-sdbc --disable-report-builder --disable-sdremote-bluetooth --disable-werror
Editing ./configure to insert set -xv after shebang and fix test == prob and PATH trailing space prob
Running ./configure.frontend with '--enable-ccache --enable-cups --enable-gstreamer-1-0 --enable-qt5 --disable-vlc --with-parallelism=4 --prefix=/usr --with-external-tar=/usr/ports/work/libreoffice/src/tarballs --enable-build-opensymbol --enable-dbus --enable-firebird-sdbc=no --enable-gtk3 --enable-introspection=yes --enable-release-build --enable-odk --enable-openssl --enable-python=system --with-lang= --with-package-format=archive --with-myspell-dicts --with-parallelism --with-build-version=libreoffice- --with-extra-buildid=CRUX 3.5 20191018 --with-package-version= --with-system-headers --with-system-libs --with-external-dict-dir=/usr/share/hunspell --with-external-hyph-dir=/usr/share/hypen --with-external-thes-dir=/usr/share/mythes --without-doxygen --without-fonts --without-gssapi --without-help --without-helppack-integration --without-java --without-system-firebird --disable-avahi --disable-build-unowinreg --disable-dconf --disable-dependency-tracking --disable-extension-update --disable-fetch-external --disable-firebird-sdbc --disable-gstreamer-0-10 --disable-gtk --disable-postgresql-sdbc --disable-report-builder --disable-sdremote-bluetooth --disable-werror --srcdir=/usr/ports/work/libreoffice/src/libreoffice- --enable-option-checking=fatal'
# Redirect this process' stdout and stderr to truncated configure.log:
exec 1>configure.log 2>&1
+ exec
+ cp -p configure.log /var/CRUX/lo6331-2.configure.log
+ touch sources.ver src.downloaded
+ echo lo_sources_ver=
+ make build-nocheck
mkdir -p /usr/ports/work/libreoffice/src/libreoffice-
Automatic fetching of external tarballs is disabled.
/usr/ports/work/libreoffice/src/libreoffice- -a /usr/ports/work/libreoffice/src/libreoffice- -c
make -j 4  -rs -f /usr/ports/work/libreoffice/src/libreoffice-  build  
make[1]: warning: -jN forced in submake: disabling jobserver mode.
[build YAC] unoidl/source/sourceprovider-parser
[build LEX] unoidl/source/sourceprovider-scanner
/usr/ports/work/libreoffice/src/libreoffice- warning: deprecated directive, use '%define api.pure' [-Wdeprecated]
   13 | %pure-parser
      | ^~~~~~~~~~~~
[build CAT] officecfg_qa_allheaders.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Inet.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Interaction.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/LDAP.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Accelerators.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Addons.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/BasicIDE.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Calc.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/CalcAddIns.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Canvas.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Chart.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Commands.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Common.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Compatibility.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/DataAccess.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/DataAccess/Drivers.hxx
/usr/ports/work/libreoffice/src/libreoffice- warning: fix-its can be applied.  Rerun with option '--update'. [-Wother]
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Draw.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Embedding.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Events.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/ExtendedColorScheme.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/ExtensionDependencies.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/ExtensionManager.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/FormWizard.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Histories.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Impress.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Java.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Jobs.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Labels.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Linguistic.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Logging.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Math.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/OptionsDialog.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Paths.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/PresentationMinimizer.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/PresenterScreen.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/ProtocolHandler.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Recovery.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/ReportDesign.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Scripting.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Security.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/TabBrowse.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/TableWizard.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/TypeDetection.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/BaseWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/BasicIDECommands.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/BasicIDEWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/BibliographyCommands.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/BibliographyWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/CalcCommands.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/CalcWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/Category.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/ChartCommands.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/ChartWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/Commands.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/Controller.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/DbBrowserWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/DbQueryWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/DbRelationWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/DbReportWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/DbTableDataWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/DbTableWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/DbuCommands.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/DrawImpressCommands.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/DrawWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/Effects.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/Factories.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/GenericCategories.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/GenericCommands.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/GlobalSettings.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/ImpressWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/MathCommands.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/MathWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/ReportCommands.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/Sidebar.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/StartModuleCommands.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/StartModuleWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/ToolbarMode.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/WindowContentFactories.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/WindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/WriterCommands.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/WriterFormWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/WriterGlobalWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/WriterReportWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/WriterWebWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/WriterWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/UI/XFormsWindowState.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Update.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Views.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/Writer.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Office/WriterWeb.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/Setup.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/System.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/TypeDetection/Filter.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/TypeDetection/GraphicFilter.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/TypeDetection/Misc.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/TypeDetection/Types.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/TypeDetection/UISort.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/UserProfile.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/VCL.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/ucb/Configuration.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/ucb/Hierarchy.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/ucb/InteractionHandler.hxx
[build XSL] CustomTarget/officecfg/registry/officecfg/ucb/Store.hxx
make[1]: *** No rule to make target '/usr/ports/work/libreoffice/src/tarballs/pdfium-3794.tar.bz2', needed by '/usr/ports/work/libreoffice/src/libreoffice-'.  Stop.
make[1]: *** Waiting for unfinished jobs....
make: *** [Makefile:274: build] Error 2
=======> ERROR: Building '/usr/ports/dlc-local/libreoffice/libreoffice#' failed.
Comment 1 Julien Nabet 2019-10-18 17:27:49 UTC
David: did you try ping devs on LO Dev IRC or dev mailing list?

Miklos: thought you might be interested in this one since it concerns pdfium.
Comment 2 David L. Craig 2019-10-18 17:31:57 UTC
No, I did not.  I haven't done much libreoffice bug chasing so far.
Comment 3 Julien Nabet 2019-10-18 17:35:54 UTC
(In reply to David L. Craig from comment #2)
> No, I did not.  I haven't done much libreoffice bug chasing so far.

No pb, it was just for information and to complete it:
from https://wiki.documentfoundation.org/Development
"If you need help getting started, contact us:

    via IRC #libreoffice-dev connect via webchat on Freenode
    via email to the mailing list
(There are links on quoted url)
Comment 4 David L. Craig 2019-10-18 17:40:37 UTC
I'm not getting started.  ;-)  I've used LO at least a decade, and it has Just Worked. was the first release I've ever had to troubleshoot.
Comment 5 Julien Nabet 2019-10-18 18:00:52 UTC
(In reply to David L. Craig from comment #4)
> I'm not getting started.  ;-)  I've used LO at least a decade, and it has
> Just Worked. was the first release I've ever had to troubleshoot.

I had indeed hesitated to remove this part since I supposed you weren't a beginner but thought it wasn't worth it :-)

BTW, now you've submitted your license agreement, if you have another patch to propose, I can submit it!
Of course, it'd be better you do the extra step to subscribe gerrit in order to be autonomous :-) (see https://wiki.documentfoundation.org/Development/gerrit).
I would lie to you if I'd tell it's gonna take 2 mins, but surely it's not an hour!
Comment 6 David L. Craig 2019-10-18 18:10:13 UTC
If I can identify to cause of this, I might do that.  But I'm hoping someone with a good handle on this part of the install code will say, "Oh!" and fix it on the spot.
Comment 7 David L. Craig 2019-10-18 20:17:14 UTC
I got confused about the history and forgot the successful build used --disable-pdfium as a Q&D fix, so this bad behavior did NOT start with  I was rushing to be able to get the problem/patch reported and the new pdfium problem was interfering with that task.  Plus I started a new 3rd-shift part-time job while this was going on.  I deeply apologize for the misinformation.
Comment 8 David L. Craig 2019-10-18 20:39:36 UTC
I have verified was the last version without the problem.
Comment 9 David L. Craig 2019-10-18 21:51:11 UTC
This is likely significant:
# ls -lh /usr/ports/work/libreoffice/src/libreoffice-
total 0
drwxr-xr-x 4 pkgmk nobody  80 Oct 18 08:16 CustomTarget
drwxr-xr-x 2 pkgmk nobody  40 Oct 18 08:16 Executable
drwxr-xr-x 5 pkgmk nobody 100 Oct 18 08:16 Headers
drwxr-xr-x 3 pkgmk nobody  60 Oct 18 08:16 LexTarget
drwxr-xr-x 5 pkgmk nobody 100 Oct 18 08:16 LinkTarget
drwxr-xr-x 2 pkgmk nobody  60 Oct 18 08:16 Misc
drwxr-xr-x 3 pkgmk nobody  60 Oct 18 08:16 Package
drwxr-xr-x 2 pkgmk nobody  40 Oct 18 08:16 UnpackedTarball
drwxr-xr-x 3 pkgmk nobody  60 Oct 18 08:16 YaccTarget

The error message says:

Gets message "[...] \
target    '[...]tarballs/pdfium-3794.tar.bz2', \
needed by '[...]libreoffice-'."

There is no UnpackedTarget directory in the build tree--I suspect that needed by is mistyped.  Here's what are in those directories thus far in the build:

# ls -lh /usr/ports/work/libreoffice/src/libreoffice-*
total 0
drwxr-xr-x 3 pkgmk nobody 60 Oct 18 08:16 officecfg
drwxr-xr-x 3 pkgmk nobody 60 Oct 18 08:16 tools

total 0

total 0
drwxr-xr-x 2 pkgmk nobody 40 Oct 18 08:16 Executable
drwxr-xr-x 2 pkgmk nobody 40 Oct 18 08:16 Library
drwxr-xr-x 2 pkgmk nobody 60 Oct 18 08:16 StaticLibrary

total 0
drwxr-xr-x 3 pkgmk nobody 60 Oct 18 08:16 unoidl

total 0
drwxr-xr-x 2 pkgmk nobody 40 Oct 18 08:16 Executable
drwxr-xr-x 2 pkgmk nobody 40 Oct 18 08:16 Library
drwxr-xr-x 2 pkgmk nobody 40 Oct 18 08:16 StaticLibrary

total 0
-rw-r--r-- 1 pkgmk nobody 0 Oct 18 08:16 DUMMY

total 0
drwxr-xr-x 2 pkgmk nobody 80 Oct 18 08:16 prepared

total 0

total 0
drwxr-xr-x 3 pkgmk nobody 60 Oct 18 08:16 unoidl
Comment 10 Miklos Vajna 2019-10-21 07:25:19 UTC
We typically just discuss build problems on the dev list, not on the bugtracker. This tracker is more for user-visible problems. (End-user, not "user as in consumer of the source code tarball".)
Comment 11 David L. Craig 2019-10-21 08:40:09 UTC
So should this be closed, then?
Comment 12 Miklos Vajna 2019-10-21 08:46:13 UTC
Yes, I just wanted to hear if there are any reasons I missed before I start a reopen war. :-)

Please ask on libreoffice@lists.freedesktop.org instead. Thanks!
Comment 13 David L. Craig 2019-10-22 08:29:27 UTC
email sent.