Bug 128238 - LibreOffice Calc - Regex Find/Replace causes massive memory usage
Summary: LibreOffice Calc - Regex Find/Replace causes massive memory usage
Status: RESOLVED DUPLICATE of bug 128313
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks: Memory
  Show dependency treegraph
 
Reported: 2019-10-18 20:09 UTC by jclayton06
Modified: 2019-11-11 15:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice Calc memory usage (16.21 KB, image/png)
2019-10-18 20:16 UTC, jclayton06
Details
Screenshot with memory usage in administrator. (140.55 KB, image/jpeg)
2019-10-19 03:07 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jclayton06 2019-10-18 20:09:59 UTC
Description:
Performing (a basic) Regular Expression Find/Replace in Calc (e.g., "^NOT" --> "YES") causes a memory usage rise of ~3GB each time. Does not go away until closing the application.

Steps to Reproduce:
1.Insert ~50 rows of data
2.Find / Replace with "Match Case" and "Selected Text" and "Regular Expression" selected
3.Use a ^ starting regex and watch the magic.

Actual Results:
Memory leak and very unresponsive application until restart.

Expected Results:
No memory leak.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 jclayton06 2019-10-18 20:16:58 UTC
Created attachment 155127 [details]
LibreOffice Calc memory usage
Comment 2 m.a.riosv 2019-10-19 03:07:04 UTC
Created attachment 155142 [details]
Screenshot with memory usage in administrator.

Showing LibreOffice with Search/replace in shadow and memory usage in Task administrator.
Memory grows with subsequent searches but slowly. 
LibreOffice doesn't crash but became unusable, even close the file takes a lot.

Version: 6.3.3.1 (x64)
Build ID: f41f4c7f9507aeca13cb9df51f34d80e8ba30a99
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc:
Comment 3 Xisco Faulí 2019-10-22 09:57:07 UTC
Thank you for reporting the bug.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 4 m.a.riosv 2019-11-01 21:56:00 UTC
Happens also with:
Version: 6.4.0.0.alpha0+ (x64)
Build ID: 758516295e5f69393bd78bb4af6e7214d48ece0b
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL
Comment 5 Xisco Faulí 2019-11-11 15:13:31 UTC
I believe this is a duplicate of bug 128313.

*** This bug has been marked as a duplicate of bug 128313 ***