Bug Hunting Session
Bug 128313 - LibreOffice Calc Editing Find&replace results in Failure to respond - Program hangs
Summary: LibreOffice Calc Editing Find&replace results in Failure to respond - Program...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0 target:6.3.4
Keywords: bibisected, bisected, needUITest, regression
: 128238 (view as bug list)
Depends on:
Blocks: gtk3-whipping-boy
  Show dependency treegraph
 
Reported: 2019-10-22 05:19 UTC by Bill L.
Modified: 2019-11-11 15:13 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bill L. 2019-10-22 05:19:33 UTC
Description:
Use LibreOffice Calc to search and replace "text" in cells of a selected column.
After the first found item, and request for next, the program stops responding. Requires forced exit.

Steps to Reproduce:
1.Repeated event with different strings
2.repeated event in different spread sheet
3.

Actual Results:
1. Select column
2. Edit/Find&Replace, Enter Find "string1", Enter Replace "string2"
3. Tick "Current selection only".
4. Find next, result is OK;  Find Next. 

Expected Results:
Following Second <Find Next> Calc stops responding


Reproducible: Always


User Profile Reset: No



Additional Info:
Calc should move to next item satisfying find criterion and wait for entry.
Comment 1 Xisco Faulí 2019-10-22 09:35:05 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 m.a.riosv 2019-10-22 10:21:35 UTC
Hangs for me for about 3 minutes, with high cpu usage (25%), and memory increasing up to 3633856
Reproducible
Version: 6.3.3.1 (x64)
Build ID: f41f4c7f9507aeca13cb9df51f34d80e8ba30a99
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc: 
with or without threaded

Last without issue for me
Version: 6.2.8.1 (x64)
Build ID: 815fe723fb0e60e4a39ff860f907cc63980a0232
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc: threaded
Comment 3 Xisco Faulí 2019-10-23 11:03:51 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=f920e86fbf3968104e1dfc0e9934e80652ed0837

author	Caolán McNamara <caolanm@redhat.com>	2019-03-22 15:59:00 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-03-24 18:19:29 +0100
commit	f920e86fbf3968104e1dfc0e9934e80652ed0837 (patch)
tree	01f8ed9c445821739b9709c5fee6e51eab0ae24d
parent	da881f38c088c439f034e340bbbb4ca53e67389f (diff)
weld SvxSearchDialog
I have to use the other way to specify an a11y role, both are implemented in
the vcl parser, but in my gtk3-3.24.7 the role tag crashes the gtk parser,
while the other route works fine.

The CONTENT_FLOWS_TO accessibility relation is another additional complexity
over the norm


Bisected with: bibisect-linux64-6.3

Adding Cc: to Caolán McNamara
Comment 4 Caolán McNamara 2019-10-23 13:19:57 UTC
what I'm seeing is an accessibility thing where the search dialog is setting content flows to the selected region. But the region is a near infinite list of cells where each cell gets an accessibility entry created.
Comment 5 Commit Notification 2019-10-23 19:52:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/12eb32fccec16a436a6c3eca725b9d6d449f8e19

Resolves: tdf#128313 disambiguate flow-to search results

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2019-10-23 19:53:12 UTC
fixed in master, backport to 6-3 in gerrit
Comment 7 m.a.riosv 2019-10-23 20:41:04 UTC
Thanks so much @Caolan.
Comment 8 Commit Notification 2019-10-24 12:16:56 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/66397e67829f2f502b9b6799dab16fa9a5390020

Resolves: tdf#128313 disambiguate flow-to search results

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2019-10-25 17:38:11 UTC
Verified in

Version: 6.4.0.0.alpha1+
Build ID: c0b8be4d7eb9fa1a0d8abfb1d27c71ac34bffd1b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!
Comment 10 Xisco Faulí 2019-11-11 15:13:31 UTC
*** Bug 128238 has been marked as a duplicate of this bug. ***