Bug 128258 - Calc feature request: more prominent visual hint for hidden rows or columns
Summary: Calc feature request: more prominent visual hint for hidden rows or columns
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All Linux (All)
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.4.0
Keywords:
: 131588 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-10-19 23:00 UTC by chameleonscales
Modified: 2022-02-09 07:18 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Mockup for comment 5 (11.27 KB, image/png)
2019-11-22 08:25 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chameleonscales 2019-10-19 23:00:26 UTC
Description:
Currently, the only way to tell if rows or columns are hidden is by seeing the thicker separation in the headers.

When I work intensively, I often forget that I have hidden cells and this visual hint is too subtle for me to notice it, which leads to me breaking my data and realizing it a while later.
Moreover,if for whatever reason I decide to hide the headers themselves, now there's no way to tell if cells are hidden.


Steps to Reproduce:
Right-clic on a row or column in a header and select "Hide Rows" (or Columns).

Actual Results:
A thicker line separates the rows between which the hidden one is contained.

Expected Results:
An efficient solution would be to have an option to display thicker borders where hidden rows or columns are contained (this time on the sheet itself).
In addition to that, a color for that thicker line would make it even more prominent and hard to miss. Of course, to ensure one could make this color stand out in any colorized sheet, this color should be changeable in the Preferences.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 m.a.riosv 2019-10-20 15:45:06 UTC
First to show the first rows/columns:
https://help.libreoffice.org/6.3/en-US/text/scalc/01/05030400.html?DbPAR=CALC#bm_id3147264

On gets more visibility of hidden, use the Menu/Data/Group & Outline, [F12} [Ctrl+F12], it's quick and visible.
Comment 2 chameleonscales 2019-10-20 16:54:33 UTC
Thanks but I know about these features and I don't find them to address my issue, as they don't display which rows/columns are hidden on the sheet itself.
Comment 3 Heiko Tietze 2019-11-21 12:51:35 UTC
Can you elaborate a bit on the workflow? I mean, do you enter a formula like =sum(A:Z) mistakenly adding the hidden column B:Y. 

Column and row text is the feedback right now and you would see A,Z in the header.
Comment 4 chameleonscales 2019-11-21 13:41:06 UTC
Producing erroneous data can happen in various ways. I may simply type a value, hit Enter and type another value, which, if there are hidden cells inbetween, skips them all without me noticing it immediately, especially when I work without headers, which I often do to save UI space (I use several Calc windows at the same time in combination with other programs and just can't afford this additional space).
Comment 5 Heiko Tietze 2019-11-21 15:36:36 UTC
Some ideas to fix the issue:
a) Draw a bold, colored line (would solve the problem when data is entered)
b) Place an indicator at cells with a formula that contains references to hidden cells
c) Show a warning if formula or input contains or jumps over hidden cells (must not interrupt the workflow so it would be in the status bar and potentially overlooked)

Eike, what do you think?
Comment 6 chameleonscales 2019-11-21 16:58:48 UTC
I'm not clear whether your fix ideas are additional operations the end user would have to perform or ideas of features to develop.
If it's the first case, then:

a) impractical considering I already use various borders in many cells, which means I would have to edit them back properly after relealing the cells
b) not sure what you mean by "indicator" but if you mean comment, once again, I use them in many places already
c) what kind of warning?
Comment 7 Heiko Tietze 2019-11-22 08:25:37 UTC
Created attachment 156025 [details]
Mockup for comment 5

(In reply to chameleonscales from comment #6)
> I'm not clear whether your fix ideas are additional operations...

It's ideas how to solve the problem per code. Solution a) is inspired by the ruler that Writer puts between pages. It would be my favorite.
Comment 8 chameleonscales 2019-11-22 08:49:35 UTC
Ok, so a) is my favorite too.
Thanks for the mockup. I should have done this from the beginning so it would've been clear right away.
Comment 9 Aron Budea 2020-03-26 03:40:57 UTC
*** Bug 131588 has been marked as a duplicate of this bug. ***
Comment 10 Heiko Tietze 2021-05-18 10:47:16 UTC
Let's draw a line... (option a) from the mockup)
Comment 11 Heiko Tietze 2021-05-25 15:39:43 UTC
*** Bug 142477 has been marked as a duplicate of this bug. ***
Comment 12 Grey 2022-01-17 11:54:49 UTC
Commenting because I've often found myself in a similar situation as bug submitter chameleonscales. I was hoping to find a way to set the width/color of the present Hide/Show line in `Tools > Options... > Application Colors` which, AFAICT, there isn't.

Heiko Tietze's proposed solution A (the dotted blue line overlay) is the most elegant: visible without being distracting nor potentially overlooked (as is the current Hide/Show visual cue). Group/Ungroup is, with all due respect, an ugly workaround: it's a different function, it unnecessarily eats screen real estate with its added outer row/column and ultimately its visual cue is identical to Hide/Show.
Comment 13 Commit Notification 2022-01-27 09:32:55 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ba0100be03c6bbc5ae10201bae340b3f7b7c4500

Resolves tdf#128258 - Draw a dotted line before hidden columns/rows

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Heiko Tietze 2022-01-27 09:35:59 UTC
The dotted line will be drawn now as in the mockup. I've experienced terrible lags with the generic VCL and disabled the dots for simple dashes in this case. But it might be a regression users with slow machines anyway. To disable (or change the color) uncheck the option at Tools > Options > Application Color: Spreadsheet > Hidden row/col.
Comment 15 BogdanB 2022-02-03 20:42:50 UTC
Nice improvment. Anyone can notice something is there now.

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: d5f015185240a7bddfed7ddf10d6b5426e35fb72
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 16 Kevin Suo 2022-02-09 06:07:09 UTC
Created attachment 178156 [details]
screenshot showing the mess

Oh my...

Would you guys reconsider this feature? Showing a long dashed lines on each filtered cell is toooooooooooo bad. See the attached screenshot. 

We already have colored row labels indicating that a filter is set, why do we need to show another indication?
Comment 17 Aron Budea 2022-02-09 06:15:28 UTC
(In reply to Kevin Suo from comment #16)
> We already have colored row labels indicating that a filter is set, why do
> we need to show another indication?
This seems to be about the more general case of hidden rows/columns, which don't have that kind of generic indication.
Comment 18 Heiko Tietze 2022-02-09 06:18:07 UTC
(In reply to Kevin Suo from comment #16)
> We already have colored row labels indicating that a filter is set, why do
> we need to show another indication?

You can disable the indicator per Tools > Options > Application Colors > Spreadsheet: [ ] Hidden row/col. I expect the average document to have only a few hidden row/col - and those need attention. No need however, if most content is hidden.
Comment 19 Kevin Suo 2022-02-09 06:59:33 UTC
> I expect the average document to have only a few hidden row/col - and those need attention. No need however, if most content is hidden.

For advanced Spreadsheet users and for they all play with complex data everyday. The mostly used function in Calc is: formulas, complex autofilter (like the one I provided in the screenshot), pivot table.

This impact is not small if the user uses Calc to prepare a simple Invoice, but it hurts real Calc users.

May I suggest you to disable that option by default?
Comment 20 Heiko Tietze 2022-02-09 07:18:23 UTC
(In reply to Kevin Suo from comment #19)
> May I suggest you to disable that option by default?

bug 147301