Bug 128318 - [l10n] Not translatable button label ("Standard") in paragraph dialog
Summary: [l10n] Not translatable button label ("Standard") in paragraph dialog
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0 target:6.3.4
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-22 08:09 UTC by Ming Hua
Modified: 2020-01-02 18:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the dialog with untranslated button (16.36 KB, image/png)
2019-10-22 08:09 UTC, Ming Hua
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ming Hua 2019-10-22 08:09:54 UTC
Created attachment 155226 [details]
Screenshot of the dialog with untranslated button

(Bugzilla doesn't have version 6.3.3 RC1 yet, so I'm filing against the version that introduced the change, hopefully it's correct.)

While testing 6.3.3 RC1 with simplified Chinese UI, I noticed a untranslated button in Writer's right click menu -> Paragraph -> Paragraph... dialog (see attached screenshot).

After some poking around I found that it's was not due to omission by the zh-CN translators, but because the button label is explicitly tagged not to be translated:
https://opengrok.libreoffice.org/xref/core/sw/uiconfig/swriter/ui/paradialog.ui?r=ed0c1bc4#41

The annotate tool says that change was made by Caolán when fixing bug 123950.  I don't know the reason it was tagged not translatable then, but surely it should be translated for master, and hopefully 6.3 branch now?
Comment 1 Xisco Faulí 2019-10-22 12:19:49 UTC
(In reply to Ming Hua from comment #0)
> After some poking around I found that it's was not due to omission by the
> zh-CN translators, but because the button label is explicitly tagged not to
> be translated:
> https://opengrok.libreoffice.org/xref/core/sw/uiconfig/swriter/ui/paradialog.
> ui?r=ed0c1bc4#41
> 
> The annotate tool says that change was made by Caolán when fixing bug
> 123950.  I don't know the reason it was tagged not translatable then, but
> surely it should be translated for master, and hopefully 6.3 branch now?

@Caolán, would it be fine to tag the label as translatable ?
Comment 2 Caolán McNamara 2019-10-22 12:43:38 UTC
Its marked as untranslatable because its supposed to have its real contents set by...

https://opengrok.libreoffice.org/xref/core/sfx2/source/dialog/tabdlg.cxx?r=2953db95#338

with STR_STANDARD_SHORTCUT

I bet it gets translated if you open the paragraph *style* dialog ?
Comment 3 Caolán McNamara 2019-10-22 12:53:22 UTC
I think the buttons should not be visible unless they are in edit style mode.
Comment 4 Ming Hua 2019-10-22 16:00:27 UTC
(In reply to Caolán McNamara from comment #2)
> I bet it gets translated if you open the paragraph *style* dialog ?
Indeed, in the dialogs for modifying and creating paragrah styles, I can confirm the "Standard" button is translated.

BTW what's the correct name of the dialog in my screenshot?  Just "paragraph dialog"?
Comment 5 Commit Notification 2019-10-22 19:09:36 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ad0a97ca200328d336a3cd58942f71a824b1f23a

Resolves: tdf#128318 'Standard' buttons should not be shown by default

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2019-10-22 19:21:09 UTC
fixed in master, backport to 6-3 in gerrit
Comment 7 Caolán McNamara 2019-10-23 08:05:45 UTC
"BTW what's the correct name of the dialog in my screenshot?  Just "paragraph dialog"?"

I guess "paragraph format dialog", I tend to name them by the path to get to them from the main menu, so "format -> paragraph" in this case.
Comment 8 Commit Notification 2019-10-23 11:38:15 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/de302d199d1445ccf872e00e6fa0f673bbdddb6d

Resolves: tdf#128318 'Standard' buttons should not be shown by default

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Ming Hua 2020-01-01 08:53:31 UTC
Verified in 6.3.4

版本: 6.3.4.2 (x64)
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU 线程: 2; 操作系统: Windows 10.0; UI 渲染: 默认; VCL: win; 
区域语言: zh-CN (zh_CN); UI 语言: zh-CN
Calc: threaded

Thanks Caolán!
Comment 10 sdc.blanco 2020-01-02 18:53:25 UTC
Modified summary to make content explicit -- because {Paragraph, Character, Frame} Style dialog boxes still use "Standard" button (in 6.5.0.0.alpha).