Bug 129497 - No explanation of "Standard" and "Reset" buttons in Paragraph Style Dialog box
Summary: No explanation of "Standard" and "Reset" buttons in Paragraph Style Dialog box
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All All
: medium normal
Assignee: sdc.blanco
URL:
Whiteboard: target:6.5.0
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures Styles-Dialog
  Show dependency treegraph
 
Reported: 2019-12-19 14:55 UTC by sdc.blanco
Modified: 2020-01-23 02:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2019-12-19 14:55:33 UTC
1.  No offline or online documentation for "Standard" and "Reset" buttons in Paragraph Style dialog.

2. LibreOffice Writer 6.0 mentions "Standard" (p. 192), but not "Reset" (and describes "Standard" to be used to "reset" properties.

3.  Clicking on the Help button in the Paragraph Style dialog box comes gives an offline help page about "Indents and Spacing" in paragraphs.  (LO 6.3.3.2)  (i.e., marginally relevant).

Here is the relevant uri:  cui/ui/paraindentspacing/ParaIndentSpacing

and corresponding online url:

https://help.libreoffice.org/6.3/en-US/text/shared/01/05030100.html?System=WIN&DbPAR=WRITER&HID=cui/ui/paraindentspacing/ParaIndentSpacing#bm_id3145138

4.  Clicking on the Help button in LO 6.4.0.0.beta1 (without offline help) gives online help to the Organizer page, but no explanation of "Standard" or "Reset" buttons.

https://help.libreoffice.org/6.4/en-US/text/shared/01/05040100.html?System=WIN&DbPAR=WRITER&HID=sfx/ui/managestylepage/ManageStylePage#bm_id3145356
Comment 1 sdc.blanco 2019-12-19 18:31:22 UTC
The "Standard" and "Reset" buttons appear for all the tabs in the Paragraph Style dialog box.  It would be useful for the documentation to note whether they apply only for the current tab, or would be applied across settings in all the tabs.
Comment 2 Olivier Hallot 2019-12-27 20:51:30 UTC
Offline and online contents differs only for extra multimedia files. Contents is the same if multimedia (video, examples files) is not involved.

The following Help page is there to supply contents in <embed> tags used in numerous pages, and is not a target page for end-user:

https://help.libreoffice.org/6.5/en-US/text/shared/00/00000001.html

Note that the same button can have different behavior depending on the dialog. A case by case is necessary before embeding the right text in the dialog page.
Comment 3 Commit Notification 2020-01-02 15:05:19 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/076efd07d9bd8c35ff26d4b4d1e54d6e63174f9b

tdf#129497  updating help pages for paragraph dialog tabs
Comment 4 Commit Notification 2020-01-03 01:08:10 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/169466b5553e03aef51d91f2b1588dc48be86c4d

tdf#129497  update help information for paragraph style dialog
Comment 5 Commit Notification 2020-01-07 20:34:56 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/84e12edbc498a2fca5a7e39eb87541969999b5df

tdf#129497 updating help for Condition tab of Paragraph Style dialog
Comment 6 Commit Notification 2020-01-22 19:20:39 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/a51da4ed164a09ce51bd92d3e99ddc9b70c6792d

Resolves: tdf#129497  help about reset for all help pages in paragraph style tabs
Comment 7 sdc.blanco 2020-01-23 02:58:32 UTC
This bug was opened because of lack of information about Reset and Standard in the Paragraph Style help pages.  The patches have added information about "Reset" to all the tabs in the Paragraph Style dialog (and also the tabs for the Paragraph dialog, because they are shared with the Paragraph Style). 

Bug #128469 shows that the meaning of Standard is being considered (and whether the name should be changed), so it was decided not to add any information about Standard until that question was resolved.

Bug #118834 also raises a question "reset" and "standard" in help for Style dialogs, but also includes "Apply" and "Cancel".  In effect, this bug #129497 is a subset of bug #118834.