Bug 128328 - Bibliography: repetion of entries used multiple times
Summary: Bibliography: repetion of entries used multiple times
Status: RESOLVED DUPLICATE of bug 128845
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, needUITest, regression
Depends on:
Blocks:
 
Reported: 2019-10-22 16:20 UTC by Charles Valente
Modified: 2019-12-04 13:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of file with the bug. Open it with LO 6.3. (12.27 KB, application/vnd.oasis.opendocument.text)
2019-10-22 16:22 UTC, Charles Valente
Details
My personal database. (27.32 KB, application/x-zip-compressed)
2019-10-24 16:53 UTC, Charles Valente
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Charles Valente 2019-10-22 16:20:03 UTC
Description:
If I insert the same bibliography entry multiple times on the text, the bibliography table will repeat that entry the amount of times it appears.
The bug began on 6.3.2. I tested on both Ubuntu 18.04 and Windows 10 64-bits, and the bug is the same. It did not happened on 6.2.

Steps to Reproduce:
Just insert the entries and the bibliography table.


Actual Results:
Duplicated entries in the bibliography table.

Expected Results:
Even if many instances of the same bibliography entry were inserted along the document, a single reference to that entry should be in the bibliography table.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Charles Valente 2019-10-22 16:22:05 UTC
Created attachment 155240 [details]
Example of file with the bug. Open it with LO 6.3.
Comment 2 Xisco Faulí 2019-10-23 14:04:29 UTC
Hello Charles,
Thanks for reporting this issue.
If I open the file attached, either with LibreOffice 6.4, 6.2 or 5.3 I get the same result, 4 entries in the TOC.
Could you explain how to reproduce this issue from scratch ?
Comment 3 Charles Valente 2019-10-24 16:53:15 UTC
Created attachment 155285 [details]
My personal database.
Comment 4 Charles Valente 2019-10-24 16:57:57 UTC
Thank you very much for your return.

The problem doesn't show up in 6.2 or bellow.
I have not tested in 6.4.
It only hapens in 6.3 (the version I have is 6.3.2).

The file teste01.odt I sent previously uses a demo database installed with LO.

Maybe the bibliography database I use for my writings will trigger the problem, so I sent it to you.

Thanks again.
Comment 5 QA Administrators 2019-10-25 02:41:23 UTC Comment hidden (obsolete)
Comment 6 jmpierre 2019-11-09 17:54:44 UTC
Bug also with 6.3.3
Comment 7 Xisco Faulí 2019-11-11 14:50:20 UTC
Ok, I can reproduce it now. Steps:
1. Open attached document
2. Update the TOC

-> Only 2 entries should be displayed. 4 entries are displayed

Regression introduced by:

author	Noel Grandin <noel.grandin@collabora.co.uk>	2019-01-18 15:38:07 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2019-01-21 07:34:09 +0100
commit	3b16e997f69efe2e3f6cdf64fe8fb2727b6ebaa7 (patch)
tree	a0d65d6b892ea39d0da8992cbab6bda579e19cdf
parent	2af5d6006948890229d9e55feb56e0e849bf857d (diff)
cleanup SwAuthEntry manual ref-counting

Bisected with: bibisect-linux64-6.3

Adding Cc: to Noel Grandin
Comment 8 Xisco Faulí 2019-12-04 13:29:12 UTC
Fixed in

Version: 6.5.0.0.alpha0+
Build ID: 8f7010eb47119a2428b77f5d79fc8577d9914958
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Closing as a duplicate of 128845

*** This bug has been marked as a duplicate of bug 128845 ***