Bug 128336 - Text in menu items is blank in Windows 10
Summary: Text in menu items is blank in Windows 10
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks:
 
Reported: 2019-10-23 10:22 UTC by John
Modified: 2020-10-06 08:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot (40.00 KB, image/png)
2019-10-23 10:26 UTC, John
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John 2019-10-23 10:22:23 UTC
Description:
The text for each menu item is blank.  The icons appear, but not the corresponding text for each menu item.  I have tried Writer and Calc and all the other components and this happens.  It also occurs on the initial Libre Office screen.  It works correctly when opening Libre Office in safe mode, that is, the menu texts are visible.

Steps to Reproduce:
1. Just need to open Libre office to see this, not in safe mode.
2.
3.

Actual Results:
Libre Office opens without texts on the menu items.

Expected Results:
I should see menu texts next to each menu item.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
I have tried restarting Libre office.  I have tried re-installing Libre Office, I have tried resetting it to factory settings, I have tried resetting the User Profile.  None of these work.
Comment 1 John 2019-10-23 10:26:57 UTC
Created attachment 155251 [details]
Screenshot

screenshot showing blank menu items.
Comment 2 m.a.riosv 2019-10-23 11:14:20 UTC Comment hidden (obsolete)
Comment 3 John 2019-10-29 09:34:27 UTC Comment hidden (obsolete)
Comment 4 John 2019-10-29 09:35:38 UTC
(In reply to m.a.riosv from comment #2)
> Please test changing OpenGL option. Menu/Tools/Options/LibreOffice/View

I have tried various options to change the GL mode in the View menu and it does not resolve the problem.
Comment 5 John 2019-10-29 09:36:13 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2019-10-30 03:38:02 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2019-10-30 08:28:32 UTC Comment hidden (obsolete)
Comment 8 John 2019-10-30 10:05:26 UTC
Here it is:

Version: 6.2.6.2 (x64)
Build ID: 684e730861356e74889dfe6dbddd3562aae2e6ad
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-AU (en_AU); UI-Language: en-US
Calc: threaded
Comment 9 Timur 2019-11-10 14:02:52 UTC
Please test with master https://dev-builds.libreoffice.org/daily/master/Win-x86_64@tb77-TDF/current/. It's separate to working LO and doesn't register extensions.
Comment 10 Timur 2019-11-10 14:08:35 UTC Comment hidden (obsolete)
Comment 11 John 2019-11-12 09:19:33 UTC Comment hidden (obsolete)
Comment 12 John 2019-11-12 09:23:25 UTC
(In reply to John from comment #11)
> (In reply to Timur from comment #9)
> > Please test with master
> > https://dev-builds.libreoffice.org/daily/master/Win-x86_64@tb77-TDF/current/.
> > It's separate to working LO and doesn't register extensions.
> 
> Notsure what you want me to do here?  Please explain?

Yes, updated regularly as and when required.  Version as follows:
Windows 10 Home
Version 1903
Installed on 23/06/2019
OS Build 18362.418
Comment 13 Julien Nabet 2020-01-16 14:54:17 UTC
On Win10 with LO 6.3.4, I don't reproduce this.

Could you give a try to last stable LO version 6.3.4 + take a look at https://wiki.documentfoundation.org/QA/FirstSteps ?
Comment 14 Paul Robinson 2020-04-06 00:09:44 UTC
I suspect this user is running Windows (10) High Contrast. Libre Office does not check for High Contrast being enabled or default to High Contrast colors. While it won't fix the menus, to get the buttons to show up, try menu
Tools, Options 
then select Accessibility
then check the three High Contrast boxes at the bottom
Click 'Ok'
The menus still don't show unless the mouse is hovering over a specific menu item, but now the buttons will.

See Also Bug 128287 for similar problem.
Comment 15 Timur 2020-04-06 06:06:02 UTC
Posao thanks for hint. But status should not be changed, Needinfo is correct, reporter should respond. If so, this should be marked duplicate of 128287.
Comment 16 QA Administrators 2020-10-04 03:50:09 UTC Comment hidden (obsolete)
Comment 17 John 2020-10-06 08:49:06 UTC
I was able to resolve this issue by disabling GL in Tools -> Options -> View.  I then restarted Libre Office and text in the menu items became available.
Comment 18 Timur 2020-10-06 08:59:13 UTC
John, thanks, please test some more as follows. 
LO doesn't have OpenGL in new versions, you didn't write your current LO version but it's likely 6.4.x.
I set WontFix for OpenGL.

Instead, in Tools -> Options -> View in newer versions we have Skia. 
To be sure this is OK, please test daily master LO from https://dev-builds.libreoffice.org/daily/master/current.html, that installs separately to your working LO. 
If you still have a problem with or without Skia, please write if you have High Contrast.