Download it now!
Bug 128375 - CRASH: Closing LibreOffice after cutting content from document
Summary: CRASH: Closing LibreOffice after cutting content from document
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.4.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-10-24 15:31 UTC by Xisco Faulí
Modified: 2019-11-13 09:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-10-24 15:31:34 UTC
Steps to reproduce:
1. Open attachment 154373 [details] from bug 127705
2. Select all
3. Cut
4. Close LibreOffice - Don't save

-> Crash

Reproduced in

Version: 6.4.0.0.alpha1+
Build ID: 6c6b00300c5430466804619394b84beea01b3187
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-10-24 15:32:29 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5ba30f588d6e41a13d68b1461345fca7a7ca61ac

author	Michael Stahl <Michael.Stahl@cib.de>	2019-09-06 19:36:48 +0200
committer	Michael Stahl <Michael.Stahl@cib.de>	2019-09-17 10:45:40 +0200
commit	5ba30f588d6e41a13d68b1461345fca7a7ca61ac (patch)
tree	6f098ffd0fb2c75a2c1cbda4e7b82bd65fb8e7dd
parent	6e1cb2e9dd406fb2883460cefaa4660622996005 (diff)
tdf#64222 sw: better DOCX import/export of paragraph marker formatting

Bisected with: bibisect-linux64-6.4

Adding Cc: to Michael Stahl
Comment 2 Xisco Faulí 2019-10-24 16:14:14 UTC
@Julien, could you please give a try to it? I can only reproduce it with gtk3 and michael can't even reproduce it. it would be nice to have a backtrace ( I can't do it myself with a dbg daily build because it only works with gen for me )
Comment 3 Julien Nabet 2019-10-24 20:25:33 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce the crash with gen or gtk3.
However I noticed these logs on gtk3:
warn:legacy.osl:1450:1450:sw/source/core/access/acccontext.cxx:442: fire event for disposed frame?
warn:legacy.osl:1450:1450:sw/source/core/access/acccontext.cxx:442: fire event for disposed frame?
warn:sw.core:1450:1450:sw/source/core/attr/calbck.cxx:229: a 16SwTextFormatColl client added as listener to a 16SwTextFormatColl during client iteration.
Comment 4 Xisco Faulí 2019-10-25 17:40:10 UTC
Moving it back to UNCONFIRMED to see if someone else can reproduce it...
Comment 5 Julien Nabet 2019-10-26 11:03:00 UTC
Xisco: perhaps we can try to fix your pb for bt retrieving with gtk3? What's your error?
I see at least 3 methods to retrieve a bt:
- From https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace 
1) soffice --backtrace
2) if you built lo, you can use "make debugrun"
then:
run --calc
run --writer
...

- from https://wiki.documentfoundation.org/Development/How_to_debug#Attaching_to_the_soffice.bin_process
3) gdb --pid=$(pidof soffice.bin)
(of course, after having launched soffice)
Comment 6 Dieter Praas 2019-10-27 12:54:17 UTC
I could only reproduce it once:

Version: 6.4.0.0.alpha1 (x64)
Build ID: cc57df8f942f239d29cb575ea5a7cb01405db787
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 7 Timur 2019-10-30 09:48:51 UTC
I reproduce in Windows like this: LO windows is closed but process remains and must be killed in Task manager. I guess that's it. So I'll confirm and leave "all" for Hardware.

Note: first time I loaded this docx, I had procdump on fileopen. I repeated with MSO saved and no procdump, but repro this issue with closing LO.
Comment 8 Michael Stahl (CIB) 2019-11-01 18:09:12 UTC
see https://gerrit.libreoffice.org/#/c/81911/
Comment 9 Commit Notification 2019-11-11 10:03:43 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/938a4d6624a78f3e272b3c4c07f314cb0c6db723

tdf#128375 sw: fix copying RES_PARATR_LIST_AUTOFMT to different SwDoc

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2019-11-13 09:59:56 UTC
Verified in

Version: 6.4.0.0.alpha1+
Build ID: 26b7ff2b6cc4def8ff7b02e223961534ba88e654
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this issue!