Bug 128495 - Print dialog box in Writer is too tall for screen so the button is off the bottom
Summary: Print dialog box in Writer is too tall for screen so the button is off the bo...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0.1 target:6.5.0 target:6.3.4
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-31 10:43 UTC by Steve
Modified: 2019-11-20 09:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
How it looks in LibreOffice 6.4 master (46.95 KB, image/png)
2019-11-11 15:19 UTC, Xisco Faulí
Details
Screenshot showing title bar above top of screen (200.83 KB, image/png)
2019-11-16 12:08 UTC, Steve
Details
how it looks after the commit (43.88 KB, image/png)
2019-11-18 09:41 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve 2019-10-31 10:43:48 UTC
Description:
Using the print dialog in 6.3.2.2 (x64) on Windows 10, the print dialog box is too tall for the screen with no option to shrink the box. The print button is off the bottom of the screen. Using a dual screen PC, moving the print box so that it spans the two screens allows the "OK" box to be seen if the screens have a vertical offset. The screens involved have resolutions 1366 x 768 and 1920 x 1080. LibreOffice was launched on the smaller screen. Moving the LibreOffice window to the larger screen results in a box that is too large for that screen.

Setting the Windows task bar to hide automatically and then using the print menu opened the print dialog so that the top of the box was above the top of the screen and the "OK" button was visible - the "cancel" button was also there, so full access to the functionality was available. When autohide was turned off and LibreOffice reopened the print dialog was still displayed with the top missing but the OK button was still visible.

Actual Results:
With a new installation of 6.3.2.2 (this was an upgrade to an earlier version), open the print dialog from a LibreOffice component with Windows set to have a taskbar at the bottom that is always visible.

I have not reinstalled 6.3.2.2

Expected Results:
The "OK" button was not displayed


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Displayed a smaller dialog box that fitted within the screen area - or that could be scrolled to show the "OK" button.

Version: 6.3.2.2 (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-GB
Calc: CL
Comment 1 m.a.riosv 2019-10-31 23:26:46 UTC
Reproducible, wide can be changed but not high.
Version: 6.4.0.0.alpha0+ (x64)
Build ID: 758516295e5f69393bd78bb4af6e7214d48ece0b
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL
Comment 2 Xisco Faulí 2019-11-11 15:19:12 UTC
Created attachment 155707 [details]
How it looks in LibreOffice 6.4 master
Comment 3 Xisco Faulí 2019-11-11 15:20:58 UTC
I believe the dialog could be slightly shorter, since it has an empty space below the right side.
@Caolán, What do you think ?
Comment 4 Caolán McNamara 2019-11-15 13:30:18 UTC
The dialog's height is mostly determined by the fixed pixel size of 500x700 for the preview widget (which was nothing to do with me). 

I suggest https://gerrit.libreoffice.org/#/c/82790/ to measure it relative to the user's font which gives approximately the same size for the gtk case by substantially reduced for the gen case which might be more desirable
Comment 5 Commit Notification 2019-11-15 19:37:37 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/e2e7bd4fdf6a6312791318f0687e8d1cfcbb1cbb

tdf#128495 measure preferred size of print preview relative to UI font

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-11-15 19:37:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1a137ef35d67a4aff7b2a6f1d3aa3c944c7a0b41

tdf#128495 measure preferred size of print preview relative to UI font

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2019-11-15 19:54:02 UTC
caolanm->x1sc0: is the result of that suitable for "fixed" ?
Comment 8 Steve 2019-11-16 12:08:23 UTC
Created attachment 155875 [details]
Screenshot showing title bar above top of screen

Thanks to all for working on this.

The size of the window is now appropriate for the screen - and looks a lot tidier, but if I have the taskbar fixed to the bottom of the screen, the window positions itself so that only the very bottom of the tabs is accessible (see screenshot) - and it is not possible to "grab" the window to move it.

I tried auto-hiding the taskbar and moving it to the right (rather than botton) of the screen and then re-starting LibreOffice, but the title bar of then window stubbornly remained above the top of the screen.The size of the window is now appropriate for the screen - and looks a lot tidier, but if I have the taskbar fixed to the bottom of the screen, the window positions itself so that only the very bottom of the tabs is accessible (see screenshot) - and it is not possible to "grab" the window to move it.

I tried auto-hiding the taskbar and moving it to the right (rather than botton) of the screen and then re-starting LibreOffice, but the title bar of then window stubbornly remained above the top of the screen.
Comment 9 Xisco Faulí 2019-11-18 09:41:12 UTC
Created attachment 155910 [details]
how it looks after the commit
Comment 10 Xisco Faulí 2019-11-18 09:46:26 UTC
Hi Caolán,
Yes, it looks much tighter now, it will definitely improve the user experience of people with small screens. IMHO, it can be closed as 'fixed' now.

@Steve, Could you please try with a clean profile < https://wiki.documentfoundation.org/UserProfile > and retest? if the issue persist, please create a follow-up bug. Thanks in advance
Comment 11 Steve 2019-11-18 10:23:28 UTC
I've re-tested with alpha1 and have the same problem. I've deleted the Dev user profile, and also use the safe mode to reset the user profile to the default.

I will open a new bug as you asked.
Comment 12 Steve 2019-11-18 10:31:14 UTC
(In reply to Steve from comment #11)
> I've re-tested with alpha1 and have the same problem. I've deleted the Dev
> user profile, and also use the safe mode to reset the user profile to the
> default.
> 
> I will open a new bug as you asked.

Sorry - downloaded wrong build. Will try again.
Comment 13 Steve 2019-11-18 10:41:46 UTC
(In reply to Xisco Faulí from comment #10)
> Hi Caolán,
> Yes, it looks much tighter now, it will definitely improve the user
> experience of people with small screens. IMHO, it can be closed as 'fixed'
> now.
> 
> @Steve, Could you please try with a clean profile <
> https://wiki.documentfoundation.org/UserProfile > and retest? if the issue
> persist, please create a follow-up bug. Thanks in advance

I've checked with the 2019-11-17 build of LibreOfficeDev_6.5.0.0.alpha0_Win_x64.msi and the tabs are now on the screen, but the title bar is off the top. I'll raise a a new bug.
Comment 14 Caolán McNamara 2019-11-18 11:41:00 UTC
I'll mark as closed as the worst of things is resolved, backport coming for 6-3.
Comment 15 Commit Notification 2019-11-18 17:02:41 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/4cf00f070fa5771bf5e6382cffe933beb65ca4b8

tdf#128495 measure preferred size of print preview relative to UI font

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Steve 2019-11-18 21:16:22 UTC
(In reply to Xisco Faulí from comment #10)
> Hi Caolán,
> Yes, it looks much tighter now, it will definitely improve the user
> experience of people with small screens. IMHO, it can be closed as 'fixed'
> now.
> 
> @Steve, Could you please try with a clean profile <
> https://wiki.documentfoundation.org/UserProfile > and retest? if the issue
> persist, please create a follow-up bug. Thanks in advance

Hi Xisco

As I still have a problem with the title bar position (though the window itself is great) I raised a new bug - https://bugs.documentfoundation.org/show_bug.cgi?id=128869 , but the comments are that it is a duplicate (of thus one).

Steve