Download it now!
Bug 128547 - [FILEOPEN PPTX] bad formatting of title and subtitle
Summary: [FILEOPEN PPTX] bad formatting of title and subtitle
Status: RESOLVED DUPLICATE of bug 131554
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-11-02 12:40 UTC by Pablo
Modified: 2020-03-25 11:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
PPTX exported from Keynote for iCloud (28.05 KB, application/zip)
2019-11-02 12:41 UTC, Pablo
Details
PDF exported from PowerPoint (2.81 KB, application/pdf)
2019-11-02 12:41 UTC, Pablo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pablo 2019-11-02 12:40:21 UTC
Description:
The PPTX exported from Keynote for iCloud. Created with the default white theme.

Steps to Reproduce:
1. Open the PPTX in Impress
2. Compare to the PDF exported from PowerPoint.

Actual Results:
The title position is wrong.
The subtitle imported as a left aligned bullet item.

Expected Results:
Title should be vertically centered.
Subtitle should have center alignment with no bullet.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.2.2
Build ID: 1:6.3.2-0ubuntu0.18.04.1~lo1
CPU threads: 1; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: en-US (en_IL); UI-Language: en-US
Calc: threaded

Version: 6.4.0.0.alpha1
Build ID: cc57df8f942f239d29cb575ea5a7cb01405db787
CPU threads: 1; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: en-US (en_IL); UI-Language: en-US
Calc: threaded
Comment 1 Pablo 2019-11-02 12:41:04 UTC
Created attachment 155460 [details]
PPTX exported from Keynote for iCloud
Comment 2 Pablo 2019-11-02 12:41:30 UTC
Created attachment 155461 [details]
PDF exported from PowerPoint
Comment 3 Pablo 2019-11-03 11:50:19 UTC
ppt/slides/slide1.xml has the correct layout for the title and subtitle.
Title:
<p:nvPr><p:ph type="ctrTitle"/></p:nvPr>
Subtitle:
<p:nvPr><p:ph type="subTitle" sz="quarter" idx="1"/></p:nvPr>

ppt/slideLayouts/slideLayout1.xml has other layout for the title and subtitle.
Title:
<p:nvPr><p:ph type="title"/></p:nvPr>
Subtitle:
<p:nvPr><p:ph type="body" sz="quarter" idx="1"/></p:nvPr>

For some reason slide1.xml doesn't override slideLayout1.xml which cause the bad layout.

I can manually edit ppt/slideLayouts/slideLayout1.xml to make it look as desited   but it shouldn't be required.
---<p:ph type="title"/>
+++<p:ph type="ctrTitle"/>

---<p:ph type="body" sz="quarter" idx="1"/>
+++<p:ph type="subTitle" idx="1"/>
Comment 4 Xisco Faulí 2019-11-04 11:42:08 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=cc6ae367280d205a88c6f907b20b84613221ca52


author	Matúš Kukan <matus.kukan@collabora.com>	2014-08-07 13:25:51 +0200
committer	Matúš Kukan <matus.kukan@collabora.com>	2014-08-07 21:05:07 +0200
commit	cc6ae367280d205a88c6f907b20b84613221ca52 (patch)
tree	a803f213ac28a7b10cb150388094b546d13821ed
parent	f4677f58a26d1183af5c91470be0e4f782e6cbeb (diff)
bnc#821916: Better algorithm to find placeholder shape.

Bisected with: bibisect-44max
Comment 5 Xisco Faulí 2020-03-25 11:34:38 UTC
This is a duplicate of bug 131554

*** This bug has been marked as a duplicate of bug 131554 ***