Bug 128665 - EDITING: Undo takes action on another shape
Summary: EDITING: Undo takes action on another shape
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.5
Keywords: bibisected, bisected, regression
: 133069 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-11-08 09:13 UTC by Xisco Faulí
Modified: 2020-05-18 10:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-11-08 09:13:04 UTC
Steps to reproduce:
1. Open attachment 153993 [details] from bug 127412
2. Select shape 3
3. Move it somewhere else
4. Undo

-> Shape 1 and 3 are moved to the same position. Only shape 3 should be moved back to the original position.

Reproduced in

Version: 6.4.0.0.alpha1+
Build ID: 498c2d3944b666c2f016b65903001920db2cb2a4
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-11-08 09:14:40 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=db257d6605143813e0b75ffa878a18810c8b3412

author	Vasily Melenchuk <vasily.melenchuk@cib.de>	2019-08-15 12:08:06 +0300
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2019-08-21 00:24:58 +0200
commit	db257d6605143813e0b75ffa878a18810c8b3412 (patch)
tree	65d79181d0ebd935ab46294f005e66c610456ad1
parent	ff3cfee4ebfcb412f54f17ffccc95512fdc15c8e (diff)
sw undo/redo: avoid usage of pointers as a style references

Bisected with: bibisect-linux64-6.3

Adding Cc: to Vasily Melenchuk
Comment 2 Vasily Melenchuk (CIB) 2019-11-21 17:22:14 UTC
While this task has different scenario, reason of this problem is the same as tdf#128782.

*** This bug has been marked as a duplicate of bug 128782 ***
Comment 3 Buovjaga 2020-05-16 17:17:31 UTC
*** Bug 133069 has been marked as a duplicate of this bug. ***
Comment 4 Buovjaga 2020-05-16 17:25:07 UTC
This is still valid for 7.0.0 alpha1. However, it is fixed in master by https://git.libreoffice.org/core/+/0b0de876bad66c84a8dd0d8d19944109e59cf21a%5E!/
sw: set unique name for shape format even if shape name is empty

Vasily: can you backport that to 6.4 and 7.0?

Changing status to fixed as this was not covered by the fix for bug 128782.
Comment 5 Vasily Melenchuk (CIB) 2020-05-17 07:27:55 UTC
@Buovjaga backport for 6.4 is in gerrit https://gerrit.libreoffice.org/c/core/+/94373

For 7.0 i see no branch yet: is it already forked?
Comment 6 Buovjaga 2020-05-17 09:38:10 UTC
(In reply to Vasily Melenchuk (CIB) from comment #5)
> @Buovjaga backport for 6.4 is in gerrit
> https://gerrit.libreoffice.org/c/core/+/94373
> 
> For 7.0 i see no branch yet: is it already forked?

Ok, sorry about that: I got confused. Branching is only in 2 weeks, so the fix will be included in Beta1 anyway. Thanks for the backport!
Comment 7 Commit Notification 2020-05-18 10:55:44 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/0a4d3852794bae8887dc11613b47cb8d2c4aa829

tdf#128665: sw: set unique name for shape format

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.