Download it now!
Bug 128782 - When execute undo, Text box moves.
Summary: When execute undo, Text box moves.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All All
: high major
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: target:6.5.0 target:6.4.1 target:6.3....
Keywords: bibisected, bisected, regression
: 121914 130485 (view as bug list)
Depends on:
Blocks: Textbox Undo-Redo
  Show dependency treegraph
 
Reported: 2019-11-13 15:47 UTC by bear32
Modified: 2020-05-18 12:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Execution environment (47.57 KB, image/png)
2019-11-14 14:56 UTC, bear32
Details
Work procedure 1 (491.80 KB, image/png)
2019-11-14 14:57 UTC, bear32
Details
Work procedure 2 (660.50 KB, image/png)
2019-11-14 14:57 UTC, bear32
Details
Work procedure 3 (654.61 KB, image/png)
2019-11-14 14:58 UTC, bear32
Details
Sample Writer file (8.34 KB, application/vnd.oasis.opendocument.text)
2019-11-14 15:00 UTC, bear32
Details
This is a screen movie(mpeg4) that I tried on LibreOffice6.4 alpha1. (1.81 MB, video/x-m4v)
2019-11-14 17:40 UTC, bear32
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bear32 2019-11-13 15:47:17 UTC
Description:
Hi

In LibreOffice 6.3.3.2 Writer, when undoing the position of a text box, another text box moved.

Steps to Reproduce:
1.Insert a two textboxes. (Textbox A and Textbox B)
2.Moving Textbox B.
3.Execute Undo. (menu : edit -> undo)


Actual Results:
Textbox A moves to location of Textbox B.

Expected Results:
Textbox A keeps position


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
The same phenomenon can be seen with rectangular objects.

Thanks to LibreOffice support in Japan, it has been confirmed that it occurs in Debian and Linux and Mac.
Comment 1 Durgapriyanka 2019-11-13 16:17:42 UTC
Thank you for reporting the bug. I cannot reproduce the bug in

Version: 6.4.0.0.alpha1+ (x86)
Build ID: ec7374ff84c71edfbb30d6e4dc5b486b6df7107f
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-11-10_21:37:30
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 2 Telesto 2019-11-13 22:03:55 UTC
No repro with
Version: 6.3.0.4 (x86)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

and not with
Version: 6.4.0.0.alpha0+ (x64)
Build ID: 758516295e5f69393bd78bb4af6e7214d48ece0b
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

Putting to NEEDINFO
Comment 3 bear32 2019-11-14 14:56:44 UTC
Created attachment 155816 [details]
Execution environment
Comment 4 bear32 2019-11-14 14:57:34 UTC
Created attachment 155817 [details]
Work procedure 1
Comment 5 bear32 2019-11-14 14:57:54 UTC
Created attachment 155818 [details]
Work procedure 2
Comment 6 bear32 2019-11-14 14:58:12 UTC
Created attachment 155819 [details]
Work procedure 3
Comment 7 bear32 2019-11-14 15:00:21 UTC
Created attachment 155820 [details]
Sample Writer file
Comment 8 bear32 2019-11-14 15:05:22 UTC
Hi

Thank you for your confirmation and reply. It may be solved with 6.4.

Later, we will try the same work with 6.4 alpha version.

Added screenshots and reference files to attachments. I would be very happy if you could refer to it.

I am poor at English. I'm sorry if there is a strange writing.

best, bear32
Comment 9 bear32 2019-11-14 17:40:41 UTC
Created attachment 155824 [details]
This is a screen movie(mpeg4) that I tried on LibreOffice6.4 alpha1.
Comment 10 bear32 2019-11-14 17:45:09 UTC
Hi

I tried Libreoffice 6.4 alpha1.
But unfortunately, the same phenomenon appeared again. For more information, please check out “movie01.m4v” in the attachments.
I really like Libreoffice and support it, so I want to solve this problem and use it every day. Please cooperate to identify the cause.

best, bear32
Comment 11 QA Administrators 2019-11-15 03:36:20 UTC Comment hidden (obsolete)
Comment 12 Dieter 2019-11-20 12:51:39 UTC
I confirm it with

Version: 6.4.0.0.beta1 (x64)
Build ID: 4d7e5b0c40ed843384704eca3ce21981d4e98920
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

using steps from video in comment 9

but not in

Version: 6.1.6.3 (x64)
Build ID: 5896ab1714085361c45cf540f76f60673dd96a72
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: de-DE (de_DE); Calc: group threaded
Comment 13 Xisco Faulí 2019-11-20 16:56:56 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=09228fabe88f3457105cf26d83c003719a793114

author	Vasily Melenchuk <vasily.melenchuk@cib.de>	2019-08-15 12:08:06 +0300
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2019-08-19 11:15:22 +0200
commit	09228fabe88f3457105cf26d83c003719a793114 (patch)
tree	7a3c75f27de075dba58932fe328c7bac1961719c
parent	92d1b0d10ec04f17d116bc54aada652f1c2cac4a (diff)
sw undo/redo: avoid usage of pointers as a style references

Bisected with: bibisect-linux64-6.4

Adding Cc: to Vasily Melenchuk
Comment 14 bear32 2019-11-21 12:59:06 UTC
Hi

Thank you for confirmation.
I am not good at English. Because of my hard-to-read English, it took time to convey the phenomenon. I'm sorry.

But I am very happy. Now, LibreOffice is further improved and grows great.

Is there anything else I can contribute to?

best, bear32
Comment 15 Dieter 2019-11-21 13:26:21 UTC
(In reply to bear32 from comment #14)
> Is there anything else I can contribute to?

No, we have to wait that a developer takes this bug. But since importance is high I'm optimistic, if it doesn't take too long.
Comment 16 bear32 2019-11-21 15:05:34 UTC
Thank you for your quick reply.
I'm looking forward to seeing the developer fix it.

Thank you, bear32
Comment 17 Vasily Melenchuk (CIB) 2019-11-21 17:22:14 UTC
*** Bug 128665 has been marked as a duplicate of this bug. ***
Comment 18 Commit Notification 2019-11-27 21:44:55 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c2d689790c332ffd2f0d73de6aae53f26f0fbe53

tdf#128782: sw: assign name to draw object

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Xisco Faulí 2019-11-29 10:56:59 UTC
Hi Vasily,
The issue is sill reproducible in

Version: 6.5.0.0.alpha0+
Build ID: 63acb8cfa4d66baf48a0fe5cdc9ababb6f981666
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

using attachment 155820 [details] or recreating the file from scratch
OTOH, I do confirm bug 128665 is fixed...
Comment 20 Vasily Melenchuk (CIB) 2019-11-29 12:14:02 UTC
Initial fix was covering both tasks, but finally I reconsider and made it in a different way. And final tests were done only with one testcase.

I confirm, that this problem still exists.
Comment 21 Commit Notification 2020-01-08 09:25:41 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c79dcf98d662e76b1290f8d43c927d1031e94729

tdf#128782: sw: set name for draw frame style for text box

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2020-01-09 09:20:37 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/fa0b6fd521b917f0f002ae22b78b25530e91d0c4

tdf#128782: sw: set name for draw frame style for text box

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Vasily Melenchuk (CIB) 2020-01-10 09:16:58 UTC
Commits above are resolving only original problem (creation of document with text boxes from scratch).

Situation with loaded file (from comment#7) is not resolved yet. Bug still in progress.
Comment 24 Xisco Faulí 2020-01-10 10:30:08 UTC
(In reply to Vasily Melenchuk (CIB) from comment #23)
> Commits above are resolving only original problem (creation of document with
> text boxes from scratch).
> 
> Situation with loaded file (from comment#7) is not resolved yet. Bug still
> in progress.

Hi Vasily,
Please, also take into account bug 129382 and bug 129479
Comment 25 Commit Notification 2020-01-15 22:57:57 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/2a676d8dcf5404a0b82e9d99c66579170b1a8690

tdf#128782: sw: set name for draw frame style for text box

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Vasily Melenchuk (CIB) 2020-01-22 09:53:30 UTC
Fix https://git.libreoffice.org/core/commit/db8fdf20fbbb22e0510f0500140bbf7a3b2642f7 for tdf#129382 also should resolve problem with loaded document (document created from scratch was fixed before)
Comment 27 Xisco Faulí 2020-01-22 17:03:33 UTC
(In reply to Xisco Faulí from comment #19)
> Hi Vasily,
> The issue is sill reproducible in
> 
> Version: 6.5.0.0.alpha0+
> Build ID: 63acb8cfa4d66baf48a0fe5cdc9ababb6f981666
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> using attachment 155820 [details] or recreating the file from scratch
> OTOH, I do confirm bug 128665 is fixed...

Verified in

Version: 6.5.0.0.alpha0+
Build ID: a821d89646ef25428cf5992f86d8f31581313bdb
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Vasily, thanks for fixing this issue!!
Comment 28 Commit Notification 2020-01-22 19:52:23 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/a70f4724af04c8bf2d366bcaeb6aeffacc95b344

tdf#128782: sw: assign name to draw object

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 29 Commit Notification 2020-01-23 17:26:00 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e13f74ba563e1c82a1de587818f6090077c6f30f

tdf#128782: Add UItest

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 30 Commit Notification 2020-01-24 10:13:06 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/fd0cade5e0fc29436572799aa48f3aca789e1734

tdf#128782: sw: assign name to draw object

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 31 Commit Notification 2020-01-24 11:55:10 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/f4e6ef766ae8a69e0abb2cfd0eab8140578321b1

tdf#128782: Add UItest

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 32 Commit Notification 2020-01-24 13:14:18 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/af27265fc26b653384a36c51cda296c08f6b9813

tdf#128782: Add UItest

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 33 Xisco Faulí 2020-02-06 17:33:11 UTC
*** Bug 130485 has been marked as a duplicate of this bug. ***
Comment 34 Xisco Faulí 2020-02-13 13:01:02 UTC
*** Bug 121914 has been marked as a duplicate of this bug. ***
Comment 35 Commit Notification 2020-05-18 12:01:45 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d08d42fd7f10f2d2c1bb42dc2aed11693bd882be

tdf#128782: move UItest to CppunitTest

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.