Bug 129382 - CRASH: Importing a specific file ( See comment 6 )
Summary: CRASH: Importing a specific file ( See comment 6 )
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: target:6.5.0 target:6.4.1 target:6.3.5
Keywords: bibisected, bisected, haveBacktrace, needUITest, regression
Depends on:
Blocks:
 
Reported: 2019-12-13 17:49 UTC by Xisco Faulí
Modified: 2020-01-24 10:13 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
gdb bt (168.80 KB, text/plain)
2019-12-13 22:07 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-12-13 17:49:05 UTC
Steps to reproduce:
1. Open attachment 102915 [details] from bug 81426

-> Crash

Reproduced in

Version: 6.5.0.0.alpha0+
Build ID: a54b3e8b8b7bf063117eaed19a590ce6c8a14e07
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-12-13 17:50:12 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c2d689790c332ffd2f0d73de6aae53f26f0fbe53

author	Vasily Melenchuk <vasily.melenchuk@cib.de>	2019-11-21 20:12:52 +0300
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2019-11-27 22:43:41 +0100
commit	c2d689790c332ffd2f0d73de6aae53f26f0fbe53 (patch)
tree	ca24314df7fae483a5b0914a20699fe6609a278b
parent	e0b70b1491143adb47990b746fe0b2e52b1ee7cb (diff)
tdf#128782: sw: assign name to draw object

Bisected with: bibisect-linux64-6.5

Adding Cc: to Vasily Melenchuk
Comment 2 Xisco Faulí 2019-12-13 18:15:13 UTC
[Bug found by mass-uitesting]
Comment 3 Julien Nabet 2019-12-13 22:07:28 UTC
Created attachment 156580 [details]
gdb bt

On pc Debian x86-64 with master sources updated today, I could reproduce this
Comment 4 Julien Nabet 2019-12-13 22:11:27 UTC
If confirm that if I comment "pFormat->SetName(pDoc->GetUniqueFrameName(), false)" and add a trace, I got no crash and the trace appears several times.
Comment 5 Thorsten Behrens (CIB) 2019-12-18 17:42:22 UTC
Hmm,

void SwAsCharAnchoredObjectPosition::CalcPosition() trips over GetAnchorTextFrame() not having _any_ valid mpAnchorFrame - it even OSL_ENSUREs that. A mystery how that change could have triggered it, Cc mst.
Comment 6 Xisco Faulí 2020-01-13 10:09:00 UTC
Since https://cgit.freedesktop.org/libreoffice/core/commit/?id=08f13ab85b5c65b5dc8adfa15918fb3e426fcc3c, the file no longer crashes at import time, however it still crashes under the following steps:

1. Open attachment 102915 [details] from bug 81426
2. Select all
3. Cut
4. Paste
5. Undo 2 times
Comment 7 Xisco Faulí 2020-01-13 10:38:07 UTC
Regarding comment 6, patch in gerrit < https://gerrit.libreoffice.org/c/core/+/86520 > fixes it
Comment 8 Commit Notification 2020-01-22 09:34:46 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/db8fdf20fbbb22e0510f0500140bbf7a3b2642f7

tdf#129382: sw: assign names to shape object styles

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2020-01-22 16:59:02 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: a821d89646ef25428cf5992f86d8f31581313bdb
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Vasily, thanks for fixing this issue!!
Comment 10 Commit Notification 2020-01-23 08:36:53 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/05d8e497b3aef745a6ef21f430b4db7e3847b370

tdf#129382: sw: assign names to shape object styles

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-01-24 10:13:19 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/271629be26f2e443923c34e2f18d100e616fd772

tdf#129382: sw: assign names to shape object styles

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.