Download it now!
Bug 128676 - Icons in menus don't display in 6.2, but they display in 6.1
Summary: Icons in menus don't display in 6.2, but they display in 6.1
Status: RESOLVED DUPLICATE of bug 123265
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.8.2 release
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-08 19:21 UTC by Ron Johnson
Modified: 2019-11-09 09:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ron Johnson 2019-11-08 19:21:33 UTC
Description:
I've got 6.1.6 (from https://www.libreoffice.org/download/download/?type=deb-x86_64), and I've been upgrading in place like that for many years.

Tools->Options->LibreOffice->View->Menu "Icons in menus" is set to Automatic, and the icons display as expected.

Finally, I decided to upgrade to 6.2, and downloaded and installed 6.2.8 from https://www.libreoffice.org/download/download/?type=deb-x86_64.  After installing it, the icons do not display even though "Icons in menus" is still set to Automatic.

The problem occurred in both Calc and Writer (that's all I tried).

Steps to Reproduce:
1.  Download the debian 6.2.8 packages.
2.  Install them in Xubuntu, parallel to 6.1.
3.  Run 6.2.8.
4.  Click any drop-down menu.

Actual Results:
Menu icons do not display.

Expected Results:
Menu icons display even when "Icons in menus" is set to Automatic.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Buovjaga 2019-11-08 20:29:24 UTC
I assume this is while using the gtk3 backend (seen in Help - About). Gtk3 does not show icons in menus and LibreOffice respects this, if you use the gtk3 backend. The gtk developers made this decision some years ago and it is final.

Recently, there was a commit "hide show-icons under gtk3", which removes the confusion in options.

*** This bug has been marked as a duplicate of bug 123265 ***
Comment 2 Ron Johnson 2019-11-08 21:22:38 UTC
Looks like I'll be sticking with 6.1 for the foreseeable future.  Have you considered dropping the fascist sh*tpile that Gtk has turned into, and going to Qt5?  (As if that could be done over a long weekend...)
Comment 3 Buovjaga 2019-11-09 09:16:26 UTC
(In reply to Ron Johnson from comment #2)
> Looks like I'll be sticking with 6.1 for the foreseeable future.  Have you
> considered dropping the fascist sh*tpile that Gtk has turned into, and going
> to Qt5?  (As if that could be done over a long weekend...)

The LibreOffice UI system is agnostic about the platform, see https://docs.libreoffice.org/vcl.html
There is already a Qt5 backend, upon which is built a KDE Frameworks backend. Thanks to the work of Caolán, the Qt5/KDE UI can be made fully native as well (the menus are already native, among some other elements).

The KDE backend is available since version 6.2, but was significantly improved with the 6.3 release.

Remaining known issues for KDE can be examined here: https://bugs.documentfoundation.org/showdependencytree.cgi?id=102495&hide_resolved=1

You might try the latest and greatest using an appimage: http://libreoffice.soluzioniopen.com/index.php/daily-version/

In a terminal, I did:
chmod +x LibreOfficeDev-6.4.0.0.alpha1_2019-11-01-x86_64.AppImage
SAL_USE_VCLPLUGIN=kf5 ./LibreOfficeDev-6.4.0.0.alpha1_2019-11-01-x86_64.AppImage

It does require having Qt and plasma-framework libraries installed.

In 6.4 (unreleased), the name of the backend was changed to kf5. In 6.3, it is still called kde. So with 6.3, you would launch with SAL_USE_VCLPLUGIN=kde