Bug 123265 - Show menu icons by default in GTK3 Backend
Summary: Show menu icons by default in GTK3 Backend
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0
Keywords:
: 124170 128676 130518 131694 (view as bug list)
Depends on:
Blocks: GTK3 UI
  Show dependency treegraph
 
Reported: 2019-02-08 13:25 UTC by Rizal Muttaqin
Modified: 2020-08-23 15:24 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2019-02-08 13:25:50 UTC
I know GTK3 / GNOME 3 by default omit icon view in menu item and button but could we revert it in LibreOffice? So user have abilities to enable or disable icon view in menu item. This is critical for icon designer especially while GTK2 back end would be killed in near time
Comment 1 Rizal Muttaqin 2019-02-08 13:34:19 UTC
Update

I've found this options in Tools > Options > View

In Menu section, set Show in "Icons in menus:" and "Shortcut in context menus"

Unfortunately this options is defective: For sub menu icons are not visible at all
Comment 2 Buovjaga 2019-02-08 13:40:27 UTC
I see the icons in sub menus.
Comment 3 Caolán McNamara 2019-02-09 16:32:07 UTC
what is missing where ?
Comment 4 Buovjaga 2019-02-09 18:44:30 UTC
(In reply to Caolán McNamara from comment #3)
> what is missing where ?

The GTK3 HIG or whatever dictates that icons in menus are hidden by default. Thus, when the setting "Icons in menus" in Tools > Options > LibreOffice > View is set to Automatic, GTK3 backend hides the icons.

Do you think we should continue conforming to the HIG or change it to Show?
Comment 5 andreas_k 2019-02-11 15:02:09 UTC
I would suggest to change it to show by default in menubar.
Comment 6 Xisco Faulí 2019-02-11 16:26:59 UTC
(In reply to Buovjaga from comment #4)
> (In reply to Caolán McNamara from comment #3)
> > what is missing where ?
> 
> The GTK3 HIG or whatever dictates that icons in menus are hidden by default.
> Thus, when the setting "Icons in menus" in Tools > Options > LibreOffice >
> View is set to Automatic, GTK3 backend hides the icons.
> 
> Do you think we should continue conforming to the HIG or change it to Show?

Hi Buovjaga,
Could you please share the link to that GTK3 HIG info ?
Comment 7 Buovjaga 2019-02-11 17:04:54 UTC
(In reply to Xisco Faulí from comment #6)
> (In reply to Buovjaga from comment #4)
> > (In reply to Caolán McNamara from comment #3)
> > > what is missing where ?
> > 
> > The GTK3 HIG or whatever dictates that icons in menus are hidden by default.
> > Thus, when the setting "Icons in menus" in Tools > Options > LibreOffice >
> > View is set to Automatic, GTK3 backend hides the icons.
> > 
> > Do you think we should continue conforming to the HIG or change it to Show?
> 
> Hi Buovjaga,
> Could you please share the link to that GTK3 HIG info ?

https://igurublog.wordpress.com/2014/03/22/gtk-3-10-drops-menu-icons-and-mnemonics/
Comment 8 andreas_k 2019-02-11 17:11:47 UTC
> https://igurublog.wordpress.com/2014/03/22/gtk-3-10-drops-menu-icons-and-
> mnemonics/

This is another bug, why there is no mnemonics use in GTK3, which is also not good, but this bug is why there are no icons in the menubar.
Comment 9 Roman Kuznetsov 2019-02-14 19:36:04 UTC
(In reply to Buovjaga from comment #2)
> I see the icons in sub menus.

Because you use Gnome 3. But in Xubuntu or in any nonGTK3 DE I don't see any icons in LibreOffice menus in daily build because vcl:gtk2 was removed and I can't change show/hide icons with options in LibreOffice in this case.

I agree with Rizal
Comment 10 Rizal Muttaqin 2019-02-14 20:06:57 UTC
While GNOME 3 software tend to remove feature I think for relative complex software it's not appropriate to not showing icon in menu.
Comment 11 Heiko Tietze 2019-03-20 19:18:37 UTC
There is the request to always show because a) of complexity of the UI compared to other apps and b) we do for win, gtk2, and qt. On the other hand we don't show because of compliance with system look and feel. This is my personal opinion overruled by the majority so got for it and make the default (aka Automatic) showing the icons on gtk3.
Comment 12 Buovjaga 2019-03-21 07:32:59 UTC
(In reply to Heiko Tietze from comment #11)
> There is the request to always show because a) of complexity of the UI
> compared to other apps and b) we do for win, gtk2, and qt. On the other hand
> we don't show because of compliance with system look and feel. This is my
> personal opinion overruled by the majority so got for it and make the
> default (aka Automatic) showing the icons on gtk3.

As this looked to be turning into a "loud majority vs. conservative minority" type of thing, I started thinking, if I am going straight to Hell for defying the GNOME design gods. After a bit of digging, it seems I will at least be in good company.

The GTK3 version of GIMP shows icons in menus by default and there is not even an option to hide them. You can check this with a fresh appimage: https://github.com/aferrero2707/gimp-appimage/releases/tag/continuous The current newest build is GIMP_AppImage-git-2.99.1-20190318-x86_64.AppImage

Inkscape's GTK3 version went with an option "Yes/No/Let the Inkscape theme decide": https://bugs.launchpad.net/inkscape/+bug/1636493 Testing the appimage, I can see icons in menus, so at least the default Inkscape theme shows them: https://inkscape.org/release/inkscape-1.0alpha0/gnulinux/appimage/
Comment 13 Rizal Muttaqin 2019-03-21 10:34:10 UTC
Copied from https://bugs.launchpad.net/inkscape/+bug/1636493 (thanks Buovjaga)

Imerion (imerion) wrote on 2018-11-02: 	#17

"One man's noise is another man's critical and crucial user interface."

Agreed. It's really surprising how much faster I find the correct menu option, even in applications I've used a lot, when there is a bit of color or a few simple shapes to go by. It also helps dyslexic people and those with visual disabilities to easier find the right option. Please don't remove them!
Comment 14 Roman Kuznetsov 2019-03-22 08:56:30 UTC
*** Bug 124170 has been marked as a duplicate of this bug. ***
Comment 15 Caolán McNamara 2019-04-11 09:17:08 UTC
I'm not going to change this. Icons on/off currently follows the desktop defaults for icons on/off. It makes more sense to me to turn icons on for all apps at the desktop level rather than per-application.
Comment 16 Rizal Muttaqin 2019-10-11 09:56:00 UTC
REOPENED: As per this build the options to show icons (Icons in menus: show & Shortcuts in context menus: Show) does not make changes with GTK3 back end. If the decision was to keep application follows desktop environment please consider to give user a freedom to choose, otherwise remove this options at all.


Version: 6.4.0.0.alpha0+
Build ID: 9377ff20724b156c32728d347cdf843fe23dcd81
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-10-10_02:50:05
Locale: id-ID (id_ID.UTF-8); UI-Language: en-US
Calc: threaded
Comment 17 Rizal Muttaqin 2019-10-11 10:02:06 UTC Comment hidden (obsolete)
Comment 18 Rizal Muttaqin 2019-10-11 10:04:29 UTC Comment hidden (obsolete)
Comment 19 Buovjaga 2019-10-11 11:14:30 UTC
(In reply to Rizal Muttaqin from comment #16)
> REOPENED: As per this build the options to show icons (Icons in menus: show
> & Shortcuts in context menus: Show) does not make changes with GTK3 back
> end. If the decision was to keep application follows desktop environment
> please consider to give user a freedom to choose, otherwise remove this
> options at all.

Please open a report for this regression.
Comment 20 Commit Notification 2019-10-11 14:56:42 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0d6a64c218791156e050c2050b8070d40fdacf97

Resolves: tdf#123265 hide show-icons under gtk3

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Buovjaga 2019-11-08 20:29:24 UTC
*** Bug 128676 has been marked as a duplicate of this bug. ***
Comment 22 jEsuSdA 8) 2020-04-02 09:22:05 UTC
Hi!

Please, reconsider add this option. IMHO there are some important reasons to it:


1 - GTK3 is not only used by Gnome3. There are some other GTK desktop environments  like XFCE and these other desktop users may not be very happy with the Gnome3 guidelines (if they were, they'd probably use it).

2 - Hide menu icons is very very inconvenient for all the people like me who teach other people to use LibreOffice. I usually teach courses on LibreOffice and other FLOSS and I've never had a problem elaborating my courses documentation. I use GNU/Linux and my students usually use Windows or Mac, so, the screenshots of LibreOffice in GNU/Linux were very similar to their system. 

But now, when I take an screenshot the menu and options without icons are so different in relation with the student environment, so it is impossible to me to update my documentation.

In addition, for newbies, having an representative icon of an option it's very convenient cause they can easily identify the option and remember it. 

Finally, when I have to teach students in other languages, my screenshots are totally valid, cause the menu icons are the same in all LibreOffice languages, but with this icons removed, the screenshots are totally unusable, cause the student has to known the language of the screenshot to understand it.

Please, please, consider that. If you want more and more people using Libre Office, please, help the people to use it, and help the people like me who try teaching others to use it. 

I know Gome 3 HIG could be awesome to some people, but Libre Office is used by a large community of other kind of people. Help us grow this community instead of making it more difficult.

Please, reconsider add the Tools > Options > View > "Icons in menus:" and "Shortcut in context menus". If you want follow Gnome HIG, make this disabled by default, but do not remove at all. Removing this option does more damage than good.

Thanks.
Comment 23 Buovjaga 2020-04-02 09:27:12 UTC
Please, do not change the status again.
Comment 24 Timur 2020-04-02 11:00:49 UTC
*** Bug 130518 has been marked as a duplicate of this bug. ***
Comment 25 Buovjaga 2020-08-23 15:24:30 UTC
*** Bug 131694 has been marked as a duplicate of this bug. ***