Bug 128686 - Image not loaded in PPTX (but loaded from new PPTX created in MSO)
Summary: Image not loaded in PPTX (but loaded from new PPTX created in MSO)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-11-09 17:10 UTC by Timur
Modified: 2020-05-16 06:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2019-11-09 17:10:18 UTC
If I open 1-slide PPTX attachment 149335 [details] from Bug 123511, I don't see the image (that's JPEG).
What I see is in screenshot attachment 155658 [details] where MSO and LO 6.4+ are compared. Tested with Intel HD Graphics in Windows 8.1.
Image load issue is a regression, worked for me in LO 6.1.6, not in 6.2.8 up to 6.4+. But only with this PPTX, if I create another PPTX in MSO with the same image, it opens in LO.
Comment 1 Timur 2019-11-09 19:43:10 UTC
Also in Linux so I set All.
Comment 2 raal 2019-11-10 07:05:50 UTC
This seems to have begun at the below commit.
Adding Cc: to Tamas Bunth ; Could you possibly take a look at this one?
Thanks

2748ce4049b42768bf69f9ee7b67aff487c07e70 is the first bad commit
commit 2748ce4049b42768bf69f9ee7b67aff487c07e70
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Mon May 13 20:44:39 2019 +0200

    source sha:f4ba484183a1e7b9824f10580d633466c266828f

author	Tamas Bunth <tamas.bunth@collabora.co.uk>	2019-05-13 01:02:07 +0200
committer	Tamás Bunth <btomi96@gmail.com>	2019-05-13 18:14:26 +0200
commit	f4ba484183a1e7b9824f10580d633466c266828f (patch)
tree	5795d2c442e3dbb3496fcfd5ac6f5bd8ddc39e15
parent	8401a26363bf7cb3c30bf783b3f8978f4b69e4c4 (diff)
ooxml import: supprt cropping to shape
Comment 3 Timur 2019-11-10 13:11:52 UTC
Thanks raal.

(In reply to Timur from comment #0)
> if I create another PPTX in MSO with the  same image, it opens in LO.
When I tried to add screenshot to trouble PPTX attachment 149335 [details] in MSO, I couldn't open in LO.
When I put the same screenshot to new PPTX in MSO as attachment 155666 [details], I can open.
Comment 4 Timur 2020-03-31 09:51:32 UTC
(In reply to Timur from comment #0)
> If I open 1-slide PPTX attachment 149335 [details] from Bug 123511, I don't
> see the image (that's JPEG).
It was in 6.4.0 but no repro now with 7.0+ (image seen). 

Tamas, please comment, because there are other regressions from  f4ba484183a1e7b9824f10580d633466c266828f.
Comment 5 Timur 2020-05-15 13:28:22 UTC
0222a69b2a26b0e7d0f8538f65a6e788de9a4052 is the first *good* commit
commit 0222a69b2a26b0e7d0f8538f65a6e788de9a4052
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Mon Apr 20 22:23:44 2020 +0200

    source sha:912217285b3058efa54c2336f91fda4efdad6ff0

https://gerrit.libreoffice.org/plugins/gitiles/core/+/912217285b3058efa54c2336f91fda4efdad6ff0%5E!/

commit	912217285b3058efa54c2336f91fda4efdad6ff0	[log]
author	Serge Krot <Serge.Krot@cib.de>	Fri Apr 10 20:08:37 2020 +0200
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	Mon Apr 20 22:17:42 2020 +0200
tree	943ba044e685f9affa51d6ad86fd82348c5c8499
parent	43f0452e174d21c5d71dbb26e1243326eb9ed22e [diff]

tdf#119187 fix: Top-aligned text in PPTX becomes bottom-aligned

Change-Id: Ic6c03e512ce3f6e240d86186fb16e24c86942343
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/92051
Tested-by: Jenkins
Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>

Previous source sha:43f0452e174d21c5d71dbb26e1243326eb9ed22e