Bug 123511 - SLIDESHOW PPTX Animation does not start automatically
Summary: SLIDESHOW PPTX Animation does not start automatically
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
: 127245 (view as bug list)
Depends on:
Blocks: Object-Animations PPTX-Animations
  Show dependency treegraph
 
Reported: 2019-02-17 05:46 UTC by seven
Modified: 2021-01-25 08:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample (767.92 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-02-17 05:47 UTC, seven
Details
Sample transition compared in MSO 2013 and LO 6.4+ (102.63 KB, image/jpeg)
2019-11-09 14:51 UTC, Timur
Details
Sample animation compared in MSO 2013 and LO 6.4+ (99.75 KB, image/jpeg)
2019-11-09 14:53 UTC, Timur
Details
Sample with vortex transition (767.90 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-11-09 16:57 UTC, Timur
Details
Another sample with transition and animations (142.49 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-11-09 16:59 UTC, Timur
Details
Example file from PP with timed slide transition (33.57 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2021-01-19 12:00 UTC, NISZ LibreOffice Team
Details
Similar settings in a native odp reproducer (12.88 KB, application/vnd.oasis.opendocument.presentation)
2021-01-19 12:03 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description seven 2019-02-17 05:46:05 UTC
Description:
Animation no start automatically, but in MS office it work.

Steps to Reproduce:
LibreOffice
1. Open file
2. Start show see background and no image auto start animation
3. Press mouse buttons to activate animation

Actual Results:
Animation not start automatically

Expected Results:
Animation start automatically


Reproducible: Always


User Profile Reset: No



Additional Info:
Same report it may be already created, but for me it difficult to search. And also new sample is better to keep in new report or have different implement
Comment 1 seven 2019-02-17 05:47:02 UTC
Created attachment 149335 [details]
Sample

Show image and animation in one slide
Comment 2 Durgapriyanka 2019-02-18 16:22:48 UTC
Thank you for reporting the bug. I can confirm the bug is present in

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 3 Hiromi Kuramoto 2019-02-19 07:01:33 UTC
I confirmed it also in my environment

with:
Version: 6.2.0.2
Build ID: 2ce5217b30a543f7666022df50f0562f82be0cff
CPU threads: 4; OS: Mac OS X 10.12.5; UI render: default; VCL: osx; 
Locale: en-US (ja_JP.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Buovjaga 2019-03-05 18:29:55 UTC
Already in 3.3.0. Also tested several other versions. It seems to want to animate the "background" with the red lines first. I noticed a fade in for it in one version.
Comment 5 Timur 2019-11-09 14:51:52 UTC
Created attachment 155658 [details]
Sample transition compared in MSO 2013 and LO 6.4+

Multiple issues here. 
JPEG image is not shown so in LO we see just a background. Tested with 6.4+ in Windows 8.1, with and without OpenGL. That's the prerequisite to proceed. I'm not sure if others see the same.
PPTX has Airplane transition and Multiple animations on click: Wheel and Contract. 
Here is transition screenshot. LO has no "Airplane" transition.
Comment 6 Timur 2019-11-09 14:53:38 UTC
Created attachment 155659 [details]
Sample animation compared in MSO 2013 and LO 6.4+

Animation is recognized in LO. Not sure if correct. See bug 127245.
Comment 7 Timur 2019-11-09 15:02:20 UTC
So, I ask others to:
- compare PPTX in MSO and LO, to know if they see the image (or that's another bug with Intel HD Graphics)
- if they do see, to modify PPTX in MSO to have supported transition in order to check that transition and animation in LO
- if need be, to change animation in MSO, maybe set one by one and turn off "On click" to skip the bug I added.
Comment 8 Timur 2019-11-09 16:53:26 UTC
This is a complicated sample.
Image load issue is a regression, worked for me in LO 6.1, not in 6.2 up to 6.4+. But only with this PPTX, if I create another with the same image, it opens in LO. 
As for "SLIDESHOW PPTX Animation does not start automatically" that seems like a duplicate of bug 127245.
In LO, transition issue "Airplane" is missing. That can be a separate bug but actually all transitions should be tested and then reported all that are missing.
There's another issue here for me in LO 6.1, now that I cannot test with 6.4+ with this PPTX: even if we change missing Airplane transition to some that exists in LO such as Vortex or Dissolve and if we click manually to start slide transition, both will not work properly with animation, although they work when there are no animations.
But, to add more complexity, if I create PPTX in MSO with the same transition that exists in LO (like vortex) and add those same animations (enterance wheel and exit contract), all is working fine in 6.4+.
Comment 9 Timur 2019-11-09 16:57:35 UTC
Created attachment 155665 [details]
Sample with vortex transition
Comment 10 Timur 2019-11-09 16:59:19 UTC
Created attachment 155666 [details]
Another sample with transition and animations

Transition is vortex that exists in LO and animations are the same.
Comment 11 NISZ LibreOffice Team 2021-01-19 12:00:20 UTC
Created attachment 169007 [details]
Example file from PP with timed slide transition

This is a simplified reproducer. There is some animation set on paragraphs, which is autoplayed in PP despite their "On click" activation. 
Timed slide transition is enabled. All of these is imported correctly in Impress, but the timed slide transition does not force the autoplay of animations like in PP.
Comment 12 NISZ LibreOffice Team 2021-01-19 12:03:44 UTC
Created attachment 169009 [details]
Similar settings in a native odp reproducer

This Impress-made reproducer shows that the behavior is not the same as in PP.
There is a timed slide transition set, however this does not force the autoplay of animations set on the first slide.

Also bug #127245 is totally a duplicate of this.
Comment 13 NISZ LibreOffice Team 2021-01-19 12:05:10 UTC
*** Bug 127245 has been marked as a duplicate of this bug. ***