Bug 128756 - Incorrect restart numbering in imported DOCX
Summary: Incorrect restart numbering in imported DOCX
Status: RESOLVED DUPLICATE of bug 108496
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-12 20:05 UTC by Alexey Rukin
Modified: 2020-05-06 08:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A test file with a list (14.54 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-11-12 20:06 UTC, Alexey Rukin
Details
A simultaneous screenshot of the same file in MS Word 2019 and in Writer (349.37 KB, image/jpeg)
2019-11-12 20:07 UTC, Alexey Rukin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Rukin 2019-11-12 20:05:00 UTC
Description:
Numbered lists in imported MS Word documents are treated incorrectly if they have "restart from 1" markers on items.

Steps to Reproduce:
1. Create a file in MS Word 2007-2019.
2. Create a numbered list with 20-30 items or more.
3. Right-click on some items in the list and restart numbering from 1 (e. g. every 5 items: 1, 2, 3, 4, 5, 1, 2, 3, 4, 5, 1, 2, 3, 4, 5...).
4. Save the file in MS Word as DOCX without any compatibility options.
5. Open this file in LibreOffice.



Actual Results:
The list will be numbered: 1, 2, 3, 4, 5, 1, 6, 7, 8, 9, 1, 10, 11, 12, 13...


Expected Results:
The list must be numbered exactly as in MS Word.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.3.2.2 (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 1 Alexey Rukin 2019-11-12 20:06:10 UTC
Created attachment 155758 [details]
A test file with a list
Comment 2 Alexey Rukin 2019-11-12 20:07:07 UTC
Created attachment 155759 [details]
A simultaneous screenshot of the same file in MS Word 2019 and in Writer
Comment 3 Alexey Rukin 2019-11-12 20:09:55 UTC
This bug exists in all 6.* versions (I didn't try earlier ones), also it exists in Google Docs.
Comment 4 Alexey Rukin 2019-11-12 20:21:19 UTC Comment hidden (me-too)
Comment 5 Alexey Rukin 2019-11-12 20:22:15 UTC
One more comment: it happens if the numbering format in the MS Word file is inside a paragraph style and the whole list has this paragraph style.
Comment 6 Julien Nabet 2019-11-12 22:08:14 UTC
On pc Debian x86-64 with master sources updated today, I got:
    1. a
    2. a
    3. a
    4. a
    5. a
    6. a
    7. a
    8. a
    9. a
    10. a
    11. a
    12. a
    13. a
    14. a
    15. a
    16. a
    17. a
    18. a
    19. a
    20. a
I noticed these on console:
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
warn:legacy.osl:21213:21213:sw/source/core/doc/DocumentListItemsManager.cxx:49: <DocumentListItemsManager::addListItem(..)> - <SwNodeNum> instance already registered as numbered item!
Comment 7 Alexey Rukin 2019-11-12 22:10:02 UTC Comment hidden (obsolete)
Comment 8 Julien Nabet 2019-11-12 22:22:45 UTC
Console logs were wrong, I submitted a patch here:
https://gerrit.libreoffice.org/#/c/82560/
Of course, it doesn't fix the main pb here.
Comment 9 Julien Nabet 2019-11-12 22:24:42 UTC
(In reply to Alexey Rukin from comment #7)
> Julien Nabet 
> What happens on the release version?

With LO Debian testing package 6.3.3.2.0, I got:
    1. a
    2. a
    3. a
    4. a
    5. a
    1. a
    6. a
    7. a
    8. a
    9. a
    1. a
    10. a
    11. a
    12. a
    13. a
    1. a
    14. a
    15. a
    16. a
    17. a
It corresponds exactly to your bug now.
=> putting at NEW
Comment 10 Timur 2019-12-20 19:56:45 UTC
DOCX was never fine, from OO to LO 6.3 as written but now with LO 6.5+ different but wrong, just 1, 2, 3, 4, 5, 6, ..20.
Comment 11 Xisco Faulí 2020-05-06 08:38:44 UTC
issue fixed by https://git.libreoffice.org/core/commit/cf13fe3e6f6a40f6db064d65d4514d13a23a31f0
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 108496 ***