Download it now!
Bug 108496 - FILEOPEN: DOCX file numbered list restarted from 1 following section break assumes previous numbered list sequence after 1
Summary: FILEOPEN: DOCX file numbered list restarted from 1 following section break as...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: target:7.0.0 target:6.4.5
Keywords: filter:docx
: 128756 130635 (view as bug list)
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2017-06-13 02:28 UTC by Gabriel Bowater
Modified: 2020-11-26 06:31 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Numbered list assuming pre-page break numbering order after restarting from one DOCX (30.84 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-06-13 02:29 UTC, Gabriel Bowater
Details
Document showing different rendering under LibreOffice 5.2.2.3 and Microsoft Office 365 (93.67 KB, application/pdf)
2017-06-13 02:30 UTC, Gabriel Bowater
Details
The issue is not visible with old format .doc (57.50 KB, application/msword)
2017-09-11 14:56 UTC, Bartosz
Details
9160_minimal.docx: simplified version for debugging (29.51 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-11-16 03:18 UTC, Justin L
Details
9160_minimal.docx: word 2003 used to simplify for debugging. (31.46 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-11-17 18:44 UTC, Justin L
Details
Numbered DOX compared MSO OO LO (150.34 KB, image/png)
2019-09-06 13:48 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Bowater 2017-06-13 02:28:50 UTC
Description:
When opened under Microsoft Office attached file has a list of 1,2 on the first page and then another list of 1,2 on the second page. When opened with LibreOffice 5.2.2.3 the list on the second page has the incorrect sequence 1,3.

Steps to Reproduce:
1. Open file under LibreOffice
2. Check numbering on second page 
3. Order reads 1,3

Actual Results:  
Second numbered list assume numbers of previous list after the first "1"

Expected Results:
Second numbered list follows correct sequence 


Reproducible: Always

User Profile Reset: No - tested on multiple systems.

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36
Comment 1 Gabriel Bowater 2017-06-13 02:29:40 UTC
Created attachment 133992 [details]
Numbered list assuming pre-page break numbering order after restarting from one DOCX
Comment 2 Gabriel Bowater 2017-06-13 02:30:19 UTC
Created attachment 133993 [details]
Document showing different rendering under LibreOffice 5.2.2.3 and Microsoft Office 365
Comment 3 Xisco Faulí 2017-06-13 08:40:19 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2017-06-13 08:41:01 UTC
Sorry, I misread the steps. Confirmed in

Version: 5.5.0.0.alpha0+
Build ID: 6ab249ea6aecef5d3f35d624622a368061cad9c3
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 5 Xisco Faulí 2017-06-13 08:44:09 UTC
Also reproduced in

- Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

- Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

- LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 6 Gabriel Bowater 2017-06-14 04:30:27 UTC
Comment on attachment 133993 [details]
Document showing different rendering under LibreOffice 5.2.2.3 and Microsoft Office 365

Description should have read "LibreOffice 5.3.3.2"
Comment 8 Bartosz 2017-09-11 14:56:30 UTC
Created attachment 136175 [details]
The issue is not visible with old format .doc
Comment 9 Justin L 2017-11-16 03:18:36 UTC Comment hidden (obsolete)
Comment 10 Justin L 2017-11-17 18:44:33 UTC
Created attachment 137833 [details]
9160_minimal.docx: word 2003 used to simplify for debugging.

Contrary to what I expected, Word 2003 considers "2 Under." to be the same numId as the first two potaints, and not the same numId as the preceding point. In the original document, the numId was undefined. That suggests that MS Word stores the next number in "Numbering-Firstlevel" abstract style, not in the numId style.

Does that mean that Word and LibreOffice fundamentally treat numbering styles differently? My impression is that this particular document seems impossible to import properly without entirely re-designing numbering.

P.S. Bug 113547 is a new, unrelated, 6.0 bug that indents "1 The." differently.
Comment 11 Timur 2019-09-06 13:41:31 UTC Comment hidden (me-too)
Comment 12 Timur 2019-09-06 13:48:10 UTC
Created attachment 153990 [details]
Numbered DOX compared MSO OO LO

Same from OO to LO 6.4+ until now. 
Seems that Michael's fix in Bug 95848 changed 2nd page from "1, 3" to "3, 4".
Is it just "restart numbering" now? A duplicate?
Comment 13 Xisco Faulí 2020-02-13 11:52:12 UTC
*** Bug 130635 has been marked as a duplicate of this bug. ***
Comment 14 Xisco Faulí 2020-02-13 11:53:35 UTC
(In reply to Timur from comment #12)
> Created attachment 153990 [details]
> Numbered DOX compared MSO OO LO
> 
> Same from OO to LO 6.4+ until now. 
> Seems that Michael's fix in Bug 95848 changed 2nd page from "1, 3" to "3, 4".
> Is it just "restart numbering" now? A duplicate?

Hi Timur,
It's always good to mention the commit for reference: https://cgit.freedesktop.org/libreoffice/core/commit/?id=7992bd73a2307edce96a145e954f8e4c3ab9f57d

@Michael Stahl, I thought you might be interested in this issue
Comment 15 Xisco Faulí 2020-02-13 12:04:08 UTC
Hi Miklos,
I thought you might be interested in this issue after you recently fixed a  very similar issue ( bug 129221 )
Comment 16 Commit Notification 2020-04-22 16:04:19 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cf13fe3e6f6a40f6db064d65d4514d13a23a31f0

tdf#108496: DOCX: redesign of override in lists

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2020-04-27 20:31:40 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4ba179eb9208185406207522e39626327c7d74c3

tdf#108496: DOCX: list overrides some cleanups

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2020-05-05 20:21:14 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/76beaebdb4e45149576e3946895d77bd3054fe50

tdf#108496: DOCX: redesign of override in lists

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Xisco Faulí 2020-05-06 08:25:27 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 1eb6210d678bbb0c875f0f72b...
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Vasily, thanks for fixing this issue!!
Comment 20 Xisco Faulí 2020-05-06 08:37:51 UTC Comment hidden (obsolete)
Comment 21 Xisco Faulí 2020-05-06 08:38:44 UTC
*** Bug 128756 has been marked as a duplicate of this bug. ***