Download it now!
Bug 130446 - problem when numbering the headings 1-2-3 in docx format upon restarting the document
Summary: problem when numbering the headings 1-2-3 in docx format upon restarting the ...
Status: RESOLVED DUPLICATE of bug 76817
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chapter-Numbering DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2020-02-05 03:35 UTC by shariqkeen
Modified: 2020-07-08 07:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample ODT (8.92 KB, application/vnd.oasis.opendocument.text)
2020-05-07 11:01 UTC, Timur
Details
Sample ODT saved as DOCX and changed in LO and MSO (38.93 KB, image/png)
2020-05-07 11:02 UTC, Timur
Details
gif 1 (316.54 KB, image/gif)
2020-06-25 21:48 UTC, shariqkeen
Details
gif 2 (331.28 KB, image/gif)
2020-06-25 21:49 UTC, shariqkeen
Details
gif 3 (248.39 KB, image/gif)
2020-06-25 21:50 UTC, shariqkeen
Details
introducing heading above issue (5.05 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-06-25 21:51 UTC, shariqkeen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description shariqkeen 2020-02-05 03:35:06 UTC
Description:
problem when numbering the headings 1-2-3, as described here in this screenshot video https://drive.google.com/open?id=19GVYu6Aw8MQqFd5JKR5qafng8RoAXcn5 

problem description according to what is shown in video: on reopening the doc, i achieved the numbers 3 and 3.1 only after clicking the update button, but that too didnt work the next time on reopening as numbering wasnt present and after i switched on the numbering again manually it was the number 4 for every outline level ie heading 1-2-3

happens everytime, create any doc and reopen office once and twice for both observations in succession

problem occurs only with docx and not odt, using tools->chapter numbering still has issue though a little different.

after numbering using tools->chapter numbering for docx format: on first doc restart- numbering updates after clicking 'update selected style' and same number gets stuck for every level newly entered as can be seen in this video https://drive.google.com/open?id=13q4uG3xV_BtsU1y2O2TCQwHjaP6q32_Y 

discussion at https://ask.libreoffice.org/en/question/227835/problem-when-numbering-the-headings-1-2-3-in-docx-format-upon-restarting-the-document/

 observed in linux and MS.

Steps to Reproduce:
1.save doc in docx format after turning on numbering for the the headings 1-2-3 either from tools->chapter numbering or directly from bullet numbering button
2. restart office and reopen the docx file and enter new headings after the previous ones. the new headings dont take the numbering according to the previously present headings but restarts from number 1
3. clicking the 'update selected style' button fixes the issue for one time but that too doesnt work if doc is reopened/restarted or upon entering new headings after clicking 'update selected style' on next reopen. if not number 1, headings of all outline level take a same number after 2nd restart or after clicking 'update selected style' button on 2nd restart.

Actual Results:
numbering restarts from 1 on 1st restart. if not number 1, headings of all outline level take a same number after 2nd restart or after clicking 'update selected style' button on 2nd restart.

Expected Results:
heading number should start in continuity to previously present headings and not from one. if headings upto number 6 is present then new heading must take the number 7 or whatever applies to that outline level in similar way.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
heading number should start in continuity to previously present headings and not from one. if headings upto number 6 is present then new heading must take the number 7 or whatever applies to that outline level in similar way.

discussion at https://ask.libreoffice.org/en/question/227835/problem-when-numbering-the-headings-1-2-3-in-docx-format-upon-restarting-the-document/
Comment 1 Dagmara 2020-02-05 11:47:45 UTC
Works ok with version:
Version: 6.4.0.1 (x64)
Build ID: 1b6477b31f0334bd8620a96f0aeeb449b587be9f
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: pl-PL (pl_PL); UI-Language: en-US
Calc: threaded
Comment 2 Dieter 2020-02-05 17:59:38 UTC Comment hidden (obsolete)
Comment 3 shariqkeen 2020-02-06 02:18:18 UTC
currently at 6.4 version but know this bug since some time, at least some 6.3.x. Observed on Linux and i think i remember on MS too from the time i first knew it.
Comment 4 shariqkeen 2020-02-06 02:19:09 UTC Comment hidden (obsolete)
Comment 5 shariqkeen 2020-02-06 02:23:21 UTC
(In reply to Dagmara from comment #1)
> Works ok with version:
> Version: 6.4.0.1 (x64)
> Build ID: 1b6477b31f0334bd8620a96f0aeeb449b587be9f
> CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
> Locale: pl-PL (pl_PL); UI-Language: en-US
> Calc: threaded

I'm new and dont understand whats meant by 'works ok'. is bug working ok being reproducible and is therefore present OR LO working ok and bug not observed?
Comment 6 Mike Kaganski 2020-02-06 07:54:29 UTC
Reproducible (expectedly) with e.g. Version: 6.4.0.3 (x64)
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: CL

Steps:

1. In new text document, add three paragraphs: "a", "b", and "c".
2. Set the first two paragraphs ("a" and "b") to Heading 1 paragraph style.
3. In Tools->Chapter Numbering, select "1-10" on "Numbering" tab, and set "Number" to "1,2,3" and "Show sublevels" to 10

=> See that the first two paragraphs are now numbered 1 and 2.

4. Save as ODCX and reload
5. Set third paragraph ("c") to Heading 1.

=> see that it's numbered by number 1, not by number 3.

That's because DOCX does not have a chapter numbering feature, and we export that as simple numbering, then using different numbering styles for imported headings and new headings. We need to find out how Word manages chapter numbering, and export/import that properly.
Comment 7 shariqkeen 2020-04-02 02:53:22 UTC
might be duplicate of bug 76817

description strikingly similar to Bug 121066 so at least must be duplicate of that which in turn is again duplicate of bug 76817

Bug 107683 might help to solve-not sure
Comment 8 Xisco Faulí 2020-05-06 08:37:51 UTC
issue fixed by https://git.libreoffice.org/core/commit/cf13fe3e6f6a40f6db064d65d4514d13a23a31f0
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 108496 ***
Comment 9 shariqkeen 2020-05-07 00:25:55 UTC
not fixed and reproduced in:

1: Version: 7.0.0.0.alpha0+
Build ID: fdaf4761bc106d7443ff95491...
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-GB (en_IN); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-05-05_17:49:07
Calc: threaded

and

2: Version: 6.4.5.0.0+
Build ID: efa7329fd9d71b75e10a2a5a8fd24bbe1a23fe66
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-4, Time: 2020-05-06_02:46:27
Locale: en-GB (en_IN); UI-Language: en-US
Calc: threaded

so not resolved contrary to the bug 108496, of which it is marked as duplicate.
Comment 10 Timur 2020-05-07 11:01:14 UTC
Created attachment 160489 [details]
Sample ODT

Reproduced with LO 7.0+.
Probably a duplicate of See Also.
Description wasn't simple with sample and steps.
I add ODT sample from comment 6, before saving and reloading DOCX.
Comment 11 Timur 2020-05-07 11:02:18 UTC
Created attachment 160490 [details]
Sample ODT saved as DOCX and changed in LO and MSO

Screenshot per comment 6.
Comment 12 Timur 2020-06-25 10:22:30 UTC
ODT sample from comment 6 is now OK when saved as DOCX and reopened. I mark this as a duplicate.

Description wasn't simple with attached minimal sample and steps, so I don't know if something else remains. Needs to be tested with master LO (which has the fix) and that is now 7.1+.

*** This bug has been marked as a duplicate of bug 76817 ***
Comment 13 shariqkeen 2020-06-25 21:48:44 UTC
Created attachment 162415 [details]
gif 1
Comment 14 shariqkeen 2020-06-25 21:49:35 UTC
Created attachment 162416 [details]
gif 2
Comment 15 shariqkeen 2020-06-25 21:50:21 UTC
Created attachment 162417 [details]
gif 3
Comment 16 shariqkeen 2020-06-25 21:51:12 UTC
Created attachment 162418 [details]
introducing heading above issue
Comment 17 shariqkeen 2020-06-25 21:52:51 UTC
Thank you very much, It seems to be partially fixed, verified in

Version: 7.1.0.0.alpha0+
Build ID: e69f547bce7de376a0af464c5f7af5e7d2c8784a
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-IN (en_IN); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-06-23_15:52:52
Calc: threaded

What still not fixed is: on reopening docx, when a new heading is introduced just above another heading, and if the level of the new heading is different from the heading below, then the heading below doesn't get updated.

For example, introduce heading 1/3 above heading 2 (heading 2 doesn't update). Or introduce heading 1/2/3 above heading 4 (heading 4 doesn't update).

Though it happens only the first time at a specific location, if the same heading is tinkered just one more time then everything gets updated correctly for that location. But i saw other locations still remain without getting updated, if multiple such instances are kept.

gifs and sample doc attached in previous comments.
Comment 18 shariqkeen 2020-06-26 01:39:56 UTC
most likely, it got partially fixed by the very recent fix of bug 76817
Comment 19 Timur 2020-06-26 16:13:20 UTC
(In reply to shariqkeen from comment #13)
> Created attachment 162415 [details]
> gif 1

That looks like bug 134294.
Comment 20 shariqkeen 2020-06-26 16:37:46 UTC
(In reply to Timur from comment #19)
> (In reply to shariqkeen from comment #13)
> > Created attachment 162415 [details]
> > gif 1
> 
> That looks like bug 134294.

oh no! that happens in odt too. i thought it was only with docx. then it's a very severe critical bug i think.
Comment 21 shariqkeen 2020-06-26 16:42:14 UTC
by the way, excluding bug 134294 thing, rest has been verified fixed in Linux 7.1 alpha as in comment 17.
Comment 22 Alan Lucas 2020-06-29 20:44:54 UTC
Hi; This bug is not resolved. I am using version 6.4.4.2 in Linux and the stable version in Windows (6.3.6.2). The following causes the numbering problem:
* Create numbered headings using chapter numbering
* save as docx and exit
* reopen the file
* insert a new heading
Bug: The new heading always starts with a number of 1.
I fix this by clicking on the heading that I have entered; then right click on "Bullets and Numbering" and choose option "Restart Numbering".
I then save this as a docx and reopen it in Microsoft Word (365). I insert a new heading and then, lo and behold, this new heading starts at 1 too. To fix this in Word I click Home then select the "Multilevel List" option and then I select a Heading list (or I create my own multi-level list). Basically, the libreoffice document that was sent to Word had the wrong type of list (i.e. not a "Heading" list)
The above might not seem like a major problem because it is a workaround. However, the bug is CRITICAL (I cannot change it to this as I do not have authority) because it stops all collaboration on documents with numbered headings between Libreoffice and Word, as I cannot ask my clients to fix numbering problems caused by Libreoffice when they are working in Word. Given that most businesses rely on numbered headings to docx formatted documents this makes it generally impossible to use Libreoffice in a shared business environment. Also, often I receive client documents in docx format I am expected to review them and make changes in docx format - not ODT format. 
Hope this helps as a clarification.
Just to say - this cannot be insuperable as Softmake Office has resolved the docx heading numbering.
Comment 23 shariqkeen 2020-06-30 01:35:40 UTC
(In reply to Alan Lucas from comment #22)
> Hi; This bug is not resolved. I am using version 6.4.4.2 in Linux and the
> stable version in Windows (6.3.6.2). The following causes the numbering
> problem:
> * Create numbered headings using chapter numbering
> * save as docx and exit
> * reopen the file
> * insert a new heading
> Bug: The new heading always starts with a number of 1.
> I fix this by clicking on the heading that I have entered; then right click
> on "Bullets and Numbering" and choose option "Restart Numbering".
> I then save this as a docx and reopen it in Microsoft Word (365). I insert a
> new heading and then, lo and behold, this new heading starts at 1 too. To
> fix this in Word I click Home then select the "Multilevel List" option and
> then I select a Heading list (or I create my own multi-level list).
> Basically, the libreoffice document that was sent to Word had the wrong type
> of list (i.e. not a "Heading" list)
> The above might not seem like a major problem because it is a workaround.
> However, the bug is CRITICAL (I cannot change it to this as I do not have
> authority) because it stops all collaboration on documents with numbered
> headings between Libreoffice and Word, as I cannot ask my clients to fix
> numbering problems caused by Libreoffice when they are working in Word.
> Given that most businesses rely on numbered headings to docx formatted
> documents this makes it generally impossible to use Libreoffice in a shared
> business environment. Also, often I receive client documents in docx format
> I am expected to review them and make changes in docx format - not ODT
> format. 
> Hope this helps as a clarification.
> Just to say - this cannot be insuperable as Softmake Office has resolved the
> docx heading numbering.

Hi there, good to know u facing the same problem as me. most likely this issue got fixed by the fix of bug 76817, visit bug 76817 yourself to see that it will be available from version 7.0. u hv checked in 6.4.4.2 and 6.3.6.2 which havent got the fix and so issue obviously is there. wait till 7.0 which will come after the next release of 6.4.5 i think. u can download unstable 7.0 or 7.1 to check urself from https://dev-builds.libreoffice.org/daily/

*** This bug has been marked as a duplicate of bug 76817 ***
Comment 24 Alan Lucas 2020-07-01 22:23:20 UTC
Thanks for the reply
I'll follow up your suggestions and post the results
Cheers
Comment 25 Alan Lucas 2020-07-02 22:00:07 UTC
Hi
The bug is still there in version 7.0.0.0. However, it appears that an attempt to fix it has recently been made in 7.0.0.1. As soon as this becomes available I will try it out and re-test the interplay between Libreoffice and Word.
Comment 26 shariqkeen 2020-07-05 22:32:48 UTC
(In reply to Alan Lucas from comment #25)
> Hi
> The bug is still there in version 7.0.0.0. However, it appears that an
> attempt to fix it has recently been made in 7.0.0.1. As soon as this becomes
> available I will try it out and re-test the interplay between Libreoffice
> and Word.

veried fixed in:

Version: 7.0.0.1.0+
Build ID: 74d3471e74478a18c5a54ed4e9be83a5c0aadd8b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-IN (en_IN); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-7-0, Time: 2020-07-04_19:10:18
Calc: threaded
Comment 27 Alan Lucas 2020-07-08 07:27:25 UTC
Thanks for this. I am running Debian and Fedora. I have tested the Debian version:
Version 7.0.0.1.0+
https://git.libreoffice.org/core/+log/a5f95804c1a730fb393c33b49e6fbe0f5a5e9eac
2020-07-05: 20:25:33
I picked this up from the pre-release version on the Libreoffice website.
I have tested the change backwards and forwards from Libreoffice to Word (my Word is from Office 365 on a Windows 10 machine). All seems to be working well and I am very pleased with the bug fix. Thanks you for responding so quickly on this.
Best Regards