Bug 130635 - FILEOPEN: DOCX: Incorrect list numbers displayed for docx with a theme
Summary: FILEOPEN: DOCX: Incorrect list numbers displayed for docx with a theme
Status: RESOLVED DUPLICATE of bug 108496
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks:
 
Reported: 2020-02-13 11:02 UTC by Simon Gaeremynck
Modified: 2020-02-13 11:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Docx file that renders incorrectly (34.96 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-02-13 11:03 UTC, Simon Gaeremynck
Details
Docx file that renders correctly -- no theme (13.29 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-02-13 11:03 UTC, Simon Gaeremynck
Details
Generated PDF with incorrect lists (62.10 KB, application/pdf)
2020-02-13 11:04 UTC, Simon Gaeremynck
Details
Comparison MSO 2010 and LibreOffice 7.0 master (99.50 KB, image/png)
2020-02-13 11:31 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Gaeremynck 2020-02-13 11:02:14 UTC
Description:
The attached document renders everything but the first list incorrectly. This can be seen in both the editor as the PDF export.

Actual Results:
Renders:

List up to 2
    1. Point 1
    2. Point 2
List up to 3
    1. Point 1
    3. Point 2
    4. Point 3

Expected Results:
Expected:

List up to 2
    1. Point 1
    2. Point 2
List up to 3
    1. Point 1
    2. Point 2
    3. Point 3


Reproducible: Always


User Profile Reset: Yes



Additional Info:
A similar document without a theme renders correctly.
Comment 1 Simon Gaeremynck 2020-02-13 11:03:06 UTC
Created attachment 157832 [details]
Docx file that renders incorrectly
Comment 2 Simon Gaeremynck 2020-02-13 11:03:33 UTC
Created attachment 157833 [details]
Docx file that renders correctly -- no theme
Comment 3 Simon Gaeremynck 2020-02-13 11:04:20 UTC
Created attachment 157834 [details]
Generated PDF with incorrect lists
Comment 4 Xisco Faulí 2020-02-13 11:31:48 UTC
Created attachment 157835 [details]
Comparison MSO 2010 and LibreOffice 7.0 master

Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: f4b6f6a8ae60bdec53512728d00853b73fa18500
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2020-02-13 11:45:52 UTC
Actually the document has different problems....
Let's use this ticket to deal with one of them: Numbering is not restarted

Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=7992bd73a2307edce96a145e954f8e4c3ab9f57d

author	Michael Stahl <Michael.Stahl@cib.de>	2019-09-03 13:49:57 +0200
committer	Michael Stahl <Michael.Stahl@cib.de>	2019-09-04 10:40:26 +0200
commit 7992bd73a2307edce96a145e954f8e4c3ab9f57d (patch)
tree 0a32009be41014940f66fca0f4f6e899f6fcbbd1
parent a9e098aa4e66c771642b26527e3e48c48c428574 (diff)
tdf#95848 writerfilter: DOCX import: fix mapping of w:abstractNum

Bisected with: bibisect-linux64-6.4

Adding Cc: to Michael Stahl

For reference, see the pdf attached, every list starts with 1.
Comment 6 Xisco Faulí 2020-02-13 11:52:12 UTC
actually it's a duplicate of bug 108496

*** This bug has been marked as a duplicate of bug 108496 ***