Bug 128799 - Numbers on the vertical axis of Calc Graphs go crazy when moving when moving the core "graph" object inside the picture
Summary: Numbers on the vertical axis of Calc Graphs go crazy when moving when moving ...
Status: RESOLVED DUPLICATE of bug 117088
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2019-11-14 13:06 UTC by Andy
Modified: 2019-12-11 15:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The vertical scale numbers are already corrupted here: negative values are gone, while positive show up but with one decimal digit insted of the 2 that are set to appear (14.28 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-11-14 13:08 UTC, Andy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy 2019-11-14 13:06:06 UTC
Description:
When editing a graph in Calc, you can select and move around in the space covered by the picture the main object it where lines or rectangles are shown. However, when you do this, the numbers showing the metric on the Y-axis do not always stay in the format you set: sometimes they disappear altogether or in part, or change format with unpredictable results

Steps to Reproduce:
1.Open the attached file. In it you'll find a few data and a graph displaying them. Double click on it to edit.
2. Now click on any point in the space between the two axis, to select the main part of the graph inside the figure. Drag and move it around repeatedly and in a casual fashion.
3.when you stop dragging and release, sometimes the look of the graph remains correct, but in other apparently random instances the numbers visible alongside the vertical axis disappear, or lose some decimals, or corrupt in some way. Dragging the object again, they can be restored or not, the way this works is difficult to grasp

Actual Results:
numbers on the vertical axis can become corrupted when dragging the graph object inside the picture.

Expected Results:
Such numbers should not change in any way when moving the graph object around


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Andy 2019-11-14 13:08:08 UTC
Created attachment 155813 [details]
The vertical scale numbers are already corrupted here: negative  values are gone, while positive show up but with one decimal digit insted of the 2 that are set to appear
Comment 2 NISZ LibreOffice Team 2019-11-19 15:31:36 UTC
Can confirm with:
Version: 6.5.0.0.alpha0+ (x64)
Build ID: 7e09d08807b5ba2fd8b9831557752a415bdad562
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: en-US (hu_HU); UI-Language: en-US
Calc: CL

Verzió: 6.1.0.3
Build az.: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU szálak: 4; OS: Windows 6.3; Felületmegjelenítés: GL; 
Területi beállítások: hu-HU (hu_HU); Calc: CL

But not with:
Verzió: 6.0.0.3
Build az.: 64a0f66915f38c6217de274f0aa8e15618924765
CPU szálak: 4; OS: Windows 6.3; Felületmegjelenítés: alapértelmezett; 
Területi beállítások: hu-HU (hu_HU); Calc: CL
Comment 3 NISZ LibreOffice Team 2019-11-19 16:53:08 UTC
Bibisected using bibisect-win32-6.1 to:

224daefae162fbe1cd5f6a4f33c5dcef804b5ccb is the first bad commit
commit 224daefae162fbe1cd5f6a4f33c5dcef804b5ccb
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sun Mar 4 03:21:46 2018 -0800

    source sha:35d062f7879d5414334643cb90bff411726b2168

https://cgit.freedesktop.org/libreoffice/core/commit/?id=35d062f7879d5414334643cb90bff411726b2168

author	Szymon Kłos <szymon.klos@collabora.com>	2018-03-02 10:39:33 +0100
committer	Szymon Kłos <szymon.klos@collabora.com>	2018-03-04 12:11:09 +0100

tdf#116163: Limit label height in chart if needed

Adding CC to: Szymon Kłos
Comment 4 Xisco Faulí 2019-12-11 15:52:11 UTC
Seems to be a duplicate of bug 117088

*** This bug has been marked as a duplicate of bug 117088 ***