Download it now!
Bug 128849 - Add new Breeze-Dark SVG / Sifr-Dark SVG icons
Summary: Add new Breeze-Dark SVG / Sifr-Dark SVG icons
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:6.5.0 target:6.4.1 target:7.0....
Keywords:
: 129946 (view as bug list)
Depends on:
Blocks: Icon-Theme-Breeze Icon-Request Icon-Theme-Sifr
  Show dependency treegraph
 
Reported: 2019-11-17 03:15 UTC by Thiago Sueto
Modified: 2020-02-23 05:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thiago Sueto 2019-11-17 03:15:48 UTC
Description:
A user named Carla Rossetti over the Facebook group "KDE Neon Users" modified Breeze SVG and Sifr SVG to create correspondent dark versions for their own use (because the non-SVG version wouldn't look correct under 4K resolution).
They are okay with it being upstreamed to LibreOffice.
Please take a look: https://github.com/primuladimaggio/libreoffice-dark-icons-svg

Actual Results:
 

Expected Results:
 


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2019-11-17 11:45:37 UTC
Rizal, Andreas?
Comment 2 Rizal Muttaqin 2019-11-17 13:01:11 UTC
Thank you for your information. This request used to came to my mind sometimes and this report confirm that actually user does need it. Would you mind if I ask the script to create the Breeze & Sifr SVG dark variant? We are very welcome if people want to give more hands also :)
Comment 3 Thiago Sueto 2019-11-19 12:04:24 UTC
Here is precisely what Carla said.

"Hi, Thiago Sueto. It's, simple. Unpack the light icon archives. On terminal I used two commands :

#For sifr_dark
find . -type f -name "*.svg" -exec sed -i'' -e 's/#555753/#eff0f1/g' {} +

#For breeze_dark
find . -type f -name "*.svg" -exec sed -i'' -e 's/#232629/#eff0f1/g' {} +

Pack and rename."
Comment 4 Luca Carlon 2020-01-09 11:48:21 UTC
Is anyone in charge of this? Can I have a look?
Comment 5 Luca Carlon 2020-01-11 10:23:04 UTC
I uploaded a patch to include the new set (https://gerrit.libreoffice.org/c/core/+/86590). I created it using the bash line provided, but I had to fix some manually cause the dark fill color was actually black.
Comment 6 Rizal Muttaqin 2020-01-12 02:45:42 UTC
(In reply to Luca Carlon from comment #5)
> I uploaded a patch to include the new set
> (https://gerrit.libreoffice.org/c/core/+/86590). I created it using the bash
> line provided, but I had to fix some manually cause the dark fill color was
> actually black.

https://gerrit.libreoffice.org/c/core/+/86581

Sorry for being late to response. I have send a patch also and especially for Breeze I have already a script in my Github repo to change the color which based on official KDE VDG color choice. So, not following Comment 3 here.


https://github.com/rizmut/libreoffice-style-breeze/blob/master/build.sh

For Sifr, the script was created against PNG version which is basically negating the bitmap I should find exact color code for this so the patch has not available yet.
Comment 7 Luca Carlon 2020-01-12 11:06:34 UTC
I'm sorry, but I downloaded your patch and it is almost identical to mine, except it arrived much afterwards. I don't see a different color, I see the fill is #eff0f1. I'm using breeze dark on my KDE desktop, and I see the color is #eff0f1. What is the reason for another patch instead of reviewing mine that I uploaded first?
Comment 8 Luca Carlon 2020-01-12 11:10:58 UTC
Sorry, I see your first patch arrived first but you just didn't reference it here. However I see your patch has not satisfied jenkins. Mine passed jenkins.
Comment 9 Rizal Muttaqin 2020-01-12 16:24:50 UTC
(In reply to Luca Carlon from comment #7)
> I'm sorry, but I downloaded your patch and it is almost identical to mine,
> except it arrived much afterwards. I don't see a different color, I see the
> fill is #eff0f1. I'm using breeze dark on my KDE desktop, and I see the
> color is #eff0f1. What is the reason for another patch instead of reviewing
> mine that I uploaded first?

We are not in a competition here, I just want to make sure that we have same color code here. So for Breeze version, I will follow yours.

Will comment on you patch afterward
Comment 10 V Stuart Foote 2020-01-12 22:34:28 UTC
*** Bug 129946 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2020-01-20 11:11:49 UTC
Luca Carlon committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/00f742cace19a8d13550eeb242a4e18bce571645

tdf#128849: Added svg version of the breeze dark icon set.

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-01-22 22:12:01 UTC
rizmut committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/54368ea4b13bfb1437459d3a3b5bc009d263079b

Breeze & Sifr: tdf#128849 & Sifr: tdf#129846

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-01-28 12:53:21 UTC
rizmut committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/482bb2085cecdd9861ba6c48098bbfe0ab2adf8c

Sifr: Added SVG version of the Sifr Dark icon set (tdf#128849).

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-02-22 03:09:44 UTC
rizmut committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4617a5b7ded7f5d0c67087d204e05a991a50ee41

tdf#128849 -- Add Sifr (Dark + SVG) to the icon theme list

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-02-22 15:18:05 UTC
rizmut committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/0273fa1e6d4a724a7d2bad062c142970038bec38

tdf#128849 -- Add Sifr (Dark + SVG) to the icon theme list

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.