Bug 129007 - Calc - names beginning with underscore no longer work
Summary: Calc - names beginning with underscore no longer work
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.5.0 target:6.4.0.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-11-25 08:54 UTC by David Lynch
Modified: 2019-12-18 10:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Lynch 2019-11-25 08:54:14 UTC
Description:
in A1 enter "_R"
in B1 enter 2
highlight A1 and B1
Sheet -> Named Ranges and Expressions -> Create... [OK]
in C3 enter =3*_R
result is "_R" not 6
This used to work about a year ago.
Version: 6.3.3.2 (x64)
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-GB
Calc: threaded


Steps to Reproduce:
see above

Actual Results:
see above

Expected Results:
see above


Reproducible: Always


User Profile Reset: Yes



Additional Info:
see above
Comment 1 Mike Kaganski 2019-11-25 09:31:52 UTC
Confirmed; the [_R] suggested by autoinput replaces everything until a space; so e.g. writing "=3* _R" then Enter succeeds.

Tested with Version: 6.3.3.2 (x64)
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 12; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 2 Mike Kaganski 2019-11-25 10:05:47 UTC
It's already bad in 4.4.0.1; it fails differently in 4.3.0.4: it replaces "=3*_R" with "=3*__R" (inserts second underscore, as if it only considers single character "R" when replacing with the suggested word).

Since the range where the current wrong behaviour is determined, marking it regression bibisectrequest. Note that last year's releases couldn't work, because 4.4 was released back in 2015, and all following releases had that problem.
Comment 3 Xisco Faulí 2019-11-26 12:37:38 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2019-11-29 16:16:13 UTC
(In reply to Mike Kaganski from comment #2)
> It's already bad in 4.4.0.1; it fails differently in 4.3.0.4: it replaces
> "=3*_R" with "=3*__R" (inserts second underscore, as if it only considers
> single character "R" when replacing with the suggested word).

The replacement problem was introduced in range https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=3ddae832bbb71306a574c4e1087de0a0da318966..45bdefccfc532d73bed2f8182543e13a18a7ac1c

Most likely related to bug 75264
Comment 5 Xisco Faulí 2019-11-29 16:31:06 UTC
The actually behaviour started after:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9fc83ae4e479f7e6784dfdce87de35c283fbadd2

author	Winfried Donkers <winfrieddonkers@libreoffice.org>	2014-08-07 11:37:02 +0200
committer	Markus Mohrhard <markus.mohrhard@googlemail.com>	2014-08-07 15:46:18 +0000
commit	9fc83ae4e479f7e6784dfdce87de35c283fbadd2 (patch)
tree	60d2ddd1a56fe477ef2dcb83d8726dd23cd34f4b
parent	38a3d53d8b9e6dd66c19f721be9b4b3e350eb249 (diff)
fdo#82241 fix autocompletion for calc functions with

Bisected with: bibisect-44max

Adding Cc: to Winfried Donkers
Comment 6 Mike Kaganski 2019-11-29 19:13:44 UTC
https://gerrit.libreoffice.org/84087
Comment 7 Commit Notification 2019-11-29 20:21:44 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d997addd504c92fea58cf62fddc2b1e9b8216a7d

tdf#129007: fix autocompletion

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Mike Kaganski 2019-11-29 20:22:16 UTC
(In reply to Xisco Faulí from comment #5)

Thank you for bibisection! That helped tremendously!
Comment 9 Xisco Faulí 2019-11-30 17:24:01 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: 47dd2c63f649828a833543e21d4eca5866ec9ebe
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Mike, thanks for fixing this issue!
Comment 10 Commit Notification 2019-12-18 10:08:41 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/e56a2c67bd0cc6204ec50eae619c907c9026e9cc

tdf#129007: fix autocompletion

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.