Bug 129065 - Incorrect formatting of a Word .docx with a label table in one particular document
Summary: Incorrect formatting of a Word .docx with a label table in one particular doc...
Status: RESOLVED DUPLICATE of bug 123435
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.3.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-11-27 18:06 UTC by Michael Barwise
Modified: 2019-11-29 15:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File with bug (79.70 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-11-27 18:09 UTC, Michael Barwise
Details
Similar file without bug (84.14 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-11-27 18:10 UTC, Michael Barwise
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Barwise 2019-11-27 18:06:10 UTC
Description:
On opening a docx with a label table, only one of the cells contains information, but they should all have the same info.  But it opens (and was created) using Word 2013.  I can open another docx with a label table without any issue.

Steps to Reproduce:
1.Try to open the attached file
2.Only the bottom right cell has data, but they should all be the same as it
3.

Actual Results:
Only bottom right hand cell contains data

Expected Results:
All cells should contain the same data


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.2.2
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 4; OS: Mac OS X 10.15.1; UI render: default; VCL: osx; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Michael Barwise 2019-11-27 18:09:16 UTC
Created attachment 156155 [details]
File with bug
Comment 2 Michael Barwise 2019-11-27 18:10:11 UTC
Created attachment 156156 [details]
Similar file without bug
Comment 3 Alex Thurgood 2019-11-28 07:20:30 UTC
In Word 16.31 (2019), both DOCX documents display a full page of labels.

With 
Version: 6.5.0.0.alpha0+
Build ID: 8d23959b9eb014b625e3d7a8ee8aea51cdc6abbf
CPU threads: 4; OS: Mac OS X 10.15.1; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded

The first document displays a label in the bottom right hand corner only.

The second document displays a full page of labels.

Confirming.
Comment 4 Alex Thurgood 2019-11-28 07:32:23 UTC
Running the "file" command in the terminal on both docx files indicates that they are both Microsoft Word 2007+ format.

FWIW, Apple Pages 8.2.0 is incapable of displaying either of the files, all of the objects in the cells are removed, leading to a blank document (nice little error message though).
Comment 5 Alex Thurgood 2019-11-28 07:35:28 UTC
Both documents open correctly with full page display of labels in

Version: 5.2.7.2
Build ID: 2b7f1e640c46ceb28adf43ee075a6e8b8439ed10
Threads CPU : 4; Version de l'OS :Mac OS X 10.15.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group

==> regression
Comment 6 Alex Thurgood 2019-11-28 07:47:17 UTC
Testing up to 6.2.8.2 shows that the buggy document displays fine.

Only from 6.3.x does it fail to display correctly.
Comment 7 Timur 2019-11-28 10:01:43 UTC
Repro also Win so OS is All.
Comment 8 Xisco Faulí 2019-11-29 15:27:29 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=3272c1eb5563f3bda2caa24f32b1018372622109
Closing as a duplicate of bug 123435

*** This bug has been marked as a duplicate of bug 123435 ***