Download it now!
Bug 129125 - Dialogs called by the grid (com.sun.star.awt.grid.UnoControlGrid) have to be closed twice
Summary: Dialogs called by the grid (com.sun.star.awt.grid.UnoControlGrid) have to be ...
Status: RESOLVED DUPLICATE of bug 127921
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-01 10:25 UTC by joesch04
Modified: 2019-12-01 14:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
testfile for reproducing the bug (18.70 KB, application/vnd.oasis.opendocument.text)
2019-12-01 10:29 UTC, joesch04
Details

Note You need to log in before you can comment on or make changes to this bug.
Description joesch04 2019-12-01 10:25:50 UTC
Description:
A dialog (or Msgbox) started from a grid is only terminated by closing it twice.

A commented example is in the attached file.

Steps to Reproduce:
1. Start a dialog with included Grind control (for which a mouse listener is registered)
2. double-click the grid to call a second dialog or Msgbox by event
3. Try to close the second dialog (or the Msgbox)

A commented example is in the attached file.

Actual Results:
The dialogue (the Msgbox) closes only after it has been closed twice.

Expected Results:
The dialog (the Msgbox) should close at the first attempt.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
The error occurs in all 6.3.x versions (I could not select "6.3 all versions" in the list).
Comment 1 joesch04 2019-12-01 10:29:14 UTC
Created attachment 156215 [details]
testfile for reproducing the bug
Comment 2 Oliver Brinzing 2019-12-01 12:42:14 UTC
reproducible with:

Version: 6.3.3.2 (x64)
Build-ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: 

but *not* reproducble with:

Version: 6.2.8.2 (x64)
Build-ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: 

Version: 6.3.4.1 (x64)
Build-ID: a21169d87339dfa44546f33d6d159e89881e9d92
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: 

Version: 6.5.0.0.alpha0+ (x64)
Build ID: b6c357506740d14611603a4611f4aacaffe4ee13
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

i think, this is a duplicate of:
Bug 128988 - Form control events triggered twice
which is a duplicate of
Bug 127921 - Presenter View of Impress 6.3.x doesn't remember slide after Slides and Close, as it used to, but returns to 1 during presentation

*** This bug has been marked as a duplicate of bug 127921 ***
Comment 3 joesch04 2019-12-01 14:14:54 UTC
That sounds good. Then maybe there is also hope that the error in 6.4.x does not occur any more.

I will test it next week with 6.4.0.0