Bug 129169 - HELP: "Selecting a new color" page needs to improve "To access this command..." section.
Summary: HELP: "Selecting a new color" page needs to improve "To access this command.....
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0 target:7.1.0
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2019-12-04 08:13 UTC by Mike Kaganski
Modified: 2021-05-06 17:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2019-12-04 08:13:10 UTC
"Selecting a new color" help page [1] has "Choose Format - Area - Area" recommendation in its "To access this command..." section. But the only module that has Area submenu under Format is Draw; while the help page is not specific to Draw, but is a generic one. So it needs to mention that it may be used in any area tab (e.g., cell/paragraph/header/...), and list some most common, like Format->Page->Area in Writer; Format->Page->Background in Calc (by the way, why is it Background, when in all other places, we seem to settle to Area?), etc.

See https://ask.libreoffice.org/en/question/219866/how-do-i-define-custom-colors-in-calc/ that shows user confusion resulting from this.

[1] https://help.libreoffice.org/latest/en-US/text/shared/optionen/01010501.html
Comment 1 sdc.blanco 2020-01-10 01:41:48 UTC
@Mike, some considerations:

How did "ask.libreoffice.org" question encounter this command/help page?

(In L06.3 Calc)
1. F1
2. type "color" into Index search field
3. click on "defining -- colors" or "colors -- adding"
4. The URL you cited appears.

This guess may explain how the question arose.  But the appropriate response may be more complicated.

Suggestion 1:  Probably these two links "defining -- colors" and "colors -- adding" should go to:  https://help.libreoffice.org/6.5/en-US/text/shared/01/05210100.html

Suggestion 2:   This page seems like the "right" page / place for giving advice defining colors.  (including a link to the Color picker page). 

It is possible that for some "custom color" means "select one of the preexisting colors" -- which the Area tab should help explain (or give a link to a relevant page).

But this advice is not there (and I could not find another help page that discusses how to use the Color within Area.)  

+ (I can see that it is currently missing access for "Calc", which I can add, and make them say "Background" instead of "Area")
+  And willing to add some commonly used access paths.  
  - Advice/suggestions on both points appreciated.

Suggestion 3.  
  Search on "custom color" in the Help Index.  
  Only "Draw" comes up, with the link to the Color Picker page.  
  Seems relevant to add bookmarks(?) for "custom colors" for the other modules.

Suggestion 4:  Modify the color picker page (01010501.html), to indicate that the picker is accessed from the Area tab page (and link to the Area tab help, 05210100.html) (presupposes that the Color Picker dialog can only be accessed from the Area tab.)  Gives a simple solution for showing all the different access routes, without having to add them directly to the color picker page. 

Most of these points require input from more knowledgeable persons.
Comment 2 Commit Notification 2020-01-11 13:10:47 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/30cafcf910513bd96e8b1468b132b205c241a8bc

tdf#129169  update "access to" in Area tab help page
Comment 3 sdc.blanco 2020-01-11 14:23:29 UTC
@Mike –  I have changed  what I could to improve the ‟To access ...” the Area tab.   But I do not have relevant knowledge to make the other proposed changes  in Comment #2.

From making the changes, have discovered some additional points:

1.  The "To access this command..."  in the shared Area tab (/text/shared/01/05210100.xhp) only embeds from the Format menu (section #flaeche2) (but some non-format menu items – ‟View Styles” and ‟Table” are also included there – which I have left).

Suggestion #5:  If the idea is to embed ‟access” commands from relevant ‟menu” pages, then some items should be moved from #flaeche2 into appropriate ‟menu” pages and then embedded into the Area tab page (/shared/01/05210100.xhp). 

2.  In relation to the previous point:  included in #flaeche2 are:  (for draw) Page - Properties - Background - tab and (impress) Slide - Properties - Background - tab.  

Suggestion #6:  Maybe there should be a separate page for "Background" tab for Draw and Impress (which uses the same contents) as the Area tab.   (Have left these commands in #flaeche2 to be embedded in the Area tab for now.) 


3.  The Calc "background" tab only has buttons for None, Color and Bitmap (for Page Style) and only None and Color (for Format Cells).   Not a good idea to use the Area tab help page (/shared/01/05210100.xhp) because then users would also expect to find Gradient, Pattern, and Hatch).   
For now I have added Format – Cells – Background  – to the Area tab  (as a temporary solution).
 

Suggestion 7:   Should probably be a separate Calc-specific page, rather than using the Area tab.  Or if Suggestion #6 is followed, conditional statements could be used to only show Calc-relevant items.
Comment 4 sdc.blanco 2020-01-11 14:47:30 UTC
(In reply to Mike Kaganski from comment #0)
> Calc (by the way, why is it Background, when in all other places, we seem to
> settle to Area?), etc.
As an empirical observation:  

"Background" tab is used for "Pages" (in Draw and Calc), "Slides (in Impress), "Cells" (in Calc), cells in "Tables" -- where the color is really a background.
(and where Calc has limited offerings, Color and sometimes Bitmap)

While "Area" refers to delimited "objects" (like Shapes, Paragraphs, Frames, etc.) (i.e., not Backgrounds).  

Suggestions #6 and #7 in comment #3 propose a way to handle these variations.

(The one exception is that Writer uses "Area" for Pages -- and maybe that should be changed to Background -- for intermodule consistency.)
Comment 5 Commit Notification 2020-06-15 15:00:29 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/522bc49632bc3eac50a56cf1746d1b923eb2b89b

tdf#129169 Access commands for area/background
Comment 6 Commit Notification 2020-06-15 20:06:58 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/01bf38a8fe1221235a2b32cc5773c49e1228a418

tdf#129169 More adjustments in area/background