Download it now!
Bug 129187 - Enhance Find & Replace regex to be able to remove a word and an extra line of space between sets of text.
Summary: Enhance Find & Replace regex to be able to remove a word and an extra line of...
Status: RESOLVED DUPLICATE of bug 38261
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-04 18:01 UTC by Dr. Pam Halton
Modified: 2019-12-05 08:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dr. Pam Halton 2019-12-04 18:01:14 UTC
Description:
In LO Writer & probably also LO Calc:
I want Find & Replace to be able to accept delete or backspace in the Replace section. 

I want Find & Replace to be able to remove a word(s) and a blank line or two. 

In other words, I want it to be able to accept delete or backspace as a character. 

For example, if you were editing a list of sets of stuff that was 7 lines per set and you had over 1000 sets, and each set had 2 lines of space between each that set and the following set, I want to be able to find the word and replace the word with [nothing, no other word] and with 2 backspaces, so the program will get rid of one of the extra lines between each set.

Steps to Reproduce:
1. I’d like to be able to type “” into the Find field.
2. I’d like to be able to type “Subtitle” and 2 backspaces into the Replace field.
3.

Actual Results:
(can't do it so no results)

Expected Results:
I’d like it to remove the word Subtitle and 1 line of blank space every time I push Find Next and then I push Replace.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Timur 2019-12-04 20:32:10 UTC
This is a duplicate. 
Until it's done, you may use extension Alternative Find & Replace.

*** This bug has been marked as a duplicate of bug 38261 ***
Comment 2 V Stuart Foote 2019-12-04 22:26:32 UTC
@Timur, wouldn't this be more aligned with bug 108256
Comment 3 Timur 2019-12-05 08:12:53 UTC
I don't think from the report, but reporter may say of it is.