Download it now!
Bug 129293 - Kde5 VCL: Buttons are different from Breeze style ones
Summary: Kde5 VCL: Buttons are different from Breeze style ones
Status: RESOLVED DUPLICATE of bug 130857
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All Linux (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-12-09 20:17 UTC by Mikhail Zolotukhin
Modified: 2020-02-22 00:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Buttons comparison (28.79 KB, image/png)
2019-12-09 20:17 UTC, Mikhail Zolotukhin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Zolotukhin 2019-12-09 20:17:13 UTC
Description:
LibreOffice buttons have smaller paddings and size compared to Breeze style buttons in Qt applications under Kde Plasma. 

To provide better integration with Kde Plasma in case of look and feel, LibreOffice dialogs should use buttons with larger paddings and larger size.

Steps to Reproduce:
1. Open any LibreOffice dialog window under Kde Plasma DE (for example, settings)
2. Look at the buttons and compare them to the buttons of Qt app (for example, launch system settings app)


Actual Results:
Buttons in LibreOffice have very small paddings and small size

Expected Results:
Buttons in LibreOffice should have paddings and size, that are the same as in buttons of any Qt app under Kde Plasma


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.2.2
Build ID: 6.3.2-2
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kde5; 
Locale: ru-RU (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Mikhail Zolotukhin 2019-12-09 20:17:42 UTC
Created attachment 156440 [details]
Buttons comparison
Comment 2 Xisco Faulí 2019-12-11 13:55:25 UTC
Does it happen with any dialog or with some ? Take into account the different dialogs in LibreOffice are being welded in order to have a native look.
Comment 3 Mikhail Zolotukhin 2019-12-11 14:19:36 UTC
(In reply to Xisco Faulí from comment #2)
> Does it happen with any dialog or with some ? Take into account the
> different dialogs in LibreOffice are being welded in order to have a native
> look.

Yes, it happens in any dialog.
Comment 4 QA Administrators 2019-12-12 03:41:40 UTC Comment hidden (obsolete)
Comment 5 Michael Weghorn 2019-12-13 08:22:06 UTC
Currently, the kf5 VCL plugin doesn't use native Qt widgets. Changing that (i.e. implement the so-called "welding" for kf5 as well, as was done for gtk3) would probably make this work "automatically", but it's quite a lot of work.

Setting to NEW.
Comment 6 Jan-Marek Glogowski 2020-02-22 00:52:25 UTC
This won't work without using the new "weld" theming API.

*** This bug has been marked as a duplicate of bug 130857 ***