Download it now!
Bug 129337 - TABBED TOOLBAR: Tables background color not implemented correctly when using background color button in table tab
Summary: TABBED TOOLBAR: Tables background color not implemented correctly when using ...
Status: RESOLVED DUPLICATE of bug 130208
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2019-12-11 21:31 UTC by george
Modified: 2020-05-06 21:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot showcasing the problem (89.59 KB, image/jpeg)
2019-12-11 21:35 UTC, george
Details
2nd screenshot showcasing the problem (88.61 KB, image/jpeg)
2019-12-12 15:28 UTC, george
Details

Note You need to log in before you can comment on or make changes to this bug.
Description george 2019-12-11 21:31:13 UTC
Description:
When you try to set background color inside the cells of a table, by using the button "Background color", the selected cells do not fill completely with the color that user selected. Instead a white border remains between border line and background color.

The only way to completely fill the cell with a color is by right click---> table properties ---> background ---> color...

Steps to Reproduce:
1.select some cells inside a table
2.click "background button" on the toolbar
3.select color

Actual Results:
The selected cells do not fill completely with the color that user selected. Instead a white border remains between border line and background color.

Expected Results:
The selected cells should fill completely by the color that user selected


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.3.3.2
Build ID: 1:6.3.3-0ubuntu0.18.04.1~lo1
CPU threads: 12; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: el-GR (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 george 2019-12-11 21:35:17 UTC
Created attachment 156500 [details]
screenshot showcasing the problem

Table cells not filled with background color which is selected by user.
Comment 2 Roman Kuznetsov 2019-12-12 12:09:17 UTC
You use "Background FONT color" icon on "Formatting" toolbar instead of using "Table cell background color" icon on "Table" toolbar in bottom part of main screen of Writer.
Comment 3 george 2019-12-12 15:28:10 UTC
Created attachment 156514 [details]
2nd screenshot showcasing the problem

From table toolbar I use "background color" and the cells do not fill completely with selected color.
Comment 4 george 2019-12-12 15:30:31 UTC
@Roman Kuznetsov

No. Even from "table toolbar" using "background color" button does not work properly. Please see 2nd screenshot
Comment 5 Dieter 2019-12-12 16:13:23 UTC
(In reply to george from comment #4)
> @Roman Kuznetsov
> 
> No. Even from "table toolbar" using "background color" button does not work
> properly. Please see 2nd screenshot

I confirm that behaviour. But the bug is about the wrong command in table tab of tabbed toolbar

Steps to reproduce
1. Open writer with standard toolbar
2. Insert table
3. put cursor in a cell => table toolbar appears
4. Click on "table cell background color" in table toolbar => Works as expected
5. Change to "tabbed toolbar"
6. Put curso in a cell
7. Click on "Background colour" in table tab => white border between background and border

Actual result
Background colour in table tab

Expected result
Table cell background colour in table tab

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 89f0af144c18efafe2573801641689a1432c0cae
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded
Comment 6 Roman Kuznetsov 2019-12-12 17:00:22 UTC
(In reply to george from comment #4)
> @Roman Kuznetsov
> 
> No. Even from "table toolbar" using "background color" button does not work
> properly. Please see 2nd screenshot

I say about Table toolbar, not about any variants of Notebookbar.

I agree with Dieter, for NB it's a bug
Comment 7 Tohotom 2020-04-04 10:20:57 UTC
I can confirm that this behavior is present in the latest stable release 6.4.2.2. The "Background Color" button in the Table Toolbar behaves as "Paragraph Background".

The Background Color button should act the same as the "Cell Background Color" form the Table sidebar.
Comment 8 andreas_k 2020-05-06 21:34:29 UTC

*** This bug has been marked as a duplicate of bug 130208 ***