Download it now!
Bug 130208 - Writer - In tabbed toolbar, Background color button should fill cell background color and not paragraph background color when in a cell
Summary: Writer - In tabbed toolbar, Background color button should fill cell backgrou...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: andreas_k
URL:
Whiteboard: target:7.0.0 target:6.4.3
Keywords: needsUXEval
: 129337 (view as bug list)
Depends on:
Blocks: Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2020-01-26 19:53 UTC by jul
Modified: 2020-05-08 08:45 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Text background is changed instead of cell background (160.93 KB, image/png)
2020-01-26 19:54 UTC, jul
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jul 2020-01-26 19:53:29 UTC
Description:
Hi there,
Following bug https://bugs.documentfoundation.org/show_bug.cgi?id=82504, and in relation with comment number 40, can you fix the button in the tabed toolbar ?
Than would be great :-)


Steps to Reproduce:
Steps:
1) Open Writer / with tabed toolbar
2) Create a table
3) While in a cell, click on the background color icon in the table toolbar
4) It will not fill the cell background but the paragraph background


Actual Results:
The background color icon fills the paragraph background.
To change the background color of the cell, then you need to right-click the cell and choose "table property".

Expected Results:
The cell background should change, not the paragraph background.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.4.2
Build ID: 1:6.3.4-0ubuntu0.19.04.1~lo1
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 jul 2020-01-26 19:54:58 UTC
Created attachment 157439 [details]
Text background is changed instead of cell background
Comment 2 Dieter 2020-01-27 07:36:28 UTC
I confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: eeb2d19e77d6dc47c68e8ba0920a02cf64a1247b
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded


But I also saw the different tooltips:
Background colour (in tabbed toolbar)
and
Table cell background colour (in standard toolbar)

So is this really the same?

=> Status "NEW", but cc: Design Team
Comment 3 Heiko Tietze 2020-01-27 10:20:40 UTC
(In reply to Dieter Praas from comment #2)
> Background colour (in tabbed toolbar)
> Table cell background colour (in standard toolbar)

Jim introduced the new .uno command TableCellBackgroundColor and this has to replace the (paragraph) background in the tabbed UI.  Andreas, one for you?
Comment 4 Ming Hua 2020-02-29 23:12:38 UTC
I would urge the developers to consider the case of editing existing document with paragraph background color applied in a table cell before implementing the change.  If a button's behavior is silently changed, users accustomed with the old behavior would be caught with some unpleseant surprises, for example bug 131040.

Although with tabbed toolbar a new (non-experimental) feature in 6.3, the effect is probably quite limited.
Comment 5 chrisofbristol 2020-03-12 12:31:37 UTC
Same for me. A couple of months ago I updated from Ubuntu Budgie 19.04 to 19.10, this includes an upgrade of LO from 6.2 to 6.3. Table cell highlighting no longer works as expected. Instead of highlighting the whole cell it highlights the line of text.

https://ask.libreoffice.org/en/question/211373/writer-table-cell-background-colour/?sort=latest

Version: 6.3.5.2
Build ID: 1:6.3.5-0ubuntu0.19.10.1
CPU threads: 2; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 6 andreas_k 2020-03-12 12:43:07 UTC
thanks for the bug report will fix it.
Comment 7 jul 2020-03-12 13:38:24 UTC
Thanks for fixing it!
Comment 8 Commit Notification 2020-03-12 15:26:30 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2a5dfda892ca444eca2a0fcba2b28b9c9fd2915e

tdf#130208 use TableCellBackgroundColor instead of BackgroundColor

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-03-20 09:57:01 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/2471784335eeb6c06e0ee54342d6260c2efac8e9

tdf#130208 use TableCellBackgroundColor instead of BackgroundColor

It will be available in 6.4.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 andreas_k 2020-05-06 21:34:29 UTC
*** Bug 129337 has been marked as a duplicate of this bug. ***
Comment 11 Dieter 2020-05-08 08:45:44 UTC
Verified with

Version: 7.0.0.0.alpha1+ (x64)
Build ID: 99c337d1d3831ce9d2c7dc1cbff713f4ac49d6ac
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Andreas, thanks for fixing it!