Download it now!
Bug 131040 - "Background Color" button on Table toolbar changed behavior from 6.2 to 6.3, causing confusions
Summary: "Background Color" button on Table toolbar changed behavior from 6.2 to 6.3, ...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-29 21:21 UTC by mvarney82
Modified: 2020-03-01 00:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer 6.2.8 Table with Cell Background Color (13.65 KB, application/vnd.oasis.opendocument.text)
2020-02-29 21:23 UTC, mvarney82
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mvarney82 2020-02-29 21:21:53 UTC
Description:
Table created in LO 6.2.8 Writer had yellow background color in certain cells.
Have been using 6.3.4 lately. Noticed that changing background color to "No Fill" did not remove the background color. Strangely, setting a background color other than "No Fill" placed the new background color in a very thin band around the outside of the cell, but left the old color in the middle of the cell.
Opened file in 6.2.8 and was able to change the background color as normal.
Perhaps LO is now using a different parameter for background color. Still, it should be possible to change the color in existing documents. Am I missing something?

Steps to Reproduce:
1. Create table with background color in 6.2.8 Writer and save.
2. Open document in 6.3.4 or higher.
3. Attempt to change background color to a different color.

Actual Results:
Background color changes in thin band around the outside of the cell. Middle of cell is not affected.

Expected Results:
Color in entire background of cell should change.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.4.1.2
Build ID: 4d224e95b98b138af42a64d84056446d09082932
CPU threads: 4; OS: Mac OS X 10.13.6; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 mvarney82 2020-02-29 21:23:12 UTC
Created attachment 158280 [details]
Writer 6.2.8 Table with Cell Background Color

Test document from Writer 6.2.8.
Comment 2 Maxim Monastirsky 2020-02-29 22:19:45 UTC
Hi,

The cells in the attached file are colored with paragraph background, not with cell background. You can change paragraph background from the menu Format > Paragraph... > Area, or customize the toolbar and add a "Background Color" button.

I think, what contributed to this confusion is that the table toolbar used to have the paragraph color button, but in 6.3 it was changed to a cell color button.
Comment 3 Ming Hua 2020-02-29 22:23:34 UTC
Reproduced on Windows with attached example.  Can change background color in 6.2.8, can't change (only the thin band at the border changes, as comment #0 described) in 6.3.5.

Version: 6.2.8.2 (x64)
Build ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
CPU threads: 2; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: zh-CN (zh_CN); UI-Language: en-US
Calc: threaded

and

Version: 6.3.5.2 (x64)
Build ID: dd0751754f11728f69b42ee2af66670068624673
CPU threads: 2; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: zh-CN (zh_CN); UI-Language: en-US
Calc: threaded
Comment 4 Ming Hua 2020-02-29 22:27:35 UTC
(In reply to Maxim Monastirsky from comment #2)
> I think, what contributed to this confusion is that the table toolbar used
> to have the paragraph color button, but in 6.3 it was changed to a cell
> color button.
The two buttons are placed in similar positions on the toolbar and use the same icon, though.  I think there is a serious UX problem here.
Comment 5 Maxim Monastirsky 2020-02-29 22:47:35 UTC
(In reply to Ming Hua from comment #4)
> The two buttons are placed in similar positions on the toolbar and use the
> same icon, though.  I think there is a serious UX problem here.
I disagree. It was a common request to have this button apply cell background and not paragraph background (see Bug 82504). After all, the button is placed on the table toolbar, and as such should apply cell attributes.

But even if we accept that there is indeed a problem here, what can we do to avoid this problem? I doubt that changing the button placement or icon will make any difference, as we have this kind of changes anyway between releases. It's also unlikely that people will even notice a minor change to the icon.
Comment 6 Ming Hua 2020-02-29 23:05:00 UTC
(In reply to Maxim Monastirsky from comment #5)
> (In reply to Ming Hua from comment #4)
> > The two buttons are placed in similar positions on the toolbar and use the
> > same icon, though.  I think there is a serious UX problem here.
> I disagree. It was a common request to have this button apply cell
> background and not paragraph background (see Bug 82504). After all, the
> button is placed on the table toolbar, and as such should apply cell
> attributes.
It's perfectly valid to change the button to apply cell background instead of paragraph background once the feature is implemented.  The problem is that it causes confusion for users editing old documents, as shown by this bug report.  This change in toolbar is not even mentioned in the release notes, only the newly available UNO command is mentioned (https://wiki.documentfoundation.org/ReleaseNotes/6.3#Writer).  Ordinary user would rarely expecting the behavior change of a button by reading that.  Or by reading the new tooltip (although it specifies "Table Cell Backgroud Color", the old one is simply "Background Color").

> But even if we accept that there is indeed a problem here, what can we do to
> avoid this problem? I doubt that changing the button placement or icon will
> make any difference, as we have this kind of changes anyway between
> releases. It's also unlikely that people will even notice a minor change to
> the icon.
Well, ideally, LO could see the current cell has no cell background color, but has paragraph background color, and either offer two buttons on the toolbar or somehow alert the user.  Or LO can alert the user when opening an document with paragraph BG color instead of cell BG color.  Or change the default setting to have cell BG color overriding paragraph BG color, unless the user explicitly change paragraph BG color again.  I'm sure UI and UX experts will have better ideas.

I'm not proposing reverting the change to the button here.  I'm just saying this is a real UX problem, and simply closing it as NOTABUG is very discouraging to our bug-reporting users.
Comment 7 Maxim Monastirsky 2020-02-29 23:49:02 UTC
(In reply to Ming Hua from comment #6)
> and either offer two buttons on the toolbar
And you call it a good UX to have two background buttons on the same toolbar? There will be much more confusion by people that won't understand the difference between the two, or accidentally click on the wrong one.  

> Or LO can alert the user when opening an
> document with paragraph BG color instead of cell BG color.
Paragraph color is a valid formatting by itself, and is not deprecated in any way. It makes no sense to "alert the user" about legitimate formatting. The software can't read user's mind, and has no way to determine if some formatting was done by mistake or by intention.

> Or change the
> default setting to have cell BG color overriding paragraph BG color,
This won't be correct, as paragraph color and cell color are two different things.

> and simply closing it as NOTABUG is very discouraging to our bug-reporting
> users.
User mistakes happen from time to time, and there's nothing "discouraging" in closing such bugs, given that a nice comment is added with explanation of the confusion and what caused it.
Comment 8 Ming Hua 2020-03-01 00:10:57 UTC
(In reply to Maxim Monastirsky from comment #7)
> (In reply to Ming Hua from comment #6)
> > and either offer two buttons on the toolbar
> There will be much more confusion by people that won't understand
> the difference between the two, or accidentally click on the wrong one.  
Not if the two buttons have distinct icons (with the paragraph one using the old icon, and the cell one using a new one); have labels and tooltips explaining the difference; only both show up when current cell's background BG color is not "None", and cell BG color is "None" (otherwise only the cell button shows up); and are well documented in Help pages and Release Notes.

Anyway, I'm not a developer, and I know it's hard to implement what I just said.  So let's just agree to disagree here.  I see the current situation as an UX problem, you don't; and until someone else chimes in, it's rather counter-productive to continue the discussion.