Download it now!
Bug 129506 - Copy/Paste or Cut/Paste unpredictable
Summary: Copy/Paste or Cut/Paste unpredictable
Status: RESOLVED DUPLICATE of bug 62196
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.8.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-19 22:22 UTC by AndreHasekamp
Modified: 2019-12-21 15:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Any LibreOffice Writer document with text and images (4.67 MB, application/vnd.oasis.opendocument.text)
2019-12-19 22:24 UTC, AndreHasekamp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description AndreHasekamp 2019-12-19 22:22:34 UTC
Description:
This is a continuation of e.g. bugs 57147, 128853, 129291, but here I consider only Copy/Paste or Cut/Paste within the same LibreOffice Writer document.

LibreOffice Still Writer, Version 6.2.8.2, running under ArchLinux (LibreOffice Arch Linux Build ID: 6.2.8-3).
LibreOffice Fresh Writer, Version 6.3.4.2.0+ running under Arch Linux distribution (LibreOffice Arch Linux Build ID: 6.3.4-1).

It is completely unpredictable when Copy/Paste or Cut/Paste succeeds or fails, but in any case, after a few attempts it definitely fails. So, below I will suggest a procedure, but you may have to repeat parts of the procedure before you see that the Copy/Paste or Cut/Paste fails.

Consider the attached document.

Let's start with a piece of text.

Copy/Paste or Cut/Paste a piece of text. For a document freshly loaded from disk, this usually succeeds.

Now, either save or don't save the document (eventually, please try both possibilities).

Then, Copy/Paste or Cut/Paste another piece of text. Usually, upon this second paste you will see that not the piece of text you think just copied or cut to the clipboard, but instead, the previously pasted text is now pasted again. This erroneous second paste occurs rather consistently, but otherwise please try a third piece of text.

Do the same with images and frames. Please, primarily do the Cut/Paste because that is what I normally do.

When the Paste goes wrong with images and frames is even less predictable, but please try a few times with different images and frames (with me, the problem occurs after I Cut/Paste an image, save the document and and then Cut/Paste another image, but sometimes the paste failure occurs upon a third Cut/Paste).

This is hopelessly irritating when you do this sort of work in a production environment. In my environment I have to do several Cut/Pastes of text as well as images within the same document.

The issue exists for a while now. Sorry, I can't say when I first saw it. You live with it, until your frustration drives you write a bug report. Does not occur with an old LibreOffice 5 running under Windows XP.

If you think it has something to do with the particular document appended to this bug report, please let me know, I will send you other documents.

Steps to Reproduce:
1.See description above
2.
3.

Actual Results:
See description above

Expected Results:
Copy and/or Paste does not work.


Reproducible: Always


User Profile Reset: No



Additional Info:
Attached document. Apparently I can only append the document as an update to this bug report. Will do that right away.
Comment 1 AndreHasekamp 2019-12-19 22:24:40 UTC
Created attachment 156682 [details]
Any LibreOffice Writer document with text and images
Comment 2 Timur 2019-12-20 22:45:04 UTC
Can we consider another duplicate of bug 62196?
Comment 3 AndreHasekamp 2019-12-21 13:28:08 UTC
OK, one way or another, I overlooked bug 62196.

Differences between bugs 62196 and 129506:

- I don't agree with comment 43 of bug 62196.
- In comment 63 of bug 62196 it is stated that you should copy from anywhere but LibreOffice. In bug 129506 I state that the problem occurs when you Copy/Paste or Cut/Paste from within the same document.

So, although bugs 62196 and 129506 are not the same, they are similar. Since bug 62196 exists already since 2013, it may be a good idea to solve that one first. Once 62196 is solved I will check if 129506 is also solved. If not, I can enter a new bug report.

Altogether, you may now mark 129506 as a duplicate of 62196.
Comment 4 Timur 2019-12-21 15:13:24 UTC

*** This bug has been marked as a duplicate of bug 62196 ***