Bug 129659 - CRASH on file opening
Summary: CRASH on file opening
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0 target:6.4.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Crash-Assert
  Show dependency treegraph
 
Reported: 2019-12-27 22:09 UTC by Telesto
Modified: 2020-02-20 17:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["writerfilter::dmapper::DomainMapper::lcl_utext(unsigned%20char%20const%20*,unsigned%20int)"]


Attachments
bt with debug symbols (15.90 KB, text/plain)
2019-12-28 13:51 UTC, Julien Nabet
Details
Flamegraph (225.23 KB, application/x-bzip)
2019-12-28 14:52 UTC, Julien Nabet
Details
Simpler, much smaller reproducer with page break endnote (18.15 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-01-20 21:49 UTC, Jan-Marek Glogowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-12-27 22:09:52 UTC
Description:
CRASH on file opening

Steps to Reproduce:
1. Attempt to open attachment 145419 [details] (bug 120351) -> Crash after 3 minutes or so

Actual Results:
Crash

Expected Results:
No crash & very long loading time


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Julien Nabet 2019-12-28 13:51:59 UTC
Created attachment 156816 [details]
bt with debug symbols

On pc Debian x86-64 with LO Debian package <ith master sources updated today, I got an assertion.
Comment 2 Julien Nabet 2019-12-28 14:52:53 UTC
Created attachment 156817 [details]
Flamegraph

Here's a Flamegraph after having waited a bit at the opening.
Comment 3 Dieter 2019-12-28 18:26:59 UTC
I confirm crash with

Version: 6.5.0.0.alpha0+ (x64)
Build ID: e26d89371f0e4f41476c9a99be01d98dedb76776
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded
Comment 4 Telesto 2019-12-30 20:45:08 UTC
The file can be opened, following bug 120351. So a regression i guess
Comment 5 Xisco Faulí 2020-01-13 11:53:12 UTC
Also reproducible in

Version: 6.5.0.0.alpha0+
Build ID: d5047c4a1cbae1cb2b57ed435ecd63e6817506d3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Xisco Faulí 2020-01-13 12:19:01 UTC
bisecting it... just saying because it's going to take a while...
Comment 7 Xisco Faulí 2020-01-13 14:19:53 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a991ad93dcd6807d0eacd11a50c2ae43a2cfb882

author	Jan-Marek Glogowski <jan-marek.glogowski@extern.cib.de>	2019-10-22 12:24:43 +0200
committer	Jan-Marek Glogowski <glogow@fbihome.de>	2019-10-28 14:48:51 +0100
commit	a991ad93dcd6807d0eacd11a50c2ae43a2cfb882 (patch)
tree	e2ca253f2106438fd18606e188c5a1e28a6bc3d2
parent	e70ccc06094bec12d1947328b98ea040b46d08fc (diff)
tdf#121441 improve DOCX footnote import

Bisected with: bibisect-linux64-6.4

Adding Cc: to Jan-Marek Glogowski
Comment 8 Jan-Marek Glogowski 2020-01-20 21:49:57 UTC
Created attachment 157282 [details]
Simpler, much smaller reproducer with page break endnote
Comment 9 Xisco Faulí 2020-01-21 08:50:21 UTC
(In reply to Jan-Marek Glogowski from comment #8)
> Created attachment 157282 [details]
> Simpler, much smaller reproducer with page break endnote

I do confirm a991ad93dcd6807d0eacd11a50c2ae43a2cfb882 also introduced the crash with the minimized file
Comment 10 Commit Notification 2020-01-30 14:36:23 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b87af9775167002d36a3bc16cb308ea7895d7ea0

tdf#129659 DOCX check global footnote context

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-01-30 15:56:53 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/a0db764766dffe868ba3075901326ed6410ea037

tdf#129659 DOCX check global footnote context

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2020-02-07 17:34:01 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: c81c383be787ec5f9acbca51f75ea5b28b63c63a
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Jan-Marek, thanks for fixing this issue!!