Download it now!
Bug 129662 - RTL: Incorrectly shown scrollbar in dropdowns
Summary: RTL: Incorrectly shown scrollbar in dropdowns
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.5.0 target:6.4.0.2 target:6.3.5
Keywords: bibisected, bisected, regression
: 129728 (view as bug list)
Depends on:
Blocks: RTL-UI
  Show dependency treegraph
 
Reported: 2019-12-28 01:51 UTC by Aron Budea
Modified: 2020-01-10 11:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2019-12-28 01:51:08 UTC
- Launch LO with: SAL_USE_VCLPLUGIN=gen SAL_RTL_ENABLED=1 ./soffice --writer
- Open one of the dropdowns, eg. Font name

=> Scrollbar is to the right, while it should be on the left.

- Hover over the items

=> Scrollbar moves to the left, but is still drawn in a buggy way.

Observed using LO 6.5.0.0.alpha0+ (3f680aef65a158cfbc98c8afd1c3628d7f4f7b83), 6.3.0.4 / Ubuntu & Windows.
No issue in LO 6.2.0.3.

This is a regression from the following commit, bibisected to its 6.3 backport using repo bibisect-linux-64-6.3. Adding CC: to Miklos Vajna.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d4714b0fdb81e6e561ae526cc517ecc9a40a603e
author		Miklos Vajna <vmiklos@collabora.com>	2019-06-17 17:02:54 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	2019-06-17 19:08:43 +0200

tdf#101978 vcl combobox/listbox floating window: avoid flicker
Comment 1 Commit Notification 2020-01-02 17:49:23 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b0fa356eed82a0452e6bcb915f179f5e2d02943a

tdf#129662 vcl: rtl: fix scrollbar in dropdowns

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Commit Notification 2020-01-06 14:56:38 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/9aa7da21e428111cbc708107c4efd75df4ea1fa2

tdf#129662 vcl: rtl: fix scrollbar in dropdowns

It will be available in 6.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Xisco Faulí 2020-01-09 12:49:10 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: 838935758a5ec8e0e68f4df0cf5bfcf737e3f6f2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!
Comment 4 Commit Notification 2020-01-09 15:23:54 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/a9d9abe590e310a82f23f297bc25609f91ae8540

tdf#129662 vcl: rtl: fix scrollbar in dropdowns

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2020-01-10 11:24:54 UTC
*** Bug 129728 has been marked as a duplicate of this bug. ***