Bug 129700 - Writer incorrectly display text without wrap inside text box for 2007 DOCX (OK if resaved in MSO)
Summary: Writer incorrectly display text without wrap inside text box for 2007 DOCX (O...
Status: RESOLVED DUPLICATE of bug 84399
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx, implementationError
Depends on:
Blocks: VML-Shapes
  Show dependency treegraph
 
Reported: 2019-12-30 14:12 UTC by Pavel
Modified: 2020-09-02 20:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Document which has described issue (16.28 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-12-30 14:13 UTC, Pavel
Details
Screenshot of file in MS Word 2019 (89.70 KB, image/png)
2019-12-30 14:14 UTC, Pavel
Details
Screenshot of file opened in LO (167.93 KB, image/png)
2019-12-30 14:15 UTC, Pavel
Details
The example file opened in Writer 7.0 (117.82 KB, image/png)
2020-09-02 18:47 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel 2019-12-30 14:12:44 UTC
Description:
LibreOffice shows text on a single line instead of splitting it to multiple line.
As a result part of text is not visible at all

Steps to Reproduce:
1. Open attached file created with Microsoft Word


Actual Results:
All text on a single line and part of it is not visible

Expected Results:
Text fills the box (see screenshot)


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.4.2.0+
Build ID: 6.3.4-1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk2; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Pavel 2019-12-30 14:13:51 UTC
Created attachment 156848 [details]
Document which has described issue
Comment 2 Pavel 2019-12-30 14:14:45 UTC
Created attachment 156849 [details]
Screenshot of file in MS Word 2019
Comment 3 Pavel 2019-12-30 14:15:30 UTC
Created attachment 156850 [details]
Screenshot of file opened in LO
Comment 4 ian 2019-12-30 17:06:59 UTC
Thank you for reporting the bug. I can confirm that the bug is present in the most recent stable build on a Windows machine. 

Version: 6.3.4.2 (x64)
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 2; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 5 Buovjaga 2020-01-23 20:01:21 UTC
The box is not yet in 4.0, but is in 4.1 and already in 4.1 it is incorrectly rendered.
Comment 6 NISZ LibreOffice Team 2020-09-02 18:47:33 UTC
Created attachment 165044 [details]
The example file opened in Writer 7.0

Looks better since: 

https://cgit.freedesktop.org/libreoffice/core/commit/?id=198685ded79d64b21023ee85e9a15fa1b32705a0

author	Miklos Vajna <vmiklos@collabora.com>	2020-03-02 20:23:04 +0100
committer	Miklos Vajna <vmiklos@collabora.com>	2020-03-03 07:57:05 +0100

tdf#84399 VML import: map <v:shape o:spt="202"> to TextShape

There is an independent regression though: the font is Calibri in Word, but MS Gothic in Writer. The former comes from direct formatting, the latter from the Normal style.
Comment 7 NISZ LibreOffice Team 2020-09-02 18:50:06 UTC
Thanks Miklos for fixing this!

*** This bug has been marked as a duplicate of bug 84399 ***