Bug 129732 - Search cannot find apostrophes and other symbols; in many cases, they cannot even be pasted or typed into the search bar
Summary: Search cannot find apostrophes and other symbols; in many cases, they cannot ...
Status: NEEDINFO
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-02 08:37 UTC by D. Gold
Modified: 2020-06-04 09:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description D. Gold 2020-01-02 08:37:38 UTC
Description:
The search bar cannot find words with apostrophes (such as publisher's) and other symbols and in many cases will not even accept them when I try to paste them in (such as à in a French word).  

Steps to Reproduce:
1.given above
2.
3.

Actual Results:
Given above

Expected Results:
The search bar accepted publisher's but could not find it. The search bar did not even accept the French diacritic when I tried to paste it in.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Alex Thurgood 2020-01-10 15:58:24 UTC
@D Gold : which search bar are you talking about ?
Which kind of document ?

Are you really using LO6304 as that version has been replaced by the current 6342?

Have you tried updating to the newest available version ?
Comment 2 D. Gold 2020-01-14 05:06:37 UTC
Reply to Bug 129732]

I have in mind the bar marked "Find" in the lower left-hand corner below each open file (I think you call it the Find bar).

The problem occurs both if I key in characters directly into that bar and if I first click Edit - Find and then enter characters into the bar.

I use only Writer Documents.

I should have written version 6.0.7.3.

No, I haven't tried the newest version.

Thanks.
Comment 3 R. Green 2020-01-14 12:44:26 UTC
Version: 6.3.4.2 (x64)
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-GB
Calc: threaded

DIACRITICS: Use the "Find & Replace" dialogue (Ctrl + H),and tick "Diacritic sensitive", to find specific diacritics.

APOSTROPHES: The search term needs to include the correct form of the apostrophe: either straight (type direct from the keyboard) or curly (Alt 0146 in Windows).