Bug 129840 - Using 'CTRL+;' shortcut adds current date in a cell (good) even if cell and sheet are protected (bad)
Summary: Using 'CTRL+;' shortcut adds current date in a cell (good) even if cell and s...
Status: RESOLVED DUPLICATE of bug 71532
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-06 18:18 UTC by Laurent
Modified: 2020-01-07 16:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent 2020-01-06 18:18:45 UTC
Description:
(Using Libre Office 5.1.6.2 on Ubuntu 16.04)

Using 'CTRL+;' shortcut adds current date in a cell (good) even if cell and sheet are protected (bad)

Sometimes 'Impossible de modifier les cellules protégées.*' message appears, but date number is inserted in the cell, destroying previous formula/data.

If cell format is 'Date' then CTRL+; add current day without any message.


Steps to Reproduce:
Create a new calc sheet

Give Sheet1.A1 any Date format
Protect Sheet1
Select A1
Press ‘Ctrl’+’;’ (in France it’s keyboard shortcut for ‘insert date of today’)
! ! ! Date has been added in a protected cell ! ! !

Select A2
Press ‘Ctrl’+’;’ 
! An error message appears (good) but Date is inserted too (bad), without date format


Actual Results:
protected cell data is crashed by date number

Expected Results:
the software should refuse to modify any protected cell


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Oliver Brinzing 2020-01-07 16:57:35 UTC
seems to be a duplicate of:

Bug 71532 - EDITING: Ctrl+; insert current date/time although cell and sheet is locked.

*** This bug has been marked as a duplicate of bug 71532 ***