Bug 130073 - Conflict between 2 Keyboard shortcuts in Calc for Italian layout keyboard
Summary: Conflict between 2 Keyboard shortcuts in Calc for Italian layout keyboard
Status: RESOLVED DUPLICATE of bug 126085
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-18 17:09 UTC by Valter Mura
Modified: 2020-07-03 09:32 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Valter Mura 2020-01-18 17:09:28 UTC
With Italian keyboard layout, there is a default shortcut which is difficult to use.

We can, of course, change it through "Customize > Keyboard", but this would be a "manual" change of the user.

I ask if it is possible to change it as default, for Italian locale.

Explanation:

The default keyboard combination is 'Ctrl+Shift+;' for the command "Insert > Time" in a cell (Calc)
 
In the Italian layout, the character ';' is made with 'Shift+, (comma)' so we can use the above mentioned default shortcut, but not that for "Insert > Date", which is 'Ctrl+;' because when hitting for ';' we have to press also 'Shift' and the commands conflict.
Comment 1 Valter Mura 2020-01-18 18:25:34 UTC

*** This bug has been marked as a duplicate of bug 129547 ***
Comment 2 Mihkel Tõnnov 2020-07-03 09:32:53 UTC
French layout is different (has semicolon key). German layout doesn't (as Italian), so linking to the related BR about German layout instead (which just recently got fixed).

*** This bug has been marked as a duplicate of bug 126085 ***