Bug 130143 - LibreOffice 6.4.0.2, Tools, Options, Fonts, Replacement Table, check, crashed
Summary: LibreOffice 6.4.0.2, Tools, Options, Fonts, Replacement Table, check, crashed
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.0.2 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2020-01-23 12:42 UTC by Petar
Modified: 2020-03-04 11:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screencast (2.88 MB, video/x-matroska)
2020-01-28 09:03 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petar 2020-01-23 12:42:31 UTC
Description:
Trying to enter font replacement table. First pair: Arial - Lieration Sans, check, it works. Second pair: Calibri - Carlito, selected both fonts from drop down menu, check - LibreOffice chrashes
OS: Linux Mint 19.3 Cinnamon,64bit,Intel© Pentium© CPU 2127U @ 1.90GHz × 2,RAM 4GB

Actual Results:
Start LibreOffice, select Tools, Options, Fonts, Replacement Table. 
First pair: Arial - Lieration Sans, select both fonts from drop down menu, check, it works. 
Second pair: Calibri - Carlito, selected both fonts from drop down menu, check, LibreOffice chrashes

Expected Results:
Start LibreOffice, select Tools, Options, Fonts, Replacement Table. 
First pair: Arial - Lieration Sans, select both fonts from drop down menu, check, it works. 
Second pair: Calibri - Carlito, selected both fonts from drop down menu, check, it works


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2020-01-23 13:05:17 UTC Comment hidden (obsolete)
Comment 2 Xisco Faulí 2020-01-23 13:19:00 UTC
(In reply to Xisco Faulí from comment #1)
> I can't reproduce a crash, but I see in console
> 
> Negative content width -12 (allocation 1, extents 6x7) while allocating
> gadget (node button, owner GtkButton)
> 
> and LibreOffice fails to display the dropdownlist...

Regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2019-09-17 12:50:05 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2019-09-20 21:20:51 +0200
commit	94d6fa11d086187b82adf9aa596e0f334827e095 (patch)
tree	4a44af903b2572efe89ae5e8aa67bb092644e038
parent	3c84b18f4f0fe4058de60b1c62149275ed858b79 (diff)
weld OfaTreeOptionsDialog

Bisected with: bibisect-linux64-6.4

Adding Cc: to Caolán McNamara
Comment 3 Commit Notification 2020-01-25 17:35:07 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e44c4d7a7b1037d8a67325feefc4a22e6d0bd6be

Resolves: tdf#130143 crash in sorted font replacement table

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Caolán McNamara 2020-01-25 17:35:41 UTC
The "Negative content width -12 (allocation 1, extents ..." remains and doesn't have an effect on the initially reported problem which I can reproduce and is fixed in master, with backport to 6-4 in gerrit.
Comment 5 Commit Notification 2020-01-27 10:26:12 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/f1e14f99179ea2169750340d184ca92ce36b3125

Resolves: tdf#130143 crash in sorted font replacement table

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2020-01-28 09:00:08 UTC
Still reproducible in

Version: 7.0.0.0.alpha0+
Build ID: aef7feb3e695ecf6d411f0777196dcc4281e201a
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

I'll attach a screencast showing the problem
Comment 7 Xisco Faulí 2020-01-28 09:03:09 UTC
Created attachment 157476 [details]
screencast
Comment 8 Caolán McNamara 2020-01-28 12:35:09 UTC
I don't see the issue locally wrt the menu not appearing, the messages about the window height in the console are presumably related to that problem. That doesn't appear to be the originally reported problem of comment #1.

What's the output of
$ fc-list |wc
to see if there is some number of number of entries which will cause the problem and I don't have enough of them maybe (922 in my case)

And do you have the same problem in the font dropdown of format->watermark, which has the same sort of list ?
Comment 9 Xisco Faulí 2020-01-28 14:36:37 UTC
(In reply to Caolán McNamara from comment #8)
> I don't see the issue locally wrt the menu not appearing, the messages about
> the window height in the console are presumably related to that problem.
> That doesn't appear to be the originally reported problem of comment #1.
> 
> What's the output of
> $ fc-list |wc
> to see if there is some number of number of entries which will cause the
> problem and I don't have enough of them maybe (922 in my case)

2469   17141  315330

> 
> And do you have the same problem in the font dropdown of format->watermark,
> which has the same sort of list ?

Indeed, same issue there
Comment 10 Caolán McNamara 2020-02-03 12:23:21 UTC
I installed 7000 fonts and it still works for me (under x11) so I can't see if https://gerrit.libreoffice.org/c/core/+/87863 would help or not
Comment 11 Commit Notification 2020-02-03 16:11:56 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d29a945f164b9b0a78578a99f85769130721e6bb

Related: tdf#130143 freeze/thaw around bulk insert

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-02-05 10:02:01 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/1b5eee9efe49787ae1acc5ad6de5b9cf1fcc07ea

Related: tdf#130143 freeze/thaw around bulk insert

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Xisco Faulí 2020-02-17 16:50:30 UTC
Hi Caolán,
Unfortunately I still reproduce the issue in

Version: 7.0.0.0.alpha0+
Build ID: 28d844a589e52abfe62dc66b888e78665221ba28
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Petar, could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
Comment 14 Caolán McNamara 2020-02-17 17:06:06 UTC
at this point we are now talking about the menu not appearing with lots of fonts, but no longer talking about the original crash right ?
Comment 15 Xisco Faulí 2020-02-17 17:10:47 UTC
(In reply to Caolán McNamara from comment #14)
> at this point we are now talking about the menu not appearing with lots of
> fonts, but no longer talking about the original crash right ?

yes. Actually I could never reproduce the crash myself. The issue described shown in the video attached is still reproducible for me. I thought they might be related. if not, I can create a follow-up bug
Comment 16 Caolán McNamara 2020-02-17 17:14:28 UTC
I feel Petar's crash was https://gerrit.libreoffice.org/plugins/gitiles/core/+diff/e44c4d7a7b1037d8a67325feefc4a22e6d0bd6be%5E%21 and the not-appearing menu is a different thing but let's see how it goes for Petar
Comment 17 Petar 2020-02-17 23:07:59 UTC
Bug 130143 tested on 17.02.2020 23:00 with:
PC Linux Mint 19.2 Cinnamon 4.2.4, 64bit, AMD Athlon(tm) II X4 640 Processor × 4, RAM 8GB
LibreOfficeDev, Version: 7.0.0.0.alpha0+
Build ID: 7fddb9a1f69a1bac676ad48421256a1ba0274c83
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-02-16_19:33:19
Locale: hr-HR (en_US.UTF-8); UI-Language: en-US

Entering font replacement table: Tools, Options, Fonts:
Font:              Replace with:
Arial              Liberation Sans
Calibri            Carlito
Cambria            Caladea
Courier New        Liberation Mono
Times New Roman    Liberation Serif

*** IT WORKS! ****

LibreOffice 6.4.0.2, bug 130143 supplemented description:
Entering font replacement table:Tools, Options, Fonts:
Font:         Replace with:
Arial         Liberation Sans, selected both fonts from drop down menu, check mark right from "Replace with", it works
Calibri       Carlito, selected both fonts from drop down menu, check mark right from "Replace with", LibreOffice crashed

Tested several times, always the same result, crash after second font pair.
Tested on:
- Dell laptop Linux Mint 19.3 Cinnamon,64bit,Intel© Pentium© CPU 2127U @ 1.90GHz × 2,RAM 4GB
- PC Linux Mint 19.2 Cinnamon 4.2.4, 64bit, AMD Athlon(tm) II X4 640 Processor × 4, RAM 8GB
Deleted folder /home/user/.config/libreoffice, installed LibreOffice fresh, crash after second font pair.
Comment 18 Buovjaga 2020-03-02 16:01:48 UTC
Let's change to fixed. Separate report for the misbehaving menu would be nice
Comment 19 Xisco Faulí 2020-03-04 11:41:52 UTC
(In reply to Buovjaga from comment #18)
> Let's change to fixed. Separate report for the misbehaving menu would be nice

ok, setting to VERIFIED based on comment 17. I'll create a follow-up bug