Bug 131120 - LibreOffice fails to display fonts' dropdownlist (gtk3)
Summary: LibreOffice fails to display fonts' dropdownlist (gtk3)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0
Keywords: bibisected, bisected, regression
: 128833 (view as bug list)
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2020-03-04 11:45 UTC by Xisco Faulí
Modified: 2020-06-17 11:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-03-04 11:45:36 UTC
Steps to reproduce:
1. Go to Tools - Options - Fonts or Format - Watermark
2. Click on the fonts' dropdownlist

-> The list is not displayed. See attachment 157476 [details] from bug 130143 for a screencast

Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: c57d6d39c80844c9d4c6bfed85cc151e52a67b34
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-03-04 11:46:42 UTC
Regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2019-09-17 12:50:05 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2019-09-20 21:20:51 +0200
commit	94d6fa11d086187b82adf9aa596e0f334827e095 (patch)
tree	4a44af903b2572efe89ae5e8aa67bb092644e038
parent	3c84b18f4f0fe4058de60b1c62149275ed858b79 (diff)
weld OfaTreeOptionsDialog

Bisected with: bibisect-linux64-6.4

Adding Cc: to Caolán McNamara
Comment 2 Caolán McNamara 2020-03-04 12:06:58 UTC
I wasn't able to reproduce the initial report of this under Fedora 31 even with a few thousand fonts installed. What distro can it be seen under, and what screen resolution, and maybe I can get it to happen in VirtualBox
Comment 3 Caolán McNamara 2020-04-13 19:37:18 UTC
we keep running into problems like this with overly-tall combobox menus in native GtkComboBoxes, lets try building a replacement out of a GtkEntry, GtkToggleButton and a GtkTreeView for the menu
Comment 4 Commit Notification 2020-04-16 18:29:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/bc0e0f633b05c4f91b6695488fc9e5c127507ba5

tdf#131120 use a replacement for GtkComboBox

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2020-04-16 18:34:30 UTC
hopefully that sorts out this issue, probably with other side effects, so let the dust settle in master for a while
Comment 6 Xisco Faulí 2020-04-21 16:14:23 UTC
(In reply to Caolán McNamara from comment #5)
> hopefully that sorts out this issue, probably with other side effects, so
> let the dust settle in master for a while

Hi Caolán,
it works like a charm in

Version: 7.0.0.0.alpha0+
Build ID: 850b8de31c5be5127eac16a4f5cc18c26a582e53
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

thanks for fixing this issue.
I don't remember anyone else reporting this particular issue so let's have in master only.
Comment 7 Kevin Suo 2020-06-17 11:15:45 UTC
*** Bug 128833 has been marked as a duplicate of this bug. ***