Download it now!
Bug 135568 - Crash when opening the 3D View option for a chart.
Summary: Crash when opening the 3D View option for a chart.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.1 target:7.1.0
Keywords: bibisected, bisected, haveBacktrace, needUITest, regression
Depends on:
Blocks:
 
Reported: 2020-08-08 21:19 UTC by Felipe Viggiano
Modified: 2020-08-11 08:23 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["GtkInstanceBuilder::weld_combo_box"]


Attachments
ScreenCast (1.22 MB, video/x-matroska)
2020-08-09 05:47 UTC, sawakaze
Details
bt with debug symbols (8.02 KB, text/plain)
2020-08-09 09:27 UTC, Julien Nabet
Details
test patch (2.46 KB, text/plain)
2020-08-10 13:08 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felipe Viggiano 2020-08-08 21:19:26 UTC
LibreOffice Calc is crasing when trying to open the 3d View dialog for a chart.

Steps to reproduce:

1. Create a new spreadsheet with Calc.
2. Insert some data to create a chart (doesn't need much, just one column and a few rows it's required).
3. Create a chart from the data and select 3D Look in the Chart Type dialog.
4. After the chart was created, go to the Edit mode by double clicking on the chart.
5. Right-click on the chart and select 3d View.

Expected result:
The 3D View dialog should be available.

Actual result:
The LibreOffice Calc crashes.
Comment 1 sawakaze 2020-08-09 05:47:55 UTC
Created attachment 164059 [details]
ScreenCast

I reporoduced this bug

Version: 7.1.0.0.alpha0+
Build ID: <buildversion>
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: ja-JP (ja_JP.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-08-06_17:35:14
Calc: threaded

screeencast is video about this bug
Comment 2 Julien Nabet 2020-08-09 09:27:40 UTC
Created attachment 164064 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 3 Julien Nabet 2020-08-09 09:34:29 UTC
I don't reproduce this with gen or kf5 renderings, only with gtk3.

Sawakaze: I noticed you assigned yourself, you want to work on fixing the bug or was it just an error?
Comment 4 sawakaze 2020-08-09 10:06:01 UTC
> Sawakaze: I noticed you assigned yourself, you want to work on fixing the bug or was > it just an error?

I seem an error, Sorry I might mistake bugzilla operation.
Comment 5 Julien Nabet 2020-08-09 10:10:34 UTC
(In reply to sawakaze from comment #4)
> > Sawakaze: I noticed you assigned yourself, you want to work on fixing the bug or was > it just an error?
> 
> I seem an error, Sorry I might mistake bugzilla operation.

No pb, I unassigned yourself.
Comment 6 Xisco Faulí 2020-08-10 11:56:22 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=bc0e0f633b05c4f91b6695488fc9e5c127507ba5

author	Caolán McNamara <caolanm@redhat.com>	2020-04-09 11:41:00 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2020-04-16 20:28:24 +0200
commit	bc0e0f633b05c4f91b6695488fc9e5c127507ba5 (patch)
tree	cca168c8aced9207ffa877693b856440764de341
parent	de1dadd591862e38242cc2de7a4a658a9a8b67ac (diff)
tdf#131120 use a replacement for GtkComboBox

Bisected with: bibisect-linux64-7.0

Adding Cc: to Caolán McNamara
Comment 7 Julien Nabet 2020-08-10 13:08:36 UTC
Created attachment 164115 [details]
test patch

I gave a try to this naive patch and indeed didn't get a crash but I noticed these on console:
(soffice:160696): Gtk-CRITICAL **: 15:06:16.833: gtk_cell_layout_add_attribute: assertion 'column >= 0' failed

(soffice:160696): Gtk-CRITICAL **: 15:06:16.833: gtk_cell_layout_add_attribute: assertion 'column >= 0' failed
free(): invalid pointer

So not sure if it's the right way.
Comment 8 Julien Nabet 2020-08-10 13:09:25 UTC
Comment on attachment 164115 [details]
test patch

Definitely the wrong way since I just noticed that in fact LO had frozen.
Comment 9 Commit Notification 2020-08-10 15:40:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/e61e4ec53ad54a17a1726220f1dbe12ee3307e7b

tdf#135568 an unexpected model for a GtkComboBox

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-08-10 18:18:31 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/386add495b3d8b7816a521bb28c5f48fc243bc99

tdf#135568 an unexpected model for a GtkComboBox

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2020-08-11 08:23:07 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 0de191e1d201d691c2196cf1aef412a98affb66f
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!