Download it now!
Bug 130200 - Writer crashes on inserting a subdocument to a master document using the “enter” key.
Summary: Writer crashes on inserting a subdocument to a master document using the “ent...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Master-Doc
  Show dependency treegraph
 
Reported: 2020-01-25 21:18 UTC by Thomas Leigh
Modified: 2020-05-02 16:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Leigh 2020-01-25 21:18:10 UTC
Description:
I use LibreOffice dialogs for open/save. I discovered that Writer crashes each and every time if I use the “enter” keyboard button to insert a file as a subdocument.

Interestingly, if I perform the same operation, but instead of pressing the “enter” key I click the “Insert” button, it works completely fine.

Steps to Reproduce:
1. I’ve just created a new master document, saved it.
2. From the Navigator I’ve clicked *Insert › File*, single-click an .odt file to insert and press the *enter* button from the keyboard.

Actual Results:
Writer crashed. A new window (“LibreOffice 6.3 Document Recovery”) showed up with a message beginning with “Due to an error, LibreOffice crashed.”

Expected Results:
The chosen file should be inserted as a subdocument.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter 2020-01-26 06:04:44 UTC
Thomas, thank you for reporting the crash. I can't reproduce it with

Version: 6.3.4.2 (x64)
Build-ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

It might be related to bug 128544. Could you please try to reproduce it again and add the link to the crash report? Thank you.
Comment 2 Thomas Leigh 2020-01-26 18:30:30 UTC
(In reply to Dieter Praas from comment #1)
> Thomas, thank you for reporting the crash. I can't reproduce it with
> 
> Version: 6.3.4.2 (x64)
> Build-ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
> CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
> Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
> Calc: threaded
> 
> It might be related to bug 128544. Could you please try to reproduce it
> again and add the link to the crash report? Thank you.

Could You please tell how to obtain such a crash report link? Writer ends up with showing me only windows titled as “Document Recovery”, there is no other window or message about any crash, although it takes place.
Comment 3 Dieter 2020-01-27 07:11:04 UTC
Please check Tools => Options => LibreOffice => General => Help Improve Libre Office. There's a checkbox "Send crash reports". Perhaps you have disabled it.
Comment 4 Thomas Leigh 2020-01-27 12:19:03 UTC
(In reply to Dieter Praas from comment #3)
> Please check Tools => Options => LibreOffice => General => Help Improve
> Libre Office. There's a checkbox "Send crash reports". Perhaps you have
> disabled it.

Unfortunately, within “Help Improve Libre Office” I have only one checkbox: “Collect usage data and send it to the Document Foundation”. I’ve checked it but still I don’t get any window with a link to the crash report.
Comment 5 Dieter 2020-01-27 12:45:41 UTC
(In reply to Thomas Leigh from comment #4)
> Unfortunately, within “Help Improve Libre Office” I have only one checkbox:
> “Collect usage data and send it to the Document Foundation”. I’ve checked it
> but still I don’t get any window with a link to the crash report.

Yes, that's correct for LO 6.3 as I could see now. Don't know the reason, why window doesn't appear. Sorry.
Comment 6 Xisco Faulí 2020-01-28 11:11:37 UTC
I can't reproduce it in

Versión: 6.4.0.3 (x86)
Id. de compilación: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
Subprocs. CPU: 2; SO: Windows 6.1 Service Pack 1 Build 7601; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

@Thomas, does it happen with any .odt file or with a specific one ?
Comment 7 Thomas Leigh 2020-01-30 02:36:09 UTC
(In reply to Xisco Faulí from comment #6)

> @Thomas, does it happen with any .odt file or with a specific one ?

It happens with any file, given that I use the enter key or double-click the chosen file for it to be loaded (instead of clicking the button after selecting the file).
Comment 8 QA Administrators 2020-01-30 03:38:17 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2020-05-02 16:10:11 UTC
Does it happen in LibreOffice's Safe Mode as well? Help - Restart in safe mode and then Continue in safe mode.

See also https://wiki.documentfoundation.org/UserProfile

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 10 Thomas Leigh 2020-05-02 16:19:58 UTC
Unfortunately I’ve reinstalled the OS in the meantime and now this bug is gone...