Download it now!
Bug 130394 - FILEOPEN: LWP: General input/output error
Summary: FILEOPEN: LWP: General input/output error
Status: RESOLVED DUPLICATE of bug 41702
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-03 15:25 UTC by Xisco Faulí
Modified: 2020-02-05 15:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-02-03 15:25:50 UTC
Steps to reproduce:
1. Open attachment 52242 [details] from bug 41702

-> General input/output error

Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: 447e4209fa16e765d9cba9f1c80bf10e8901204c
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-02-03 15:27:11 UTC
regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=18d636063fd7be165e7888af49372a6e2b851776

author	Caolán McNamara <caolanm@redhat.com>	2017-06-19 09:46:31 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2017-06-19 13:32:01 +0200
commit	18d636063fd7be165e7888af49372a6e2b851776 (patch)
tree	7e272d9a34aa715af3b19faef384d2f3b64e229a
parent	0df3de34ad775d6d3c49036c03c3f6dad7141536 (diff)
ofz: use OString instead of bare char*

Bisected with: bibisect-linux64-6.5

Adding Cc: to Caolán McNamara
Comment 2 Caolán McNamara 2020-02-03 20:18:44 UTC
In this case the regression of 18d636063fd7be165e7888af49372a6e2b851776 was fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=efbd217afc52390138195e06e96ef9c8f10bf37b

But, like the example in bug 123815, this example is of file format version 10 and the filter only handles file format > 11 

(i.e. https://cgit.freedesktop.org/libreoffice/core/tree/lotuswordpro/source/filter/lwp9reader.cxx#n87 where it says m_nFileRevision>=0x000B)

its just that at one stage the filter didn't report that the import failed (giving bug 41702 that the document opened empty) and now it does so in that sense this is just a duplicate of bug 41702 that the version isn't supported

*** This bug has been marked as a duplicate of bug 41702 ***
Comment 3 Xisco Faulí 2020-02-05 15:38:04 UTC
oh I see, great explanation. will take it into account for the future