Download it now!
Bug 130412 - Print a calc document is hanging in LO 6.4 (print ranges) (gen)
Summary: Print a calc document is hanging in LO 6.4 (print ranges) (gen)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 130285 130381 (view as bug list)
Depends on:
Blocks: regressions-printable-page-borders
  Show dependency treegraph
 
Reported: 2020-02-04 06:31 UTC by Keith B
Modified: 2020-02-13 19:34 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Logging sheet for tracking daily results (16.84 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-02-04 06:36 UTC, Keith B
Details
Logging sheet for tracking daily results (protection removed) (16.81 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-02-04 06:55 UTC, Keith B
Details
screenshot (47.04 KB, image/png)
2020-02-08 13:11 UTC, Oliver Brinzing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Keith B 2020-02-04 06:31:05 UTC
Description:
I have a calc spreadsheet that I have been using for awhile now. It printed fine using versions of LO up to release 6.3.4.2 (x64). Once I installed LO 6.4 this file will hang with the dialog "Printing Page 20 of 20" (there are only two pages in this document). Closing the spreadsheet will cause the printer to move a blank sheet of paper to the out bin.
I do have other calc document that seem to print fine in all versions of LO.

Steps to Reproduce:
1.Load document
2.Print one (or two) page(s)
3.

Actual Results:
Printing dialog shows "Printing Page 10 of 10" (or "Printing Page 20 of 20)

Expected Results:
Page printed out on printer.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.4.0.3 (x64)
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

I will supply the actual calc spreadsheet that is exhibiting the issue.
Comment 1 Keith B 2020-02-04 06:36:02 UTC
Created attachment 157628 [details]
Logging sheet for tracking daily results

This calc spreadsheet prints fine in LO versions up to 6.3.4.2
This cals spreadsheet print hangs in LO version 6.4.0.3
Comment 2 Keith B 2020-02-04 06:55:01 UTC
Created attachment 157629 [details]
Logging sheet for tracking daily results (protection removed)
Comment 3 raal 2020-02-04 07:42:02 UTC
I cannot confirm with Verze: 6.4.0.3
ID sestavení: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
Vlákna CPU: 4; OS: Linux 4.15; Vykreslování UI: výchozí; VCL: gtk3
Comment 4 Keith B 2020-02-04 16:51:49 UTC
After further testing, I find that this is accuring when I have multiple Print Ranges defined (i.e. a print range for each page).
In the Print Range dialog:
with "User Defined" set to "$A$1:$R$26,$A$27:$R$52" will no print.
with "Selection" set to "$A$1:$R$52" will print
Comment 5 Oliver Brinzing 2020-02-05 11:08:19 UTC
reproducible with:

Version: 6.4.0.3 (x64)
Build-ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU-Threads: 4; BS: Windows 10.0 Build 18363; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: 

steps to reproduce:
- open attached spreadsheet
- print raanges are: $A$1:$S$26;$A$27:$S$53
- open print dialog, two pages are shown in preview
- print
-> dialog shows "Page 20 from 20" and freezes

but *not* reproducible with:

Version: 6.3.4.2 (x64)
Build-ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc:
Comment 6 Oliver Brinzing 2020-02-05 11:13:26 UTC
just noticed: 
after opening attached spreadsheet:
-> CPU stuck at high load.
this is Bug 130381 - Calc: max. cpu load when defining 2 print ranges
Comment 7 Xisco Faulí 2020-02-07 19:38:40 UTC
*** Bug 130381 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2020-02-07 19:39:22 UTC
*** Bug 130285 has been marked as a duplicate of this bug. ***
Comment 9 Xisco Faulí 2020-02-07 19:41:29 UTC
(In reply to Oliver Brinzing from comment #6)
> just noticed: 
> after opening attached spreadsheet:
> -> CPU stuck at high load.
> this is Bug 130381 - Calc: max. cpu load when defining 2 print ranges

I can't reproduce it in

Versión: 6.4.0.3 (x86)
Id. de compilación: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
Subprocs. CPU: 2; SO: Windows 6.1 Service Pack 1 Build 7601; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded
Comment 10 Xisco Faulí 2020-02-08 11:36:02 UTC
I can't reproduce it in

Version: 6.5.0.0.alpha0+
Build ID: 7de3b4bc881671692d15cfc93a4c887ed77b6c64
CPU threads: 8; OS: Mac OS X 10.13.6; UI render: default; VCL: osx; 
Locale: en-US (en_ES.UTF-8); UI-Language: en-US
Calc: threaded

I see some people reported the problem using a empty document.
Are these the steps to reproduce it ?
1. Open Calc
2. Select a range of cells
3. Format - Print ranges - Define
4. Select another range of cells
5. Format - print ranges - Defines

- at this point, it hangs ?
Comment 11 Oliver Brinzing 2020-02-08 13:11:14 UTC
(In reply to Xisco Faulí from comment #10)

> I see some people reported the problem using a empty document.
> Are these the steps to reproduce it ?
> 1. Open Calc
> 2. Select a range of cells
> 3. Format - Print ranges - Define
> 4. Select another range of cells
> 5. Format - print ranges - Defines
> - at this point, it hangs ?

Yes, after adding the second print range CPU stuck at high load (~25%).
If i press (F2) to edit a cell, cursors flickers.
If i start printing, print hangs ...

attaching a screenshot ...
Comment 12 Oliver Brinzing 2020-02-08 13:11:52 UTC
Created attachment 157743 [details]
screenshot
Comment 13 Noel Grandin 2020-02-09 20:10:15 UTC
I'm fairly sure this has just been fixed by Miklos Vajna with commit e7e01efc56f7061d0a2e5142b4bae84dd403cc50
Comment 14 Xisco Faulí 2020-02-10 11:53:05 UTC
(In reply to Noel Grandin from comment #13)
> I'm fairly sure this has just been fixed by Miklos Vajna with commit
> e7e01efc56f7061d0a2e5142b4bae84dd403cc50

it seems not, I can reproduce it in

Version: 7.0.0.0.alpha0+
Build ID: 4188c7e2132ec3f1c3e879c179e92ff75c86d24f
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

I'll bisect it...
Comment 15 Xisco Faulí 2020-02-10 11:55:21 UTC
I can't reproduce it with gtk3
Comment 16 Xisco Faulí 2020-02-10 11:58:17 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=caeb7b141280a65e60525f11a7e6514b76e12e11

author	Ilhan Yesil <ilhanyesil@gmx.de>	2019-07-10 15:41:27 +0200
committer	Eike Rathke <erack@redhat.com>	2019-10-01 22:13:09 +0200
commit	caeb7b141280a65e60525f11a7e6514b76e12e11 (patch)
tree	4f7b1f0db28fc7229b89a7f198eb87596135c4d8
parent	32f28dfa4c1de2b92664a5c0c3eca4fffecc0b28 (diff)
tdf#124983 In calc make printable page borders also initially visible

Bisected with: bibisect-linux64-6.4

Adding Cc: to Ilhan Yesil
Comment 17 Xisco Faulí 2020-02-10 13:22:44 UTC
(In reply to Oliver Brinzing from comment #11)
> Yes, after adding the second print range CPU stuck at high load (~25%).
> If i press (F2) to edit a cell, cursors flickers.

Flickering problem reported in bug 130556
Comment 18 Xisco Faulí 2020-02-13 19:34:50 UTC
Problematic commit reverted in https://git.libreoffice.org/core/commit/c4281cb41e6b76cabd5fe42fc707877e864dfb82
Closing as RESOLVED FIXED